Topografia Comandi

Posizione del menu a tendina.

Per il caricamento di Menu Topografia accedere al menu 'I&S CAD' e cliccare su ' Menu Topografia':


Gestione rilievi

Posizione menu a tendina

Toolbar

Questa toolbar contiene i comandi per:

· Trasferimento dati rilevati da strumento topografico a PC.
· Acquisizione dei dati di campagna da files di testo generati da software in dotazione agli strumenti topografici come stazioni totali e GPS.
· Calcolo dei rilievi e praparazione dei libretti, compreso quello di Pregeo.
· Materializzazione dei punti direttamente nell'editor di AutoCAD.
· Preparazione dei file da trasferire agli strumenti per il tracciamento.


Driver di acquisizione unificato

Nome Comando al Prompt: UniDrv

Questo comando permette alternativamente di :
a) Scaricare i dati da stazioni totali direttamente per le strumentazioni che supportano la trasmissione attiva, cioè lo strumento spedisce i dati ed il computer li riceve.
b) Se lo strumento non permette l'accesso diretto alla memoria, permette di trasformare i file scaricati con il software in dotazione allo strumento nel formato adatto a CADPak <nomefile>.MYT (libretto di campagna con coordinate polari) che si devono poi elaborare con il comando NewPolig.

Nel caso a) in cui lo strumento è in grado di inviare attivamente i dati si deve procedere nel seguente modo.
1. Premere il pulsante Porta per impostare i parametri della porta seriale attaverso la quale lo strumento invia attivamente i dati al computer.
2. Premere il pulsante NomeFile per fornire il nome di un fileda generare ex novo (ricordarsi di selezionare il tipo di strumento corretto) in cui scaricare i dati provenienti dallo strumento.
3. Premere Ricevi (che si trasforma in Stop) per mettere il programma in attesa dei dati dallo strumento.
4. A questo punto spedire i dati dallo strumento (vedi manuale dello strumento) e nella finestra di dialogo si devono veder scorrere i dati in via di ricezione.
5. Quando la trasmissione è terminata premere il pulsante Stop.
6. Premere il pulsante File Grezzo per vedere i dati scaricati. (Facoltativo)
7. Premere il pulante Converti! per convertire il libretto grezzo nel formato di CADPak (Estensione <nomefile>.myt).

Nel caso b) invece lo strumento non dispone della possibilità di spedire i dati al PC ma è dotato di un software che permette di prelevare i dati e di generare sul computer un file di testo contenente i dati.
I questo caso la procedura è la seguente:
2. Premere il pulsante NomeFile per selezionare il nome di un file esistente generato dal programma si scarico dati dello strumento, ricordarsi di selezionare lo strumento corretto (vedi figura).
6. Premere il pulsante File Grezzo per vedere i dati scaricati. (Facoltativo)
7. Premere il pulante Converti! per convertire il libretto grezzo nel formato di CADPak (Estensione <nomefile>.myt).

Qualsiasi sia la procedura al termine si deve avere un file con estensione myt contenente i dati di rilievo, simile al seguente:

TOLLE   0.05  0.05  0.05
TOLLT   0.05  0.05  0.05
PUNTI   3
1000   101       15      1.518    125.3320  101.4997     31.836  1.530
1000   102       15      1.518    107.2360   99.1235     14.615  1.530
1000   103       15      1.518      3.1471   99.0781      9.646  1.530
1000   104       15      1.518    361.4932  100.2724     23.166  1.530
1000   105       15      1.518    350.1567  100.3656     37.719  1.530
(... punti rilevati ...)
1000   3000     101      1.530    331.1818   99.2467    397.853  1.530

3000   1000      02      1.575    131.1833  100.7673    397.843  1.530
3000   3001      02      0.000    158.4230  100.0000   1000.000  0.000
3000   3002      02      0.000    158.2560  100.0000   1000.000  0.000
3000   3003      02      0.000    296.7433  100.0000   1000.000  0.000
3000   3004      02      0.000    240.4866  100.0000   1000.000  0.000
(... punti rilevati ...)
3000   9000     101      0.000     31.3091  100.0000    817.708  0.000

9000   3000     100      0.000    231.3091  100.0000    817.708  0.000
9000   9001     100      0.000    128.4411  100.0000     30.872  0.000
(... puntirilevati ....)
FINE
PFISS    1000  0.00   0.00   0.00
ORIEN    1000  0.00
POLIG
 1000 3000 9000
FINE

Si possono trovare alcuni esempi di files *. myt nella cartella

C:\Programmi\IeS\CADPak\Esempi\Topografia\RilieviTopografici\

NOTA IMPORTANTE:
CADPak contiene già una serie di convertitori per vari strumenti presenti sul mercato, tuttavia può capitare che qualche strumento non sia gestito. I&S possiede un certo numero di convertitori aggiuntivi che possono essere richiesti dall'utente, ed è in grado anche di fornire dei nuovi convertitori che si rendessero necessari, l'utente in questo caso deve reperire presso il produttore dello strumento le specifiche tecniche ed alcuni file di esempio contenenti almeno due di stazioni. Per maggiori informazioni contattare il servizio di assistenza tecnica al numero 0461.402122 oppure inviare un e-mail a ltsupport@ies.it.


Visualizza/Modifica dati - Medit Editor

Visualizza/Modifica dati - Medit Editor Editor

Nome Comando al Prompt: Medit

Questo comando permette la creazione da zero e/o la modifica dei libretti di campagna nel formato di CADPak (<nomefile>.myt), ed è stato pensato principalmente per gli utenti che hanno strumenti privi di registratore di dati; permette di generare, visualizzare e modificare i libretti di campagna.

La finalità di questo comando è quella di generare un file myt (libretto di camoagna) da elaborare con il comando NewPolig; il libretto di campagna contiene i dati riulevati ma anche le istruzioni su come elaborare il rilievo.
Queste istruzioni sono allocate in coda al file e possono essere diverse da rilievo a rilievo a seconda del meotodo di orientamente come spiegato quì di seguito.

Il libretto di campagna (<nomewfile>.myt ), che dovrà essere elaborato con il comando NewPolig (poco più avanti in questo manuale), contiene dati, istruzioni e può essere strutturato in tre possibili formati:

Formato 1 – Azimut, Distanza Orizzontale, Dislivello strumentale (centro strumento - centro prisma)
Estratto del file myt
....
PUNTI       1
100   101  21   1.460    14.6640   10.248   0.8480     1.460
100   102  20   1.460    18.7428   12.519   0.7900     1.460
....
St    Pt   Cod    Hs     Az        Do     Disl.Strum.    Hp

Formato 2 – Azimut, Distanza Orizzontale, Dislivello topografico
Estratto del file myt
....
PUNTI       2
100   101  21   1.460    14.6640   10.248   0.8480      1.460
100   102  20   1.460    18.7428   12.519   0.7900      1.460
....
St    Pt   Cd    Hs      Az        Do      Disl.top.      Hp

Formato 3 – Azimut, Distanza Inclinata, Zenit
Estratto del file myt
....
PUNTI        3
100   101   10    1.51   13.5555   104.1375   91.2900   2.000
100   102    3    1.51   16.9535   104.2130   90.7399   2.000
....
St    Pt   Cod     Hs    Az         Zenit     Dist.Inc.   Hp

Nella scheda Punti contenuta nella finestra di dialogo di questo comando vi è la possibilità di scegliere il tipo di formato; la scelta, nel caso di inserimento manuale dei dati, deve avvenire prima dell' inserimento dei dati.
Se questo comando viene utilizzato per visualizzare un file esistente il tipo di formato viene riconosciuto automaticamente in base alla seguente riga che è presente nel file myt:

PUNTI n

Dove n può assumere i valori 1, 2, 3 a seconda del tipo di formato.

I pulsanti contenuti in questa maschera sono:
Nuovo - Azzera i campi della maschera e consente di iniziare un nuovo libretto
Apri - Comando che permette di aprire libretti esistenti
Ultimo File - Apre l'ultimo libretto utilizzato o prodotto con il comando UniDrv
Salva - Salva il libretto correntemente aperto con il nome attuale
Salva come - Permette di salvare il libretto con un nuovo nome
Vista file - Apre il libretto corrente con il programma blocco note di Windows

oltre ai pulsanti appena descritti vi sono delle schede:
Punti - permette la visualizzazione e/o modificare delle letture
Poligonali - permette la definizione delle poligonali del rilievo
Tolleranze - permette la definizione delle tolleranze per i calcoli
Orientamento rilievo - permette di definire l'orientamento del rilievo
Punti fissi - permette di definire dei punti di coordinate fisse nel rilievo

Scheda Punti
Questa scheda contiene i comandi per aggiungere e/o modificare la lista delle letture sui punti rilevati;
Nella parte in basso vi è la tabella contenente tutte le letture, nella parte in alto vi sono le caselle di testo che contengono i dati relativi alla lettura selezionata nella tabella sottostante.
Il pulsante Aggiungi aggiunge una nuova lettura utilizzando i dati contenuti nelle caselle di testo.
Il pulsante Rimuovi elimina la lettura correntemente selezionata.
Il pulsante Memorizza aggiorna la lettura selezionata con i valori contenuti nelle caselle di testo.
Il pulsante Aggiungi un libretto permette di selezionare un'altro file myt ed aggiungere in coda al libretto presente le letture in esso contenute.
La lista a discesa Formato dei dati serve per selezionare il formato dei dati; questa scelta va fatta prima di iniziare la digitazione dei dati.

Scheda Poligonali
In questa scheda si definiscono le poligonali dei rilievo.
Aggiungi riga serve per aggiungere una riga, cioè un poligonale.
Aggiunti colonna serve per aggiungere una stazione.

Scheda Tolleranze
Questa scheda permette di fissare i parametri di tolleranze espressi in metri per il controllo delle letture reciproche tra le stazioni ed anche per definire gli errori massimi di chiusura.
Quando poi il comando NewPolig (vedi oltre) effettuerà l'elaborazione del libretto utilizzerà questi valori per il calcoli.

Scheda Orientamento rilievo
Questa scheda contiene gli strumenti per orientare il rilievo.

I modi per orientare un rilievo sono 3:

1) Fissare le coordinate della prima stazione ed un angolo di correzzione da applicare a tutti i valori azimutali letti dalla prima stazione; di conseguenza in fase di calcolo con il comando NewPolig tutto il rilievo verrà ruotato e traslato.
Si deve utilizzare l'opzione Coordinate+ correzione, scrivere le coordinate da imporre alla stazione e poi inserire l'angolo di correzione.
Alla fine in coda al file myt le righe sono come le seguenti:
6000      245     17   1.600   189.4540   105.1050     47.560    1.460
6000      246     17   1.600   186.8035   104.9615     53.383    1.460
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE
PFISS           1000   0.0    0.0     0.0
Significato --> Prima stazione     Est    Nord  Quota
ORIENTAMENTO    1000   -12.326
Significato --> Prima stazione     Correzzione azimutale da applicare a tutte le letture fatte dalla prima stazione
POLIGONALE
1000 2000 3000 4000 5000 6000
FINE

2) Fare stazione su di un punto di coordinate note PN1 e poi collimare ad altro punto di coordinate note PN2.
Si deve utilizzare l'opzione Coordinate+ correzione e poi premere il pulsante in corrispondenza di Corr.angolare da applicare in modo da far apparire la seguente maschera dove si devono inserire le coordinate dei due punti noti ed in basso scegliere la lettura dal pu to PN1 al PN2 come schematizzato nella figura.

6000      245     17   1.600   189.4540   105.1050     47.560    1.460
6000      246     17   1.600   186.8035   104.9615     53.383    1.460
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE
PFISS           100   0.0    0.0     0.0
Significato --> Prima stazione     Est    Nord  Quota
ORIENTAMENTO    100   82.5040
Significato --> Prima stazione     Correzzione azimutale da applicare a tutte le letture fatte dalla prima stazione
POLIGONALE
100 200 300 400 5000 6000
FINE

3) Battere due punti di coordinate note dalla prima stazione del rilievo.
Si deve utilizzare l'opzione Battute su punti noti, selezionare il nome dei punti noti con gli appositi pulsanti e poi inserire le relative coordinate.
400    460    25    1.42    30.6660     93.1880     32.5700     1.3200
400    461    25    1.42    35.2135     96.6294     71.2800     1.3200
FINE
PNOTO   100  125  -82.38972 -76.25983 0.00000
Significato --> Prima stazione      Punto noto    Est    Nord    Quota
PNOTO   100  126  -73.51726 -76.70539 0.00000
Significato --> Prima stazione      Punto noto    Est    Nord    Quota
POLIG
100 200 300 400
FINE

Scheda Punti Fissi
Questa scheda serve per inserire dei punti fissi.
I punti fissi possono esser costituiti da:

1) La prima stazione del rilievo
2) L'ultima stazione della poligonale (o delle poligonali)


Poligonazione

Nome Comando al Prompt: NewPolig

Questo comando esegue il calcolo delle poligonali effettuando, laddove ne esistano i requisiti, la compensazione.
Le tipologie di poligonale gestite sono:

· Aperta non vincolata
· Chiusa
· Aperta e vincolata

Per utilizzare il comando è necessario avere il libretto (si tratta di un file di testo), contenente i dati rilevati in campagna.
Il libretto di campagna è un file di testo, con estensione *.myt, che si può ottenere trasformando il file di scarico proveniente dalla stazione totale utilizzando il comando UniDrv (vedi sopra), che trasforma i dati dei più diffusi strumenti sul mercato.
Nel caso in cui lo strumento o il formato del file di scarico non rientrasse nella lista è possibile richiedere dei convertitori specifici rivolgendosi telefonicamente ai nostri tecnici oppure via e-mail all'indirizzo ltsupport@ies.it inviando in allegato anche un esempio di file scaricato contenente un rilievo con almeno due stazioni.

Il comando visualizza la seguente finestra di dialogo:

Il formato del libretto di campagna è il consueto formato *.myt come mostrato quì di seguito:

NEWMYT   à   Indica a CADPak l'inizio dei dati
TITOL Rilievo di prova per Topografia   à   Indica a CADPak il titolo del rilievo
TOLLE           0.05 0.05   à   Tolleranze sulle letture reciproche per distanza e dislivello
TOLLT           0.05 0.05 0.02   à   Tolleranze sulla chiusura Planimetrico, Altimetrico ,Angoli
PUNTI           3   à   Linea che indica a CADPak l'inizio dei punti battuti
1000        1      5   1.560     5.6290    96.7275     62.036    1.460
1000        2      5   1.560    10.2170    96.7255     60.581    1.460
. . .
Staz      Punto   Cod   Hs      Azimut     Zenit     Dist. Incl.   Hp
. . .
6000      236      9   1.600    32.1775    91.3440     22.304     1.46
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE   à   Linea che indica a CADPak la fine dei punti battuti
PFISS           1000 0.0 0.0 0.0   à   Coordinate della prima stazione del rilievo – Pfiss Staz x y z
ORIEN           1000 0.0   à   Orientamento della prima stazione – Orien Staz Angolo
TRASL    0.00    0.00   516.326   à   Linea che indica a CADPak di traslare il rilievo di Dx, Dy, Dz
POLIG   à   Indica a CADPak che segue una definizione di una poligonale
1000  2000  3000  4000  5000  6000   à   Stazioni che compongono la poligonale
FINE   à   Indica a CADPak che la fine dei dati
Il formato del file con i codici (chiamato anche tabelle dei codici) descrittivi è il seguente (le righe che iniziano con il carattere punto e virgola [ ; ] sono trascurate da CADPak).
CADPak inizia a leggere i codici contenuti nella tabella dei codici dalla riga contenente la parola CODICI e termina con la riga contenente la parola parola FINE.
Il file è modificabile a piacere dall'utente che potrà personalizzarlo secondo le proprie esigenze

CODICI
;-----------------------------------------------
;Codici con descrizione geometrica
;-----------------------------------------------
 0     Stazione
 1     Base
 2     Sommità
 3     Ciglio
 4     Spigolo
 5     Bordo
 6     Allineamento
 7     Vertice
 8     Incrocio
 9     Inizio
 10    Fine
 11    Estremità
 12    Punto
;-----------------------------------------------
;Morfologia terreno
;-----------------------------------------------
 40    Scarpata
 41    Impluvio
 42    Conpluvio
 43    Displuvio
 44    Rampa di accesso
 45    Sommità
;-----------------------------------------------
;Elementi
;-----------------------------------------------
 50    Fiume
 51    Sentiero
 52    Ferrovia
 53    Massicciata
 54    Muretto
 55    Recinzione
 56    Argine destro
 57    Argine sinistro
 56    Asse fluviale
 58    Canale irriguo
59   Chiodo miniato
 60    Linea elettrica
 61    Linea telefonica
 62    Traliccio
 63    Palo di sostegno
FINE

Il comando NewPolig gestisce anche i codici combinati come ad esempio
9 + 51 significa "Inizio Sentiero".
Per utilizzare i codici combinati si deve già in fase di rilievo in campagna utilizzare la combinazione, cioè quando è il momento di inserire il codice descrittivo nello strumento si inserisce direttamente la combinazione 9.51 (che CADPak poi riconoscerà come "Inizio Sentiero" visto che nella tabella 9= Inizio 51=Sentiero) come nell'esempio appena menzionato.
Alcuni strumenti non danno la possibilità di inserire il carattere punto nel codice e pertanto nel caso dell'esempio precedente si dovrebbe utilizzare 0951 dove 09= Inizio 51=sentiero.
Per indicare a CADPak quale tipo di codifica si è utilizzata, cioè per scegliere il tipo di codifica tra "9.51" e "0951" è necessario premere il pulsante Tipo Codifica nella finestra di dialogo visualizzata da questo comando.

Quando si hanno a disposizione sia il file con i dati ed il file con i codici si può utilizzare il pulsante "Calcola" per avviare la procedura di calcolo.
Definizione della struttura delle poligonali del rilievo
Nella fase di calcolo il comando NewPolig apre il libretto di campagna (formato *.myt mostrato nelle pagine precedenti) leggendo le letture ai punti ed anche le istruzioni in esso presenti; ad esempio se trova la parola POLIG si aspetta la dichiarazione di una poligonale e che la riga successiva contenga l'elenco delle stazioni contenute nella poligonale.

POLIG
100 200 300 400 500 600 100

In questo caso le due righe (del file) indicano a CADPak che il rilievo contiene una poligonale chiusa (l'ultima stazione della poligonale coincide con la prima) composta dalle stazioni descritte.
Se una poligonale avesse una poligonale collegata la definizione sarebbe

POLIG
100 200 300 400 500 100
POLIG
200 700 800 900

Se le poligonali sono collegate, le poligonali "figlie" devono avere la prima stazione coincidente con una qualsiasi stazione della poligonale "madre". Nel figura la poligonale "madre" sarebbe quella definita dalle stazioni 100 200 300 400 500 600.
Imposizione dell'origine del rilievo
Imporre l'origine del rilievo significa fissare le coordinate della prima stazione del rilievo che si fa aggiungendo e/o modificando la seguente riga nel file dei dati *.myt.
PFISS <prima stazione> <X stazione> <Y stazione> <Z stazione>
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
dove la seguente riga
PFISS  100   123.326    236.124     345.802
È composta da
100   = Nome della prima stazione del rilievo
123.326   = coordinata EST della prima stazione del rilievo
236.124   = coordinata NORD della prima stazione del rilievo
345.802   = coordinata QUOTA della prima stazione del rilievo
L'origine del rilievo può essere anche imposta attraverso un'apertura a terra, con il metodo spiegato poco più avanti in questo manuale.

Imposizione delle coordinate dell'ultima stazione di una poligonale (aperta vincolata)
E' possibile imporre le coordinate dell'ultima stazione del rilievo aggiungendo la seguente riga nel file dei dati *.myt, in aggiunta a quella che eventualmente definisce le coordinate della prima stazione come visto nel punto precedente con la stessa sintassi.

PFISS <ultima stazione> <X stazione> <Y stazione> <Z stazione>

Orientamento del rilievo e apertura a terra
L'orientamento del rilievo consiste sia nel determinare le coordinate della prima stazione che l'orientamento angolare vero e proprio; con CADPak esistono tre modi per orientare un rilievo:
1) Metodo dell'angolo di correzione e delle coordinate imposte alla prima stazione
Questo metodo di orientamento prevede di imporre un valore di correzione da applicare a tutti gli azimut letti dalla prima stazione e di imporre le coordinate alla prima stazione.
Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT)
Sintassi:
PFISS <prima stazione> <X stazione> <Y stazione> <Z stazione>
ORIEN <prima stazione> <angolo di correzione>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
ORIEN  100    56.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
L'istruzione PFISS serve, come visto nel punto precedente, per imporre le coordinate della prima stazione
L'istruzione ORIEN serve invece per fare in modo che CADPak aggiunga algebricamente un determinato valore angolare a tutti gli azimut letti dalla prima stazione provocando la rotazione del rilievo a cascata su tutte le stazioni del rilievo.
2) Metodo dell'azimut imposto e delle coordinate imposte alla prima stazione
Questo metodo di orientamento prevede di imporre un valore ad una lettura azimutale effettuata dalla prima stazione della prima poligonale del rilievo.
In questo modo CADPak ruota tutto il rilievo di un angolo che risulta dalla differenza tra azimut imposto ed azimut letto realmente.
Angolo di correzione = Azimut Letto – Azimut Imposto
Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT):
Sintassi:
PFISS <prima stazione> <X stazione> <Y stazione> <Z stazione>
AZIMU <prima stazione> <punto letto> <azimut imposto>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
AZIMU  100     102      156.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
3) Apertura a terra plaminetrica su due punti di coordinate note
Questo metodo di orientamento prevede la conoscenza di due punti di coordinate note battuti dalla prima stazione.
Questa istruzione si può dare aggiungendo nel file MYT, due righe come la seguente:
Sintassi:
PNOTO <prima stazione> <punto battuto> <X punto> <Y punto> <Z punto>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS     100      0.000      0.000        856.323
PNOTO     100      125      -82.38972      -76.25983      0.00000
PNOTO     100      126      -73.51726      -76.70539      0.00000
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
Per imporre la quota della prima stazione del rilievo si può utilizzare il comando PFISS come nella riga dell'esempio:
PFISS     100      0.000      0.000    856.323
In questo modo il programma calcolerà le coordinate planimetriche riferendosi ai due punti noti e le quote verranno calcolate partendo dal fatto che la prima stazione del rilievo è a quota 856.323.
Nota importante:
Se si fa stazione su uno dei due punti di coordinate note di deve utilizzare il metodo dell'imposizione di azimut come nel seguente esempio (si è fatta stazione sul punto 100 e si è collimato il punto 124):
AZIMU   100    124        123.3266
PFISS   100   -154.97245   98.42561   723.3265    (coordinate della stazione)
Il comando NewPolig calcola le coordinare cartesiane dei punti di rilievo.
Se il calcolo avviene nell'ambito di una poligonale chiusa o vincolata le coordinate dei punti si distinguono tra compensate e non compensate; infatti i punti battuti da una stazione le cui coordinate sono compensate avranno coordinate compensate, in altre parole per ogni punto si avranno due terne di coordinate X,Y,Z (non compensate) e Xc,Yc,Zc (compensate).
Inoltre vengono generati alcuni libretti che tecnicamente sono dei file di testo, con dei nomi particolari per renderne agevole il riconoscimento.

Rilievo.myt         Libretto di campagna originale
Rilievo.log         Registro delle attività e delle anomalie trovate
Rilievo_(1.1).txt         Libretto di campagna con gli azimut originale
Rilievo_(1.2).txt         Libretto di campagna con azimut corretti per trasporto
Rilievo_(1.3).txt         Libretto di campagna con azimut derivati per compensati
Rilievo_(2.1).txt         Libretto delle stazioni
Rilievo_(3.1).txt         Libretto delle poligonali
Rilievo_(4.1).txt         Coordinate cartesiane NON compensate
Rilievo_(4.2).txt         Coordinate cartesiane compensate
Rilievo_(5.1).dat         Libretto delle misure nel formato di Pregeo 7
Rilievo_(5.2).dat          Libretto delle misure nel formato di Pregeo 8
Rilievo_CP(6.1).xyz   Coordinate NON compensate da utilizzare con il comando C2D di CADPak
Rilievo_CP(6.2).xyz   Coordinate compensate da utilizzare con il comando C2D di CADPak

Tra questi libretti, che sono numerati, vi sono i due libretti 5.1 e 5.2 che sono i libretti di Pregeo; questi possono essere importati in forma grafica nell editor di AutoCAD con il comando C2DP (vedi più avanti inn questo manuale).


Carica Strumento

Nome Comando al Prompt: CreaStrum

Questo comando serve per trasformare dei file di coordinate cion n,x,y,z in file dati nel formato dei alcuni strumenti topografici
ai fini del tracciamento, cioè permette di caricare nello strumento i punti da tracciare prelevandoli da AutoCAD.

La procedura, a partire da AutoCAD, è la seguente:

1) Esportare in un file di testo (*.xyz) i punti, vertici di linee, vertici di polilinee, centri di cerchi, punti di inserimento di blocchi con il comando
EXPDAT di CADPak.

Esempio:
    1     119.51     123.68       12.126
    2     122.05     118.59       14.498
    3     123.33     106.71       10.326
    4     118.23      97.80       18.629
    5     106.35     103.74       20.674
    6     103.38     120.28        8.123
    7     137.34     143.20       19.045
    8      92.76     112.65       24.788

2) Utilizzare il comando CreaStrum per trasformare il file nel formato adatto allo strumento.

Esempio strumento Trimble --> File *.are
5=1
4=0
37=123.680000
38=119.510000
39=0.000000
5=2
4=0
37=118.590000
38=122.050000
39=0.000000

I riquadri presentio nella finestra di dialogo sono i seguenti
Strumento: in questa sezione è possibile scegliere lo strumento per il quale si vuole generare il file;
File di testo: Riquadro per la Scelta e/o la Modifica del file con i dati sotto forma di coordinate cartesiane (.xyz) generato con il comando ExpDat;
File Strumento: Riquadro per la Scelta del nome del file che deve essere generato contenente le coordinate cartesiane nel formato della stazione totale, pronto per essere trasferito nella memoria interna dello strumento; il nome del file si deve fornire e non scegliere perchè questo riquadro serve per fornire un nome di un file che deve essere generato da zero.


Piano quotato

Posizione menu a tendina

Toolbar

Questa barra degli strumenti contiene i comandi per la gestione dei piani quotati.
Si possono importare piani quotati partendo da file di coordinate cartesiane, oppure esportare dei piani quotati sotto forma di files ASCII in vari formati.
E' possibile inoltre modificare i piani stessi aggiungendo dei nuovi punti ricavati per interpolazione.


Imposta interpolazione

Nome Comando al Prompt: PXYDAT

Questo comando è complementare al comando "Pxy" che serve per calcolare la quota e disegnare un punto interpolato (vedi figura nella descrizione del comando Pxy). Lo scopo del comando Pxy è il seguente: dati due punti, individuabili eventualmente con gli osnap di AutoCAD, si desidera ricavare la quota di un terzo punto fra i due, scrivendo anche il testo della quota ed il numero del punto.
La seguente finestra di dialogo viene visualizzata dal comando PxyDat e serve per impostare il funzionamento del comando Pxy.

Creare testo di quota: abilita/disabilita il disegno automatico del testo della quota del punto interpolato; se abilitato, il riquadro Testo di quota serve per determinarne l'altezza, l'angolo di rotazione, il layer, la posizione rispetto alla crocetta che materializza il punto.

Creare numerazione: abilita/disabilita il disegno automatico del testo del nome del punto; se abilitato, il riquadro Parametri consente di determinare la posizione, l'altezza del testo, l'angolo di rotazione, la posizione ed il numero di partenza per la numerazione.

Creare punto: abilita/disabilita il disegno automatico della crocetta del che materializza punto interpolato; se abilitato il riquadro Punto permette di scegliere se il punto debba essere in 3D oppure no e su quale layer.

Selezione quota: serve per decidere come si intendono specificare i punti di appoggio per l'interpolazione; se si sceglie l'opzione Testo è possibile decidere se la selezione del testo avviene toccando delle stringhe intere oppure dei testi suddivisi in parte intera e parte decimale.
Le variabili globali che regolano questo box di dialogo sono nel, file TOPAK1.VAR e sono quelle comprese fra TP7465 e TP7499.


Genera punti con iterpolazione

Nome Comando al Prompt: PXY

Questo comando consente di generare dei nuovi punti in un piano quotato ricavando la sua quota per interpolazione fra altri due, di quota nota.
Prima di utilizzare questo comando si devono impostare i parametri attraverso il comando PxyDat. Se si intende evitare l'impostazione dei parametri ogni volta con il comando PxyDat, si possono modificare le variabili globali comprese fra TP7465 e TP7499 nel file TOPAK1.VAR, vedi comando Imposta.
Esempio:

Segue esempio di funzionamento del comando:
Command: PXY (Invio)
Selezione quota: da testo
Punto num. 1 - Punto da interpolare: (selezionare la crocetta del punto da interpolare)
Primo punto: (selezionare la crocetta del primo punto di riferimento)
Selezionare la quota: (selezionare il testo della quota di tale punto)
Secondo punto: (selezionare la crocetta del secondo punto di riferimento)
Selezionare la quota: (selezionare il testo della quota di tale punto)
1-> p1 9.91 -21.31 -0.27
p2 13.51 -16.95 -1.06
pi 12.01 -19.16 -0.69
Punto num. 2 - Punto da interpolare: (Invio)
Command:


Inserisci punto (X,Y)+quota

Nome Comando al Prompt: CP_PUNTO

Comando che consente di inserire nuovi punti in un piano quotato presente nel disegno, oppure di generare un nuovo piano quotato un punto alla volta, inserendo accanto all'oggetto che materializza i punti anche i testi con quota e nome.
I punti possono essere materializzati con degli oggetti PUNTO di AutoCAD oppure con dei BLOCCHI, possono essere tridimensionali oppure posti tutti a quota zero.
Attraverso l'opzione in linea BOX , viene visualizzato il box con il quale l'utente controlla la modalità di disegno dei punti.
Il funzionamento è il seguente:

Comando: CP_PUNTO
Box/<coordinate-posizione punto>: B (Invio)

Nel riquadro Tipo di input è necessario specificare quali dati relativi al punto vengano dati con il mouse (o tavoletta) e quali con la testiera; nel caso specifico della figura sarà richiesto all'utente di specificare il nome del punto e la sua quota con la tastiera, mentre la posizione planimetrica verrà definita con il mouse; inoltre la materializzazione dei nuovi punti avverrà con degli oggetti PUNTO di AutoCAD

Se nel riquadro Materializzazione Punto si utilizza l'opzione Blocco è necessario che il blocco contenga un attributo la cui etichetta sia QUOTA oppure quella specificata dalla variabile TP0050 nel file TOPak1.var delle variabili globali relative alla topografia e che di default è QUOTA.
(TP0050 "QUOTA") ;nome dell'attributo quota
(TP0051 "NOME") ;nome dell'attributo nome
Analogamente è necessario che esista un attributo con l'etichetta NOME che è regolata dalla variabile globale TP0051 nel file TOPak1.var. Nel caso dell'utilizzo dell'opzione è necessario disabilitare tutte le caselle di Crea testo perché nome e quota sono già inseriti sotto forma di attributo. Se CADPak non trova questi attributi nel blocco non scrive il testo relativo. Attivando l'opzione Crea Testo Nome, per ogni punto apparirà la richiesta alla riga di comando di indicare il nome del punto. E' gestito l'incremento dei codici nel caso di testi numerici o alfanumerici. Digitando, ad esempio, "AX12", il prossimo nome di punto proposto sarà "AX13" e così via.
Il riquadro Parametri serve a definire la scala e relativamente ad essa l'altezza dei testi in millimetri stampati altre che l'angolo di rotazione. Inoltre l'opzione Punti 3D, se attivata, serve per forzare il disegno dei punti in 3D altrimenti vengono altrimenti vengono disegnati in 2D.


Esporta dati

Nome Comando al Prompt: EXPDAT

Comando che permette di esportare in un file di tipo ASCII, piani quotati presenti nel disegno corrente
Le coordinate dei punti da esportare vengono ricavate da vari oggetti di AutoCAD. Il comando apre il seguente box di dialogo:

File: Il pulsante Scelta permette di indicare il nome e la posizione del file da generare; il pulsante Modifica apre un editor di testi da cui è possibile modificare o stampare il file .xyz . Attivando l'opzione Aggiungi è consentito aggiungere nuovi punti in un file precedentemente creato. Se l'opzione è disabilitata, ogni volta che si effettuerà l'esportazione del piano quotato in un file precedentemente già salvato, questo sarà sovrascritto con le coordinate dei nuovi punti.
Tipo di output permette di indicare il contenuto del file da esportare: Nome crea una colonna con indicato il nome del punto; x,y e x,y,z creano una colonna per ogni coordinata;
Layer crea una colonna contenente il nome del Layer su cui è posto quel punto. Combinando le caselle si possono ottenere diversi formati (in questo caso n x y z).

I formati possibili per i file testo da produrre sono i seguenti:

1° formato | N X Y | 5° formato | X Y
2° formato | N X Y Layer | 6° formato | X Y Layer
3° formato | N X Y Z | 7° formato | X Y Z
4° formato | N X Y Z Layer | 8° formato | X Y Z Layer

Il riquadro Separatore permette la scelta del carattere separatore fra le colonne di dati (virgola o spazio).
Coord. Permette di decidere il sistema di riferimento delle coordinate cartesiane da estrarre, fra un sistema di riferimento personalizzato (vedi comando UCS di AutoCAD) e il sistema di riferimento globale di AutoCAD (WCS).
Selezionare permette di individuare gli elementi AutoCAD su cui filtrare la selezione: linee, polilinee, punti, testi, blocchi, cerchi. La selezione poi avverrà attraverso un finestra di AutoCAD.
Selezione manuale: attiva la selezione manuale dei singoli punti da esportare. In questo caso è possibile deliberare come effettuare la nominazione dei punti attivando il chek Nome:
opzione Manuale: richiede la selzione del testo del punto,
opzione Automatica permette di numerare automaticamente i punti esportati in base ai parametri impostati nel riquadro Numero.
L'opzione Quota (attiva nella modalità Selezione Manuale) permette di indicare le quote dei punti selezionadone i relativi testi (con ciò posso ricavare l'informazione tridimensionale da punti a video 2D);

Filtro serve per decidere di filtrare gli oggetti da interessare per layer singolo o per layered (vedi curve di livello layered).
Formato Dati serve per decidere la lunghezza dei campi con i dati esportati ed il numero di decimali
Le variabili globali che regolano questo box di dialogo sono nel file TOPAK1.VAR e sono quelle comprese fra TP7500 e TP7531.
Nel caso siano presenti punti doppi nel gruppo di selezione, solamente uno sarà esportato.
Numerazione dei punti esportati
La numerazione dei punti dipende del gruppo di selezione e può essere:
Casuale se l'operatore sceglie i punti da esportare attraverso finestre di selezione, CADPak numera gli oggetti a seconda dell'ordine con cui AutoCAD gli trasmette il gruppo di selezione generato dall'utente
Progressiva se l'operatore seleziona gli oggetti da esportare uno alla volta, AutoCAD fornisce a CADPak gli oggetti nello stesso ordine con cui l'operatore li ha selezionati e la numerazione dei punti segue tale ordine. Inoltre se l'utente seleziona una polilinea o una linea disegnata in AutoCAD secondo un certa sequenza di vertici, la numerazione avverrà secondo la stessa sequenza. Se l'utente desidera numerare i punti secondo una numerazione progressiva a partire da un certo numero può utilizzare l'opzione Nome Manuale e le impostazioni del riquadro Numero.

Per fare un esempio si immagini di avere un piano quotato nel disegno e di volerlo esportare in un file ASCII con - n x y z - dove la numerazione dei punti deve avvenire nella sequenza indicata dall'utente partendo dal punto numero 100; si devono fare le impostazioni riportate nella finestra di dialogo riportata a fianco. In questo caso CADPak per chiederà di specificare per ogni punto: La selezione del punto con l'osnap opportuno; La selezione del testo della quola; La numerazione dei punti avverrà partendo da 100 in sequenza incrementando di uno il numero dei punti successivi.
Selezione Manuale + Quota => serve per fornire le coordinate XY con l'indicazione dei punti attraverso gli osnap e la Z selezionando il testo che rappresenta la quota.

L'opzione layer serve per consentire l'esportazione del nome del layer che contiene gli oggetti e quindi ottenere la codifica dei punti. Questa possibilità non è valida se l'opzione Selezione Manuale è selezionata, infatti in questo caso CADPak non è in grado di acquisire il nome del layer dato che la selezione dei punti non avviene attraverso dei gruppi di selezione.

Esempio:
n x y z layer
1  65.23      34.36       0.00   CONTORNI
2  42.82      71.05       0.00   CONTORNI
3  81.39      85.58       0.00   CONTORNI
4 131.74      76.35       0.00   CONTORNI
5 136.82      53.74       0.00   CONTORNI
6  98.48      50.05       0.00   CONTORNI
7  78.85      47.05       0.00   CONTORNI
8  76.77      37.82       0.00   CONTORNI


Disegna piano quotato da file di coordinate

Nome Comando al Prompt: C2D

Questo comando permette di disegnare dei piani quotati partendo dalle coordinate cartesiane contenute in file di testo (ASCII). Il file testo che l'utente deve avere a disposizione può essere ottenuto in più modi: utilizzando le funzioni per la celerimensura di CADPak (ConvStrum, NewPolig); tramite un programma di topografia in grado di esportare file ASCII; inserendo una tabella di coordinate cartesiane utilizzando un editor qualsiasi.
Il file testo deve corrispondere ad uno dei seguenti formati:

1° formato | N X Y | 6° formato | X Y Layer (codice)
2° formato | N X Y Layer (codice) | 7° formato | X Y Z
3° formato | N X Y Z | 8° formato | X Y Z Layer (codice)
4° formato | N X Y Z Layer (codice) | 9° formato | File di Pregeo
5° formato | X Y |  |

I campi di ciascuna riga possono essere separati da uno o più spazi oppure da un carattere virgola; non sono ammesse condizioni miste.

File di dati
Attraverso il pulsante Scelta… è possibile indicare il nome del file ASCII i dati; con Modifica… si apre il file scelto in un editor di testi da cui è possibile modificarlo o stamparlo. Attivando l'opzione File PreGeo è possibile caricare un file in formato Pregeo *.dat.
Separatore serve per scegliere il carattere che separa le colonne di dati. Il valore deve essere coerente a come è stato creato il file.
Tipo di input serve ad indicare a CADPak cosa si desidera acquisire dal file; naturalmente i dati che si richiedono devono esser presenti nel file. Sistema serve per indicare a CADPak l'ordine con cui sono inserite le colonne delle coordinate cartesiane, cioè se con il sistema X e Y oppure Nord ed Est
Materializzazione Punto serve per decidere se i punti debbano essere visualizzati attraverso degli oggetti tipo Punto di AutoCAD o da Blocchi, nel caso di blocchi si deve indicarne il nome (pulsante Blocco); si veda oltre per il dettaglio dell'inserimento di un blocco.
Cerchi serve per materializzare i punti con dei cerchi, oltre che con gli oggetti definiti nel riquadro Materilizzazione punto.
Parametri serve per impostare la scala di stampa (al fine di poter calcolare l'altezza dei testi) e l'altezza dei testi direttamente in millimetri (in funzione della scala) ed un angolo di rotazione per i testi espresso in unità correnti secondo le impostazioni eseguite con il comando DDUNITS di AutoCAD.
Se il file contiene le informazioni relative alla quota dei punti, è possibile attivare l'opzione Punti 3D: in questo modo otterremo la materializzazione dei punti in formato tridimensionale, base essenziale per l'ottenimento di modelli digitali del terreno.
Nota: le variabili globali che regolano questa finestra di dialogo sono quelle comprese fra TP1000 e TP1083.

Crea testo serve per scegliere cosa debba essere riportato accanto all'oggetto che materializza il punto: quota, nome, x, y (vedi figura di es.). Polilinea Stazioni. Se nel file ASCII delle coordinate esistono delle righe che iniziano con il carattere asterisco (*), abilitando Disegna CADPak unisce con una polilinea i punti così indicati. Il comando CalcPolig scrive un file ASCII dove in coda inserisce i punti che rappresentano le stazioni già marcati con il carattere asterisco. Esempio: *100     23.326     36.326    125.326 *200     85.326    124.326    126.326 *300    214.322    312.323    124.326

Il riquadro "Contorni" abilita o disabilita la possibilità di unire i punti di contorno automaticamente. Nel file delle coordinate è possibile inserire dei simboli ">" e "<" per indicare a CADPak quali sono i punti di contorno da unite con delle linee.

(>) Unire con il punto precedente
(<) Termina unione punti
(&) Chiudi su primo punto della polilinea
Esempio:
    >1      65.23      34.36       0.00  CONTORNI
    >2      42.82      71.05       0.00  CONTORNI
    >3      81.39      85.58       0.00  CONTORNI
    <4     131.74      76.35       0.00  CONTORNI
     5     136.82      53.74       0.00  CONTORNI
    >6      98.48      50.05       0.00  CONTORNI
    >7      78.85      47.05       0.00  CONTORNI
    &8      76.77      37.82       0.00  CONTORNI
Il carattere ">" indica l'inizio di un nuovo contorno o un punto da collegare mentre il carattere "<" indica la fine di una polilinea.
Le opzioni "File Pregeo" e "Linee Stazione -> Punto" servono per la restituzione finalizzata a Pregeo e pertanto si rimanda al manuale Procedure Pregeo.
Utilizzo di blocchi per la materializzazione dei punti nel disegno
Nel riquadro Materializzazione punto del box di dialogo, abbiamo visto che è possibile scegliere di materializzare i punti con dei blocchi anziché con dei punti.

È necessario che il blocco che si intende utilizzare abbia un attributo il cui nome è definito dalla variabile globale (TP050 "QUOTA") nel file TOPakl.var e che per default contiene "QUOTA"; se il blocco non ha attributi la quota non viene inserita da nessuna parte nel disegno e viene persa con l'impossibilità quindi di elaborare il modello a falde triangolari in seguito.
Il riquadro Crea testo è indipendente dalla scelta di rappresentare il piano quotato per punti o blocchi e se si utilizzano i blocchi con l'attributo QUOTA, si dovrà disabilitare Quota come nella seguente figura, altrimenti si avranno i testi le quote scritti due volte.

Determinazione dei layer nel disegno dei piani quotati

Se il campo codice, il quale può diventare il nome di un layer di AutoCAD, risponde ai limiti esistenti per la definizione dei nomi dei layer, come ad esempio la mancanza del carattere spazio o altri caratteri non ammessi, è possibile utilizzarlo per fare in modo che CADPak suddivida i punti in funzione della loro tipologia; ad esempio i punti che definiscono una edificio possono esser posizionati su di un layer che si chiama edifici. Il comando "CalcPolig" scrive un file di coordinate cartesiane calcolate .xyz che contiene un campo che si rifà al codice descrittivo dei punti rilevati in campagna. A questo proposito si veda anche la descrizione del comando CalcPolig.

Esempio:
Il comando "CalcPolig" produce, tra gli altri, un file come il seguente che è la forma ideale per poter sfruttare al meglio le possibilità del comando "C2D" in questione:
    101      19.251      89.040      -6.419  TP-025  Marciapiede
    102      23.828      87.350      -6.491  TP-025  Marciapiede
    103      19.451      74.765      -6.409  TP-025  Marciapiede
    104      14.297      76.168      -6.364  TP-025  Marciapiede
    109      15.755      59.839      -6.076  TP-027  Ciglio strada
    110      15.907      57.913      -6.000  TP-027  Ciglio strada
    111      15.510      55.008      -5.699  TP-027  Ciglio strada
    112      13.540      54.883      -5.725  TP-026  Linea di confine
    113       9.179      61.481      -6.041  TP-025  Marciapiede
    114       4.715      47.922      -4.728  TP-025  Marciapiede
Se l'opzione "Codice" del comando "C2D" è abilitata, il punto 103 di questo esempio verrà disegnato utilizzando i layer nel modo descritto quì di seguito.

- La crocetta (Punto) sul layer "tp-025"
- Il testo nome del punto sul layer "ntp-025"
- Il testo della coordinata X sul layer "xtp-025"
- Il testo della coordinata Y sul layer "ytp-025"
- Il testo della coordinata Z sul layer "ytp-025"
Nota: il file dell'esempio è stato generato utilizzando il comando CalcPolig ed il campo con il codice decrittivo del punto può essere utilizzato per divenire il nome di un layer di AutoCAD.

Il prefisso "tp-" viene aggiunto automaticamente e significa Tipo di Punto; l'utente ha la possibilità di modificare a piacere il prefisso modificando la variabile globale (TP7970 "TP-") nel file topak1.var, tenendo presente che questa variabile viene utilizzata dal comando CalcPolig nella fase di generazione del file di coordinate e non da questo comando
Se l'opzione "Codice" non è abilitata i punti vengono materializzati con l'uso dei seguenti layers:

- La crocetta sul layer corrente
- Il testo del nome sul layer "n"
- Il testo della coordinata X sul layer "x"
- Il testo della coordinata Y sul layer "y"
- Il testo della coordinata Z sul layer "z"

Alcune regole per il file dati di input per il comando "C2D":
· Il file deve avere uno dei formati:
1° formato | N X Y | 6° formato | X Y Layer (codice)
2° formato | N X Y Layer (codice) | 7° formato | X Y Z
3° formato | N X Y Z | 8° formato | X Y Z Layer (codice)
4° formato | N X Y Z Layer (codice) | 9° formato | File di Pregeo
5° formato | X Y |  |

· Non ci devono essere spazi tra una coordinata e l'altra se si utilizza la virgola come separatore e non ci devono essere virgole tra una coordinata e l'altra se si utilizza lo spazio come separatore;
· Opzionalmente si possono scambiare le X con le Y: N°, X, Y, Z oppure N°, Nord, Est, Z;
· Il carattere separatore può essere virgola o spazio;
· Il carattere per le cifre decimali è il punto e non la virgola (es. 10.236 e non 10,236);
· Le righe che iniziano con il carattere ";" vengono ignorate
· Eventuali linee vuote vengono trascurate;

Le variabili globali che regolano questo box di dialogo sono nel file TOPAK1.VAR e sono quelle comprese fra TP1000 e TP1083.


Elimina/nasconde testi sovrapposti

Nome Comando al Prompt: TextOverlap

Questo comando permette di eliminare oppure di spostare su altro layer i testi che si sovrappongono.
Spesso accade che nei piani quotati i testi associati ai punti battuti si sovrappongono e quindi l'operatore deve spostare o eliminare manualmente i testi; questo comando aiuta in questo operazione permettendo di eliminare automaticamente i testi secondo delle regole dettate proprio dall'utente.

Tecnicamente il comando individua l'area di ingombro dei testi che ha forma rettangolare, e su questa si basa per confrontare i rettangoli e stabilire se si sovrappongono, quindi valutare eventualmente di quanto.
L'utente ha la possibilità di fissare una percentuale massima di sovrapposizione ed eventualmente di maggiorare la figura di ingombro per fare in modo che i testi oltre a non sovrapporsi debbano anche essere distanziati di un certo numero di millimetri (in funzione della scala di stampa impostata- vedi comando IMPOSTA).
Una volta individuati i testi da eliminare il programma permette di decidere se eliminarli oppure se spostarli su di un altro layer il cui nome viene costruito utilizzando il nome del layer originale con l'aggiunta del suffisso specificato nella finestra di dialogo.


Triangoli

Posizione menu a tendina

Toolbar

Questa toolbar contiene i comandi per la generazione e la gestione del modello del terreno.
Si possono generare dei modelli partendo da piani quotati, introducendo anche delle linee di vincolo. I modelli generati possono essere materializzati con triangoli a polilinee 3D oppure con 3Dfacce ed eventualmente trasformare le une nelle altre. Vi sono dei comandi che consentono la modifica delle falde triangolari dopo averle generate oppure colorarle in funzione della quota o della pendenza.
E' possibile importare le maglie quadrate, nonché generale partendo dal modello a falde triangolari.


Crea linea di vincolo (3DPolilinea)

Nome Comando al Prompt: _3DPOLY

E' il comando _3DPOLY di AutoCAD standard ed è stato inserito in questa toolbar per comodità.
Le polilinee 3D, infatti, sono utilizzate per definire le linee di vincolo come contorni esterni, isole, discontinuità.


Proietta polilinea sul modello

Nome Comando al Prompt: Clop3D

Questo comando permette di proiettare una linea oppure una polilinea su un modello a falde triangolari. Tecnicamente ogni triangolo definisce un piano nello spazio tridimensionale e con questo comando le linee o le polilinee selezionate vengono proiettate su detti piani.

Il comando visualizza la finestra di dialogo mostrata nella figura dove sono presenti tre riquadri descritti quì di seguito.
Riquadro Crea polilinea 3D: serve per scegliere se generare la polilinea 3D proiettata sul modello, dato che l'utente potrebbe voler generare solo i punti corrispondenti ai vertici.
Riquadro Crea Punti: serve per scegliere se generare i punti corrispondenti ai vertici e alle intersezioni con i lati dei triangoli.
Riquadro Tipologia: serve per indicare a CADPak su quale tipo di oggetti deve basarsi per fare la proiezione, infatti non sempre si hanno a disposizione i triangoli, si potrebbero avere le curve di livello di tipo layered oppure semplicemente degli oggetti tridimensionali.
Nota: Layered è un termine coniato per CADPak e serve per definire un tipo di curve di livello bidimensionali con l'informazione relativa alla quota intrinsecamente definita nel fatto che ogni curva di livello o allocata su di un layer il cui nome esprime la quota. Ad esempio la curva di livello di quota 10.5 è posizionata sul layer P0010_50.


Unione linee di vincolo

Nome Comando al Prompt: Poly_Join

Questo comando unisce entità linea, polilinea o arco che abbiano almeno un vertice in comune, creando un'unica polilinea con le caratteristiche (layer, colore, tipo linea) della prima selezionata. Il funzionamento richiede di selezionare la prima entità e poi di seguito le altre. Il comando successivo, che genera il modello a falde triangolari, chiede all'utente di individuare con il mouse un poligono tutto d'un pezzo sotto forma di 3D polilinea che descrive il contorno esterno del modello da generare. Molto spesso, soprattutto se il piano quotato è molto grande, non si riesce a disegnare in autocad una polilinea 3D unica, ma delle spezzate disgiunte che se separate non delimitano un contorno, da quì la necessità di unirle. Si evidenzia il fatto che le estremità comuni tra le varie spezzate devono coincidere perfettamente, anche in quota.


Elabora e disegno modello da punti

Nome Comando al Prompt: Trigon

Icona Voce di Menu Comando tastiera
Il comando genera il modello del terreno a falde triangolari sulla scorta dei punti tridimensionali presenti nel disegno.
I dati necessari sono solamente i punti in 3D a video.
I dati facoltativi sono i vincoli, cioè:
· Contorni: Polilinee 3D (3dpoly) che definiscono i contorni esterni delle aree in cui si desidera ottenere l'elaborazione del modello.
· Isole: Polilinee 3D (3dpoly) che definiscono dei contorni interni al modello che si desiderano escludere dall'elaborazione (Edifici, Strade ecc..)
· Discontinuita': Polilinee 3D (3dpoly) che definiscono le linee di interruzione, es. ciglio strada, base rampa ecc.
Questi vincoli devono essere delle polilinee 3D che passano per i punti, da individuare con il modo di osnap NODO.
Lanciando il comando apparirà il box di seguito descritto:

Tipo di entità permette di impostare la tipologia del modello a falde triangolari:
3Dfaccia: i triangoli verranno disegnati con degli oggetti 3D faccia di AutoCAD;
Polilinea 3D: imposta il disegno dei triangoli con delle polilinee tridimensionali. Il riquadro Selezionare permette di filtrare il tipo di oggetti con cui sono materializzati nel disegno i punti del piano quotato e sui quali verranno generati i triangoli. CADPak, infatti, con il comando C2D (vedi), può restituire i punti con degli oggetti PUNTO oppure con dei BLOCCHI con un attributo, il cui nome è specificato dalla variabile globale (TP050 "QUOTA") contenuta nel file TOPak1.var e che per default è "QUOTA".

Se, nel riquadro Selezionare, l'opzione Blocchi è abilitata, il comando TRIGON, che genera i triangoli e che quindi necessita delle quote, cerca nei blocchi l'attributo QUOTA (specificato dalla variabile TP0050); se esiste ne acquisisce il valore e lo utilizza come quota, mentre se non esiste utilizza la coordinata Z del punto di inserimento dei blocchi.
E' inoltre possibile determinare il dislivello massimo tra le quote dei punti (Parametri)e su quale Layer creare il modello (Layer…).
Dopo aver cliccato OK, il programma chiederà di selezionare gli oggetti, secondo la sequenza (per passare da un dato all'altro digitare Invio):
· Contorni: Con il pickbox toccando le 3dpoly opportune.
· Punti: Se esistono i contorni è sufficiente selezionarli nuovamente, se invece i contorni non ci sono, la selezione dei punti avviene per finestre (come per il comando cancella di AutoCAD).
· Isole: Con il pickbox toccando le 3dpoly opportune.
· Discontinuità: Con il pickbox toccando le 3dpoly opportune.


Disegna modello da file

Nome Comando al Prompt: TrigonTrDwg

Questo comando permette di caricare e visualizzare un modello a falde triangolari, precedentemente salvato in un file di testo con il comando TrigonTrSave.
Dopo aver selezionato il file, il comando apre lo stesso box di dialogo del precedente a cui si rimanda per la spiegazione.
Quando si preme OK verrà chiesto il punto base di inserimento, che, in caso di risposta nulla (Invio: scelta consigliata), coinciderà con il punto di origine del sistema di riferimento del modello.
Se si desidera inserire il modello in una posizione diversa si dovranno specificare sia il punto base che un secondo punto.


Salva il modello a triangoli

Nome Comando al Prompt: TrigonTrSave

Salva il modello a triangoli (3Dface oppure 3Dpoly) in un file testo con estensione *.tri.
Il comando chiede di specificare un punto da assumere come origine del sistema di riferimento rispetto al quale calcolare le coordinate.


Visualizza baricentro dei triangoli

Nome Comando al Prompt: TrigonTrVis

Questo comando serve per far disegnare dei punti tipo grdraw (che vengono eliminati con un Ridis o Rigen) in corrispondenza
del baricentro dei triangoli allo scopo di verificarne l'esistenza.


Spegne/Accende Layer DTM

Nome Comando al Prompt: TrigonTrOnOff

Questo comando spegne/accende il Layer su cui è stato creato il modello del terreno.
Il Layer di default, è indicato nella variabile TP7291 nel file Topak1.var.


Aggiungi triangoli

Nome Comando al Prompt: TrigonTrAdd

Comando per aggiungere nuovi triangoli nel disegno. È possibile scegliere il tipo di triangolo da creare: 3DFACE o 3DPOLY, scegliendo l'opzione opportuna alla riga di comando (F/P). Di default è proposta l'ultima utilizzata dal comando TRIGON o TRIGONTRADD.


Elimina falde triangolari

Nome Comando al Prompt: TrigonTrDel

Comando per l'eliminazione delle falde triangolari del terreno.
Chiede di selezionare l'area su cui intervenire e poi di individuare con il mouse dei punti interni ai triangoli da cancellare.
N.B. L'eliminazione dei triangoli deve essere eseguita pertendo dai triangoli esterni dell'area selezionata.


Modifica quadrilatero

Nome Comando al Prompt: TrigonTrInv

Dato un quadrilatero formato da due triangoli è possibile variare la disposizione del lato comune semplicemente toccandolo con il cursore.

Così facendo è possibile variare la geometria del modello per meglio adattarla a situazioni particolari che si possono verificare sul terreno naturale.


Trasforma 3DFaccia in polilinea o viceversa

Nome Comando al Prompt: D3F2PLV

Comando che permette di trasformare una 3DFaccia a tre lati in una polilinea 3D a tre vertici, e viceversa. Dopo aver scelto quale tipo di operazione effettuare attraverso il box di dialogo, sarà richiesto di selezionare gli oggetti da modificare.


Punto nel piano definito da tre punti

Nome Comando al Prompt: PTPLAN

Il comando permette di determinare la quota di un punto, di cui si conoscono solo le coordinate X e Y, giacente su un piano definito dai vertici di un triangolo.
Una volta lanciato il comando PTPLAN, è richiesto di selezionare i tre punti di riferimento; in seguito si deve indicare la posizione del quarto punto: questa operazione può essere effettuata tramite il mouse o digitando le coordinate X e Y.

Esempio:
Comando: PTPLAN
Primo punto: (102.616,66.117,-2.500)    (individuare il vertice del triangolo)
Secondo punto: (91.976,65.560,-2.500)    (individuare il vertice del triangolo)
Terzo punto: (94.432,42.739,-1.545)    (individuare il vertice del triangolo)
Punto da interpolare:    (individuare il punto di cui si vuole conoscere la quota)
Intersezione = (96.089,58.292,-2.189)
Comando:


Punto nella triangolazione

Nome Comando al Prompt: CpPtOnDtm

Questo comando permette di definire la quota di un punto posto all'interno del modello. Le coordinate x,y devono essere indicate nel disegno con il mouse, mentre la quota è calcolata in automatico.
E' possibile utilizzare questo comando per spostare punti o blocchi sul modello utilizzando l'opzione [Selezionare oggetti].

Esempio:

Comando:
Selezionare i triangoli...
Selezionare oggetti: Specificare angolo opposto: trovato(i) 90
Selezionare oggetti:
Numero di triangoli...:    90
N. Triangoli: 90
Punto [Selezionare oggetti]:
Punto interno alla triangolazione: (198.656324, 44.584764, 59.657079).


Crea griglia 3D da triangoli

Nome Comando al Prompt: CpGrid

Questo comando permette di creare una griglia 3D, partendo dalla selezione di un modello a falde triangolari. Viene visualizzato un box di dialogo dove è possibile scegliere i parametri di creazione della griglia 3D.

Nei riquadri Dati triangolazione e Triangoli sono elencati i dati riguardanti il numero di triangoli analizzati, le coordinate minime e massime raggiunte dal modello nello spazio (in x, in y e in z) e la distanza tra esse.
In Passo della rete vanno impostati i parametri sulla cui base verrà creata la maglia. E' possibile indicare il numero di righe e di colonne che si vogliono ottenere o il passo in x e in y. Attivando l'opzione Griglia quadrata ogni maglia avrà lo stesso passo sia in X che in Y: sarà perciò sufficiente inserire il numero delle colonne o il passo in X.
In Parametri della rete è possibile assegnare la Quota base, che influirà sulla quota delle maglie esterne al perimetro della triangolazione; la scala in cui verranno calcolate le quote rispetto a quelle del modello a falde triangolari (Scala quote) e il Layer su cui creare la griglia. Attivando l'opzione
Seguire l'andamento, la griglia avrà un contorno aderente alla forma del modello: saranno disegnate solo le maglie che contengono almeno un punto del modello.


Importa griglia 3D da file

Nome Comando al Prompt: DtmIn

Questo comando permette di importare nel disegno corrente una griglia 3D da un file con estensione *.dtm , *.asc. o file *.dat dell'IGM.

File DTM: permette di scegliere il file tramite il pulsante "…" Riquadro Parametri: E' possibile indicare un Moltiplicatore di passo in X e in Y: se ad esempio le maglie del file hanno passo 10m sia in X che in Y, assegnando come moltiplicatore di passo per entrambe le coordinate il valore 5, la maglia importata avrà passo 50m.
In Fattore di scala Z, è possibile assegnare un fattore di scala alle quote del modello. Assegnando un valore di Spostamento in Z il modello sarà inserito nel disegno con una traslazione in Z pari al valore indicato.
Nel riquadro Informazioni sono riportati i dati riguardanti il Modello: il passo, il numero delle celle, le coordinate X e Y del punto base.
Nel riquadro Tipo di Entità, è possibile scegliere se si desiderano importare nel disegno solo le entità 3D Faccia, solo le entità Punto o entrambe, e indicare i Layer su cui dovranno essere poste.


Colora triangoli

Nome Comando al Prompt: TriangColor

Questo comando permette di colorare i triangoli, o la maglia quadrata in funzione della quota del baricentro, della pendenza massima, dell'orientamento o dell'esposizione.
Il comando apre una finestra di dialogo da dove è possibile impostare i parametri della tipologia di colorazione che si vuole ottenere.

Dopo aver indicato nel riquadro Selezione Oggetti con che tipo di entità (3D Facce o Polilinee 3D) è rappresentato il modello, si deve procedere alla Selezione degli oggetti.
Attraverso il riquadro Operazione, è possibile scegliere il tipo di colorazione che si desidera effettuare: per Quota media, per Pendenza massima, per Orientamento o per Esposizione.
Riquadro Parametri
Titolo: indicare il titolo dell'eventuale legenda.
Prefisso: indicare il prefisso per i nomi dei Layer che verranno creati.
Attivando Inserimento legenda, verrà inserita la legenda della colorazione in un punto che l'utente dovrà definire a video al termine dell'elaborazione.
Riquadro Identificativo di classe
Attivando il check box Crea, verrà inserito in ciascun trinagolo un testo identificativo: il suo contenuto potrà essere l'Intervallo dei valori che indica la classe di appartenenza o un numero Progressivo, secondo l'opzione attivata.
Riquadro Vettore Direzione/Intensità
Se nel riquadro Operazione si è scelto di effettuare una colorazione in base alla pendenza massima, all'orientamento o all'esposizione, le opzioni contenute in questo riquadro saranno attive.
Attivando l'opzione Disegno, per ogni falda del modello, sarà disegnato un vettore, rappresentante il rapporto tra le diverse situazioni. Questa linea avrà origine nel baricentro del triangolo, e sarà ortogonale ad esso (nello spazio). La lunghezza massima, che si indica nel box Lungh. max. (mm), rappresenta il massimo valore del vettore associato al dato maggiore; gli altri dati saranno rappresentati da vettori proporzionali ad esso. In Layer è visualizzato il nome del Layer su cui saranno disegnati i vettori: somma tra il Prefisso (definito sopra), e il testo indicato nella variabile TP7335 nel file TOPak1.var (di default "Direzione").
Riquadro Esposizione
Se nel riquadro Operazione si è scelto di effettuare una colorazione in base all'esposizione, è necessario indicare l'Azimut e lo Zenit nei due box.
Dopo aver impostato i parametri ci cui sopra e selezionato le entità su cui effetturae l'operazione, si deve provvedere alla Classificazione, attraverso il punsante Creazione.

Il pulsante Creazione apre il box di dialogo a fianco, attraverso il quale si possono impostare i parametri che regolano la colorazione vera e propria.
Classificazione: permette di impostare la classificazione: Il combo box permette di scegliere la tipologia dell'intervallo che può essere: valore singolo, intervalli uguali, quantili, valori distinti. Nel caso di scelta di valore singolo, nel campo Valori devo indicarne il relativo valore.
Numero delle Classi: permette di indicare il numero di classi con cui si desidera lavorare (impostare il valore e poi fare doppio clic all'interno del riquadro per confermare);
Arrotondamento: permette di decidere la precisione dell'intervallo di suddivisione delle classi (un valore negativo indica quanti decimali si desiderano); es.: se desideriamo dividere in classi che considerino i valori approssimate alle decine di unità dovrò inserire il valore 1 e poi fare doppio clic;

Classi: i tre pulsanti presenti in questa area permettono di inserire una nuova classe, eliminare o fondere due o più classi selezionate. La selezione delle classi si effettuata nell'area sovrastante
Colorazione e Intervalli, cliccando sulle singole classi attraverso l'uso dei tasti Shift e Ctrl nella maniera classica di Windows per le selezioni multiple. Il meccanismo è il seguente: se desidero inserire una classe mi posiziono in quella da modificare e clicco su Inserisci, il software creerà una nuova classe sottostante "spezzando" in due la precedente. Per eliminare una o più classi basta selezionarle e cliccare su Elimina. Per fondere due o più classi si deve selezionare la prima e l'ultima e cliccare su Fondi; in questa maniera si otterrà un'unica classe "somma" delle precedenti. Attenzione che non si devono selezionare tutte le classi dell'intervallo ma solo la prima e l'ultima!
Colorazione e intervalli: questa zona visualizza i dati delle singole classi (progressivo di classe, colore, intervallo, etichetta, n° degli elementi presenti). Cliccando due volte sul colore di una classe si apre il dialog box Colore di AutoCAD e si può impostare il colore da associare. Questa operazione si può effettuare per tutte le singole classi, oppure è sufficiente impostare la prima e l'ultima e poi attraverso i bottoni Interpola Colori di conseguenza assegnare alle altre classi i "colori adeguati". Il meccanismo è il seguente: definisco il colore della prima classe, dell'ultima ed eventualmente di alcune intermedie; seleziono queste classi attraverso l'uso di Ctrl (quelle selezionate manterranno il colore impostato) a questo punto con i tasti AutoCAD o RGB dell'area Interpola Colori faccio si che il software esegua l'interpolazione attraverso i colori di AutoCAD o lo standard RGB. Attenzione: cliccando sull'intestazione Col/Inv della colonna colore è possibile invertire l'ordine della colorazione.


Disegna retino SOLID su triangoli

Nome Comando al Prompt: TriangSolid

Comando che permette di colorare i triangoli con un retino solido. Richiede soltanto di selezionare i triangoli. Questo comando risente delle impostazioni effettuate con il comando Trigon: dal gruppo di selezione verranno filtrati solamente i triangoli specificati.


Crea solidi 3D

Nome Comando al Prompt: TriangSol3D

Questo comando permette la creazione di un modello del terreno creato da solidi, sulla base di un modello a falde triangolari esistente.
Ogni triangolo, che può essere un oggetto 3DFACE o 3DPOLY, sarà proiettato lungo l'asse z fino all'intersezione con il piano XY individuato dalla quota base indicata. Saranno quindi creati deglii oggetti 3DSOLID di Autocad che geometricamente sono dei solidi prismatici a base triangolare.
Dopo aver lanciato il comando, appare il seguente box di dialogo.

Il riquadro Oggetti, consente la selezione degli oggetti a video, premendo il pulsante Seleziona. Gli oggetti selezionati possono essere 3DFACE o 3DPOLY. I campi Quota riportano i valori di quota massimi e minimi, raggiunti nel modello a falde triangolari. Nel campo Quota base è possibile indicare la quota base dei solidi che saranno creati. Il riquadro Proprietà, contiene un pulsante per la selezione del Layer su cui creare i solidi.


Curve di livello

Posizione menu a tendina

Toolbar

Questa barra degli strumenti contiene i comandi per la generazione e la gestione delle curve di livello.
CADPak può generare le curve di livello in diverse modalità: a spezzate, a curve, bidimensionali, tridimensionali, di tipologia layered.
Vi sono dei comandi di conversione da una modalità ad un'altra per consentire flessibilità di gestione, anche quando le curve di livello provengono, via files dxf, da altri programmi.


Impostazioni curve di livello

Nome Comando al Prompt: CURLIV_DAT

Questo comando richiama una finestra di dialogo con cui impostare le modalità di disegno delle curve di livello. Deve essere effettuato prima di disegnare le curve di livello, perché non agisce sulle curve già disegnate, ma soltanto su quelle disegnate in seguito; le impostazioni influiscono sui comandi che seguono.

Il riquadro l'Equidistanza permette di definire il passo di equidistanza tra una curva e l'altra, attraverso il Valore corrente dove è possibile indicare il valore. Alternativamente è possibile anche selezionare uno dei Valori predefiniti.
In Dislivello max va indicato il dislivello massimo consentito tra la curva di livello con quota maggiore e quella con quota minore. Nel caso che nella selezione effettuata sul modello a falde triangolari preso come riferimento, non si possa verificare tale condizione, sarà visualizzato un messaggio di avvertimento. Il riquadro Tipologia consente di definire la modalità di disegno delle curve:
Layered: ogni curva, di tipo bidimensionale, apparterrà ad un layer il cui nome ne definisce la quota;
Unico: le curve di livello (2D) verranno disegnate su di un unico layer. Selezionando 3D, le curve verranno disegnate in 3 dimensioni, come Lwpolyline (polilinee leggere di AutoCAD). Attivando l'opzione 3DPOLY, esse saranno materializzate come polilinne 3D, e non come polilinee leggere 3D (LWPOLYLINE).

Layered è un termine coniato dai programmatori di CADPak per indicare un particolare tipo di curve di livello bidimensionali, la cui quota viene definita attraverso il nome del layer al quale appartengono. Esisterà un layer per ogni quota delle curve di livello; ad esempio le curve di livello di quota +10.00, saranno poste sul layer P0010_00, mentre quelle di quota -10.00 sul layer M0010_00.
Nel riquadro Offset Quota è possibile indicare un valore che sarà sommato alla quota del modello, cioè di "spostare" altimetricamente il modello a curve rispetto al modello triangolare del terreno.
Nella sezione Parametri Layered (attivo se la tipologia selezionate è Layered) è possibile definire il colore delle curve (bottone Col. a sinistra). Attivando l'opzione Mult. è consentito differenziare il colore delle multiple (bottone Col. a destra) ed il passo tra una multipla e la successiva attraverso il box Val. Il passo va indicato quale dislivello tra una multipla e la successiva.

Selezione punti serve per governare il funzionamento del comando Curliv_T, per la generazione delle linee di livello triangolo per triangolo (puntando con il puntatore sui punti del piano quotato). In tal caso le possibilità sono:
a) I punti a video sono in 3D. Selezionare i vertici del triangolo.
b) I punti a video sono in 2D con il testo della quota accanto. Selezionare i vertici del triangolo e i testi che ne definiscono la quota. Per maggiori informazioni vedere la descrizione dettagliata del comando.

Il riquadro "Parametri" serve per decidere se si devono generare le curve di livello come delle Spezzate a spigoli o Smussate. Si possono impostare delle variabili che governano il modo in cui CADPak smussa le linee.

Selezionando Smussate, è possibile modificare il "Fattore di raccordo" (min e max) che determina il valore percentuale di arrotondamento delle linee; esso varia in funzione dell'angolo in ciascun vertice da un valore minimo per a (angolo nel vertice, vedi figura) tendente a zero (vedi variabile globale TP7274 in TOPAK1.VAR) ad un valore massimo per a tendente all'angolo piatto (vedi variabile globale TP7275 in TOPAK1.VAR) secondo una legge non lineare in funzione di (sen a/2)^(1/2). Così facendo, le spezzate vengono sostituite da delle linee curve (polilinee) in cui le curve vere e proprie sono dei piccoli segmenti di retta a lunghezza variabile in funzione dell'angolo nel vertice e che discretizzano la parabola di raccordo fra i tratti diritti.

L'opzione Spezzate invece abilita il disegno delle curve di livello a segmento rettilinei.
Attenzione: selezionado l'opzione Smussate è ulteriormente possibile selezionare anche l'opzione Spezzate (e viceversa) e posizionare la seconda visualizzazione su di un altro layer (ad esempio spento e/o non stampabile), in questa maniera si riesce ad evidenziare sia la restituzione rigorosa( spezzata) sia la sua approssimazione.
I pulsanti Layer che vi sono in questa area del box sono abilitati quando la restituzione delle curve non è di tipo Layered, oppure quando si è fatta la doppia selezione.
L'utente ha la inoltre facoltà di determinare l'ampiezza dei tratti di discretizzazione intervenendo sulla formula matematica che governa il calcolo della lunghezza dei tratti (vedi pulsante Avanzati):

Dove:
a = angolo in radianti
L = lunghezza dei tratti
L0 = lunghezza dei tratti per a < angolo minimo
E = coefficiente numerico a discrezione dell'utente
K = coefficiente numerico a discrezione dell'utente

Le variabili globali che regolano la generazione delle curve di livello sono nel file TOPAK1.VAR e sono comprese fra TP7250 e TP7285.


Disegna curve di livello

Nome Comando al Prompt: TRIGONCL

Disegna le curve di livello sulla base del modello a falde triangolari e secondo le specifiche introdotte con il comando Curliv_Dat.
Il comando verifica se esiste nella memoria del computer un modello elaborato ma mai disegnato; se esiste chiede all'utente di poterlo disegnare con il box di dialogo della figura.

Se l'utente risponde SI, CADPak disegna il modello (triangolazione) presente in memoria. Se l'utente risponde NO, CADPak chiede di selezionare il modello, cosa che si può fare attraverso finestre di selezione. Selezionato il modello, o parte di esso, con Invio il comando disegna le curve di livello secondo i parametri impostati.

Se TRIGONCL non trova modelli ancora residenti in memoria significa che sono già stati disegnati oppure salvati in un file (vedi comando TRIGONTRSAVE) e pertanto chiede direttamente di selezionare i triangoli nel disegno.


Curve di livello su triangolo 3 punti

Nome Comando al Prompt: CURLIV_T

Questo comando genera le linee di livello all'interno di un triangolo di cui si indicano i vertici (anche se sono in 2D). La determinazione delle modalità di selezione dei vertici e di disegno delle linee, viene gestita tramite il riquadro Selezione punti nel box di dialogo di CURLIV_DAT (vedi sopra). Se non esistono i triangoli ed i punti sono 2D con il testo della quota a fianco è possibile impostare 2D + Testo affinchè CADPak ricavi le coordinate X e Y indicando i punti nel disegno con il mouse e la quota dei punti attraverso la selezione del testo che ne definiscono la quota. Se i punti sono in 3D, è possibile far sì che CADPak acquisisca la quota dalla selezione dei punti nel disegno con il mouse (utilizzando un Osnap NODO), dopo aver impostato nel box l'opzione 3D.


Curve di livello su triangolo per punto interno

Nome Comando al Prompt: TRIGONCLPINT

Dato un modello a falde triangolari, con questo comando è possibile disegnare le linee di livello nei singoli triangoli (uno alla volta), selezionandone un punto interno.
Questo comando risente delle impostazioni effettuate con CURLIV_DAT.


Accendi/spegni curve di livello layered

Nome Comando al Prompt: CLONOFF

Con il seguente box è possibile spegnere o accendere tutti i layer che rispondono alla codifica LAYERED. Si ricorda che LAYERED è un nome coniato dalla I&S per definire una serie di piani il cui nome rappresenta la quota delle curve di livello in essi contenute.


Raccorda polilinee

Nome Comando al Prompt: SMOOTHMPL

Questo comando serve per smussare una o più polilinee contemporaneamente secondo i parametri stabiliti nel box di dialogo di CURLIV_DAT. Dopo aver selezionato le polilinee il comando presenta il box di dialogo a fianco.


Cancella curve di livello tipo layered

Nome Comando al Prompt: CLDELLYD

Cancella tutte le curve di livello, ricadenti in una o più finestre di selezione, che rispondano alla codifica layered. In pratica il comando esegue un filtro sui soli oggetti layered tralasciando altri eventuali oggetti selezionati.


Colora curve di livello tipo layered

Nome Comando al Prompt: CLDATCOL

Questo comando permette di cambiare il colore e/o il tipo di linea delle curve di livello che corrispondono alla codifica Layered oppure 3D.
In Selezionare entità è possibile indicare in che modalità sono rappresentate le curve di livello: secondo la codifica Layered o in 3D (in pratica si imposta il filtro).
Riquadro Parametri: è possibile definire il colore e il tipo di linea delle curve (bottoni Colore…; Linea… Normali). Attivando l'opzione Multipli è consentito differenziare il colore e il tipo di linea delle multiple (bottoni Colore…; Linea…) ed il passo tra una multipla e la successiva attraverso il box Valore(uc) Il passo indicato definisce il dislivello tra una multipla e la successiva.
Entrambi i chek box Generazione Continua consentono di rappresentare le polilinee delle curve come segmenti proporzionali e non seguendo i vertici delle stesse (la cosa e ben visibile se si imposta un tipo di linea spezzata e/o a puntini).


Eleva in serie

Nome Comando al Prompt: EPM

Questo comando permette di impostare la quota delle curve di livello, cioè di tradurre delle semplici polilinee e/o segmenti in curve di livello con una quota.
Spesso accade che, importando delle curve via file DXF da un programma di topografia (oppure digitalizzandole su un raster), si ottengano delle curve di livello prive di elevazione e quindi non utilizzabili per estrarre sezioni.
È necessario conoscere la quota di almeno una curva all'estremità di una intera planimetria (o di una porzione) e l'equidistanza tra le curve di livello: con questi dati è possibile elevare le linee e/o convertirle nella codifica Layered.
Cliccando su EPM appare il box di dialogo rappresentato nella figura seguente:

La procedura consiste nell'impostare i parametri necessari nel box, premere "OK" e tracciare una linea (che sparirà con RIDIS) intersecando le curve che si desidera modificare (vedi esempio in seguito).
Tramite il riquadro Selezione entità si indica la tipologia delle curve di livello in origine:
- Layered: se le curve rispondono alla codifica secondo cui il nome del Layer su cui è
posta ciascuna linea, ne indica la quota;
- Layer se le curve appartengono tutte ad un unico layer, che si dovrà indicare attraverso il
bottone Scelta, nel riquadro Layer..
- AutoCAD se le curve appartengono a diversi layer.
Nel riquadro Parametri si indicano le impostazioni secondo cui basare la trasformazione. In Quota è necessario immettere il valore dela prima curva e l'incremento sulle successive - Equidistanza.
Attraverso il riquadro Tipo di creazione si decide come deve essere la configurazione finale delle curve di livello.

Il riquadro Tipo di creazione permette di scegliere come crere le curve:
Layered Le curve diventano layered.
Normale (3D e layer corrente) Le curve diventano 3D e vengono spostate nel layer corrente.
Layer (3D e cambio layer) Le curve diventano 3D e vengono spostate nel layer che viene deciso con il bottone "Scelta" sottostante.
Layered e 3D Le curve diventano 3D e contemporaneamente con la codifica layered cioè posizionate su layer che ne indicano la quota.

Esempio: Si immagini di avere delle polilinee ad elevazione 0.00 e contenute sul layer 0:.

Command: EPM impostarei i parametri relativi alla quota della prima curva e gli altri come visto sopra (invio)
Primo punto: (selezionare il primo punto)
al punto: (selezionare il secondo punto)
Processing: Entities/Intersections: 13/13

Elevation: 13/13 quota= 22.50 - int.= 0.50

Command:
Il primo punto da selezionare è quello alla quota più bassa; CADPak modifica le curve assecondando le impostazioni effettuate in "Tipo di creazione". Se le curve di livello non sono polilinee, bisogna fare in modo che lo diventino con il comando MKP.


2D<->3D

Nome Comando al Prompt: LAY23DLAY

Con questo comando l'utente ha la facoltà di trasformare le curve di livello dalla modalità Layered in 3D e viceversa. Si tratta di selezionare la trasformazione desiderata, premere OK e di selezionare con una finestra di selezione le linee interessate. La stessa cosa si può fare per trasformare una polilinea leggera di AutoCAD in una 3Dpolilinea.


Unire polilinee

Nome Comando al Prompt: MKP

Con questo comando è possibile unire delle linee con i vertici in comune ed ottenere un'unica polilinea (vedi comando POLY_JOIN). Lanciando MKP, appare il box di dialogo a lato. Il riquadro Selezione entità consente di modificare selettivamente le linee. Ad esempio è possibile unire solo ed esclusivamente le linee in formato layered, o tutte quelle appartenenti ad un determinato piano (Layer). Si consiglia di selezionare piccoli gruppi di linee da unire per evitare tempi di elaborazione troppo lunghi.


Edita polilinea

Nome Comando al Prompt: _PEDIT

E' il comando _PEDIT di AutoCAD standard che consente di modificare le polilinee presenti nel disegno.


Sezioni

Posizione menu a tendina

Toolbar

Questa toolbar contiene i comandi per la generazione, la modifica, il disegno delle sezioni direttamente nell'editor grafico di AutoCAD.
CADPak può generare le sezioni basandosi sulle curve di livello, sulle falde triangolari, sui punti battuti secondo le necessità dell'utente.
CADPak ricava automaticamente i numeri generatori delle sezioni dal disegno lungo la linea di sezione indicata dell'utente e li memorizza sotto forma di file a ASCII. Con un secondo comando poi disegna la sezione leggendo i dati memorizzati in file ASCII ed eventualmente modificati dall'utente.


Ricava dati sezione - Quotare curve di livello

Nome Comando al Prompt: CLOPER

Attraverso questo comando, che visualizza inizialmente un box di dialogo, si estraggono in un file ASCII le coordinate dei picchetti di una sezione semplicemente tracciando sopra le linee di livello LAYERED o 3D oppure anche sulle falde triangolari 3Dpoly una linea o una polilinea (anche curva) qualsiasi che ne definisce la traccia.
Per utilizzare questo comando, è necessario avere le curve di livello in 3D oppure in modalità LAYERED oppure ancora le falde triangolari sotto forma di 3DPoly, in modo che esse contengano l'informazione sulla quota.
L'obiettivo della funzione CLOPER è quello di individuare, estrarre, e scrivere in un file ASCII i dati necessari al disegno della sezione, che avverrà in un secondo momento tramite il comando S2D; il file ASCII che viene generato consta di due parti, la prima denominata INTESTAZIONE individuata nelle prime sei righe del file, contiene una serie di parametri che serviranno poi per il disegno della sezione, la seconda parte invece contiene i dati veri e propri della sezione, cioè una serie di righe scritte nella forma seguente:

n
Dp
Q

Dove:

n | = | Numero del punto
Dp | = | Distanza parziale fra il punto n-1 e n.
Q | = | La quota del punto n.

Con questa funzione CADPak trova le coordinate cartesiane dei punti di intersezione fra la linea di sezione e le linee di livello, le traduce in DISTANZE PARZIALI e QUOTE ed infine scrive questi valori calcolati in un file testo. Il comando S2D acquisisce i dati da questo file e disegna la sezione corrispondente.
Le variabili globali che regolano questo comando sono nel file TOPAK1.VAR e sono quelle comprese fra TP7350 e TP7392.
Le opzioni disponibili nel comando sono:
riquadro Operazione permette di scegliere se lungo la linea o spezzata che interseca le linee di livello, si vogliono estrarre i dati di una sezione oppure inserirne le quote (Estrarre o Quotare).

Di seguito vengono esplicitati i parametri relativi all'operazione di estrazione di una sezione:

Il riquadro Tipologia serve per indicare a CADPak la tipologia delle linee di livello su cui si intende operare: la scelta permette di scegliere tra le curve di tipo Layered, 3D oppure di effettuare la sezione o la quotatura sui Triangoli.
Riquadro Selezione serve a definire come si intende definire la linea lungo la quale eseguire la sezione, ossia se si desidera selezionare una linea/polilinea di sezione presente nel disegno e che interseca gli oggetti da sezionare, o se il riferimento è una polilinea 3D, oppure se si vuole tracciare una linea di sezione al momento che però è virtuale e sparisce con l'utilizzo del comando RIDIS o RIGEN.

Estrazione dati profilo è un riquadro con cui si sceglie il nome del file che contiene l'intestazione (chek box Intestazione e pulsante Scelta…), eventualmente modificarlo (Modifica…), il nome del File di dati da generare (intestazione + dati della sezione) tramite il bottone Scelta…, il tipo di output dei dati cioè se n,d,q (numero, distanza, quota) oppure n,x,y,z (numero, coordinate x,y,z).
Il sotto riquadro Parametri permette di gestire il calcolo automatico delle quote interpolate, cioè quelle dei vertici delle eventuali linee di sezione spezzate, attraverso le seguenti opzioni: Distanza di ricerca indica a CADPak la distanza massima fra il punto di cui deve interpolare la quota e le più vicine intersezioni fra linea di sezione e curve di livello, tale distanza deve essere pensata in funzione della pendenza del terreno e della equidistanza delle curve. Il valore di default è Distanza di ricerca = 20 m.

Suddivisioni Per trovare la quota, CADPak ha bisogno di provare su di un fascio di rette centrato sul punto da interpolare quella per cui è minima la distanza fra le due curve che si trovano a monte ed a valle del punto cercato, cioè la linea di massima pendenza. E' evidente che se il numero di rette fosse infinito come richiederebbe la definizione di fascio, Topografiaarriverebbe alla soluzione in tempi lunghissimi, sorge quindi la necessità di limitare ad un numero finito la quantità di rette da "testare"; il default è Suddivisioni = 12.
Includi punto iniziale e finale: indica al software di considerare nel calcolo della sezione anche i punti di inizio e fine della Linea/Polilinea lungo la quale si estrae la sezione stessa. Ovviamente in questo caso tali punti devo no contenere l'informazione quota, pertanto la Linea/Polilinea dovrà essere di tipo 3D. Se non viene selezionato la sezione inizia nel primo punto di intersezione e termina nell'ultimo;
Mantieni la quota originale: disabilita l'opzione di interpolazione, pertanto genera la sezione considerando i valori di quota dei vertici originali della livelletta di riferimento (cioè della polilinea lungo la quale estraggo il profilo);
Progressive: abilita la possibilità di indicare la distanza tra una progressiva e la successiva;
Il chek Linee di Estensione permette di abilitare il disegno in automatico di linee trasversali al tracciato della sezione, la cui Lunghezza e Layer… sono definibili dall'utente. Tali segmenti saranno tracciati nei punti di intersezione con le curve di livello e fungono da base per l'estrazione delle sezioni trasversali.

Segue una esemplificazione di cosa si intende per Intestazione e Tabella:

Di seguito riportiamo un tipico file dati di una sezione:

Le prime sei righe costituiscono l'intestazione, mentre le rimanenti righe rappresentano i dati numerici relativi alla sezione.

Un altro compito che il comando CLOPER è in grado di svolgere è quello di inserire le quote nelle linee di livello semplicemente tracciando una linea/polilinea che le intercetta; quest'ultima operazione si esegue selezionando Quotare nel riquadro Operazione e selezionando i parametri adeguati allo scopo nel riquadro Quotatura; tali parametri sono:
Posizione: permette di inserire il testo della quota o Lungo la sezione oppure alla fine della curva di livello (Finale);
Opzioni: permettono di effettuare il Taglio curve, cioè se la quotatura deve avvenire tagliando ed inserendo il testo di quota lungo una curva di livello oppure no, ed eventualmente di Quotare solo le multiple stabilendone il passo (Valore);
Altezza testo direttamente in millimetri stampati; risente della scala impostata attraverso il box di dialogo del comando IMPOSTA.
Fattore di larghezza per il testo, che utilizza lo stile corrente.
Distanza laterale determina la distanza in millimetri stampati fra il testo e le due porzioni di curva fra i quali viene inserito (se attivato taglio curve). Questa opzione risente delle impostazioni IMPOSTA.
Il bottone Layer serve per stabilire il nome del piano su cui inserire il testo di quota.
Quanto ai parametri dei riquadri Tipologia e Selezione si rimanda a quanto già descritto nella sezione relativa all'estrazione del profilo.

Profili longitudinali su polilinee curve .

Se la linea di sezione è una polilinea contenente degli archi o dei settori circolari CADPak determina i punti di intersezione fra la linea di sezione e le curve di livello (o triangoli) ed inoltre i punti iniziali e finali delle curve quindi lo sviluppo, il raggio e l'angolo al centro delle curve.
Si riporta lo stampato di un file di sezione eseguita su di un profilo contenete una curva:

1000,3
"Q = ",0.0," m s.l.m.",70,2,ISO,35,4,2
40,10,0,20,12
10,20
"Scala lunghezze 1:",100," ",100,20,ISO,35,5,0
"Scala altezze 1:",100," ",100,30,ISO,35,5,0
    1        0.0000      486.0000
    2        3.6328      487.0000
    3        3.6200      488.0000
    4        3.6583      489.0000
    5        3.4749      490.0000
    6        2.6039      491.0000
    7        2.4508      492.0000
$8           1.3531      492.3707   -3.0203  64.3064  21.2916   (Angolo, Sviluppo, Raggio)
    9        2.3583      493.0000
   10        3.5402      494.0000
   11        5.0538      495.0000
   12        3.5356      496.0000

Se vi sono degli elementi circolari tipo archi e curve, CADPak inserisce nel file dati generato dal comando CLOPER, oltre ai consueti dati sotto forma di distanza parziale e quota, dei campi aggiuntivi contenenti i dati generatori della curve come Angolo in radianti, Sviluppo, Raggio. Il valore dell'angolo potrà essere positivo o negativo a seconda della direzione della curva, negativo se destrorsa e positivo se sinistrorsa.


Disegno profilo o sezione

Nome Comando al Prompt: S2D

La funzione che interagisce con questo box di dialogo serve per produrre il disegno di una sezione partendo da un file ASCII con intestazione e dati, ottenuto con il comando CLOPER oppure manualmente con un editor.

Il box è suddiviso in tre riquadri denominati File terreno, File progetto, File tabella. Il riquadro File terreno serve per la scelta del file testo contenente l'intestazione e i dati metrici della sezione (Scelta…), la sua eventuale Modifica…, per decidere se scrivere dei dati statistici (Riepilogo) accanto alla sezione, per abilitare il calcolo della quota fondamentale automatico (Quota base automatica) e per eventualmente Invertire il disegno della sezione (vedi sotto). E' inoltre possibile stabilire un Offset di quota ed indicare il Dislivello max tra il picchetto più alto e il più basso. se il profilo supera tale limite un messaggio avviserà l'utente. I chek Spazio e Virgola servono per indicare al software il tipo di separatore dei dati nel file txt.
Il riquadro File Progetto serve per scegliere un eventuale file ASCII contenente i dati di una sezione di progetto ottenuta con R08C09 oppure manualmente con un editor. I pulsanti Scelta… e Modifica… funzionano come per il precedente riquadro, così come Invertire, Spazio e Virgola; Azzera elimina il nome del file di progetto (non cancella il file!) per evitare che CADPak disegni la sezione comparativa terreno naturale/progetto.

Per quanto riguarda la numerazione dei picchetti CADPak può tenere conto del fatto che alcuni di essi sono contrassegnati da asterisco e quindi non disegnati; l'utente può scegliere se la numerazione deve essere comunque progressiva trascurando il fatto che alcuni dei picchetti non sono presenti (solo nel disegno) oppure se debba essere presente il vuoto di numerazione fra due picchetti consecutivi. Per scegliere le due possibilità l'utente deve scegliere fra Progressiva e Originale.

Le due caselle Invertire che si trovano sia nel riquadro File terreno che in File progetto servono per far sì che CADPak disegni le sezioni con la disposizione dei picchetti invertita.

Normale

Invertita

Se le righe del file con i dati della sezione iniziano con il carattere asterisco *, vengono ignorate ai fini del disegno delle linee verticali della sezione, delle quote e delle distanze relative però la presenza del picchetto rimane al fine del calcolo delle progressive dei picchetti successivi.

Le righe in grassetto e corsivo differiscono per il simbolo asterisco all'inizio della riga che, se presente, impone a CADPak il disegno della sezione come mostrato nella figura.

Il riquadro File Tabella permette di gestire la tabella allegata al profilo della sezione; tale tabella è un file ASCII di estensione *.TAB e di cui ve ne sono alcuni di esempio nella cartella …\Utipak del programma. Il file definisce cosa debba comparire nella tabella della sezione. Sono sotto riportate le regole per la generazione e/o modifica dei file ASCII per la tabella. L'intestazione, che nel file ASCII dei dati viene rappresentata dalle prime sei righe, è personalizzabile dall'utente intervenendo direttamente nel file ASCII oppure utilizzando il bottone Modifica… nel box di dialogo che richiama il comando MODDT di cui si possono avere maggiori informazioni più avanti in questo manuale.

Le variabili globali interessate da questo comando sono comprese fra TP1210 e TP1290 nel file TOPak1.var.

Specifiche per Intestazione e File tabella.
Intestazione - specifiche per la personalizzazione.
Per intestazione si intende una porzione di file testo, composta da 6 righe, che permette a CADPak di reperire le informazioni su come disegnare la sezione.
Esempio di file testo con i dati di una sezione:

Se una riga nel file testo inizia con un carattere "*", come (nell'esempio il picchetto 3), il picchetto non viene disegnato, mentre la sua presenza viene conteggiata nelle distanze e nelle quote.
L'intestazione può essere aggiunta automaticamente dal comando CLOPER; oppure, nei casi in cui essa non è inserita automaticamente, aggiunta dall'utente con il comando DT_UNION.
L'intestazione di default fornita con CADPak è il file testo di nome PROXY.INT contenuto nella cartella C:\…\…\CADPAK7\UTIPAK.
File intestazione:

Di seguito si riporta la definizione dei parametri che governano ognuna delle righe dell'intestazione (si rammenta che ogni riga di un file testo è denominata record, ed ogni record è suddiviso in campi).
Significato delle righe del file di intestazione:
INT = Numero intero REA = Numero con virgola (obbligatorio) STR = Stringa
01, 02, 03, 04, 05, 06 . . .=Numero del campo all'interno della riga.
Le stringhe devono essere racchiuse tra una coppia di " "
Queste regole sono descritte nel file REG-TAB.TXT e si possono leggere con un qualsiasi editor.
ð Riga 01 (1000,3) -----> (01,02)
Campo 01 INT Unita' di misura: 1=mm 10=cm 100=dm 1000=m ecc.
Campo 02 INT Tipo di dati:
1 se file con: Nome picch., X, Y, Z Riga 7 (1)
3 se file con: Nome picch., Dist. parz., Quota Riga 7 (3)
Nella versione 4.20 questo campo viene ignorato, perché il riconoscimento del tipo di file avviene automaticamente.
ð Riga 02 ("Quota = ",0.0,"m.s.l.m.",70,2,ISO,35,4,2) ---->(01,02, . . . . ,08)
Campo 01 STR Prefisso per stringa quota fondamentale. es. "Quota="
Campo 02 REA Quota fondamentale. es. 930.00
Campo 03 STR Postfisso per stringa quota fondamentale. es. "m.s.l.m."
Campo 04 REA Distanza X in mm dall'origine per posiz. testo quota fondamentale.
Campo 05 REA Distanza Y in mm dall'origine per posiz. testo quota fondamentale
Campo 06 STR Stile testo per quota fondamentale (max 8 caratteri)
Campo 07 STR Piano testo per quota fondamentale
Campo 08 REA Altezza testo fondamentale in mm
Campo 09 INT Numero decimali per fondamentale
ð Riga 03 (40,10,0,20,12) ---->(01,02,03,04,05)
Campo 01 STR Piano per la polilinea profilo terreno
Campo 02 STR Piano linee verticali
Campo 03 STR Offset alla quotatura progressiva (aggiunge)
Campo 04 STR Piano per le linee verticali estreme della sezione.
Campo 05 STR Piano per le linee verticali delle eventuali quote interpolate.
ð Riga 04 (100,20) ---->(01,02)
Campo 01 REA Distanza per le ettometriche (es.: 100)
Campo 02 STR Piano per le ettometriche
ð Riga 05 ("Scala lunghezze 1:",100," ",100,20,ISO,35,5,0) ---->(01,02, . . . ,09)
Campo 01 STR Prefisso per stringa scala lunghezze (orizz.)
Campo 02 REA Denominatore di scala lunghezze.
Campo 03 STR Postfisso per stringa scala lunghezze (orizz.). es. " " oppure " Come da planimetria"
Campo 04 REA Distanza X in mm dall'origine per posiz. testo scala lunghezze
Campo 05 REA Distanza Y in mm dall'origine per posiz. testo scala lunghezze
Campo 06 STR Stile testo per scala lunghezze (max 8 caratteri)
Campo 07 STR Piano testo per scala lunghezze
Campo 08 REA Altezza testo per scala lunghezze
Campo 09 INT Numero decimali per scala lunghezze
ð Riga 06 ("Scala altezze 1:",100," ",100,30,ISO,35,5,0) ---->(01,02, . . . ,09)
Campo 01 STR Prefisso per stringa scala altezze (vert.)
Campo 02 REA Denominatore di scala altezze
Campo 03 STR Postfisso per stringa scala altezze
Campo 04 REA Distanza X in mm dall'origine per posiz. testo scala altezze
Campo 05 REA Distanza Y in mm dall'origine per posiz. testo scala altezze
Campo 06 STR Stile testo per scala altezze (max 8 caratteri)
Campo 07 STR Piano testo per scala altezze
Campo 08 REA Altezza testo per scala altezze
Campo 09 INT Numero decimali per scala altezze

File tabella - specifiche per la personalizzazione.
Il file tabella PRO.TAB viene fornito con CADPak ed è contenuto nella sotto directory C:\CADPak\UTIPAK.

Come si legge il file:
Ogni riga del file corrisponde ad una riga nella tabella della sezione.
Ogni riga deve contenere 15 elementi (campi) separati dal carattere virgola ",".
Di seguito si forniscono le definizioni per ognuno dei 15 elementi, con l'indicazione del tipo: INTero, REAle, STRinga.
Le stringhe devono essere racchiuse da una coppia di apici doppi " ".
Descrizione dei campi di ogni riga (hanno tutte lo stesso numero di campi):

L'utente può aggiungere, se necessario, alcune righe vuote e da completare manualmente, del tipo:

0,5,3,1,5,POSIZIONE PALI,ISO,35,0,25,3,ISO,0.5,1,1

Vi sono inoltre altri parametri di gestione della tabella, che si trovano nel file delle variabili globali TOPak1.var di cui si riporta di seguito un estratto.


Sezione di progetto

Nome Comando al Prompt: OUT_DAT

Questo comando permette di trasformare una linea/polilinea tracciata nel disegno da sinistra verso destra in un file ASCII con i dati per la generazione delle sezioni, eventualmente completo di intestazione. Vedi descrizione dei comandi CLOPER e S2D.

Lo scopo di questo comando è duplice:
ð Creare un file testo contenente i numeri generatori (n, d.parz., quota) di una linea/polilinea di progetto disegnata su una sezione del terreno naturale presente nel disegno.
oppure
ð Creare un file dati di un terreno naturale da una linea/polilinea digitalizzata.

Attraverso questo comando si può trasformare la polilinea della figura in un file testo come una serie di righe del tipo indicato di seguito.

La sequenza dei comandi da seguire è:
1. Disegnare la linea/polilinea 2D (da sinistra verso destra), che potrebbe anche essere una polilinea di progetto sopra una sezione già presente nel disegno, che è il caso più frequente.
2. Determinare il punto di inizio (vedi figura sopra) che serve solo ai fini del calcolo delle quote.
3. Conoscere la quota di base (vedi figura sopra).
4. Dare avvio al comando OUT_DAT.

Se la linea/polilinea è una situazione di progetto rispetto ad una sezione già esistente, non è necessario aggiungere alcuna intestazione, dato che già esiste quella nel file del terreno naturale, e quindi nel box di dialogo la casella Intestaz. dovrà rimanere disattivata (senza crocetta). E' importante notare che CADPak esclude l'intestazione della sezione di progetto ed utilizza sempre quella del terreno naturale, pertanto anche se l'utente ritiene opportuno includere l'intestazione nel file della sezione di progetto CADPak la ignorerà.
Al contrario, se la linea/polilinea rappresenta una linea del terreno, come potrebbe essere quella digitalizzata ricalcando un vecchio profilo su carta, sarà necessario aggiungere l'intestazione attivando la casella Intestaz. ed in questo caso naturalmente diventa indispensabile.
E' anche possibile ricavare le coordinate attraverso la selezione di punti con il puntatore procedendo da sinistra verso destra; in tal caso si dovrà attivare la casella Punti nel riquadro Selezione.
I pulsanti Scelta… hanno lo scopo di permettere la scelta e posizione nel disco, del file dati da creare e dell'intestazione da utilizzare.
L'opzione Aggiungi, se abilitata inibisce l'aggiunta automatica dell'intestazione al file ASCII che viene generato e serve a fare in modo che l'utente possa aggiungere ad un file già esistente dei nuovi dati in coda anziché sovra scrivere il file; il bottone Modifica permette di editare tale file.
Il box Quota base consente di inserire il valore di base per il calcolo delle quote (si veda disegno. sopra), mentre i chek Spazio e Virgola nel riquadro Separatore indicano al programma quale carattere utilizzare come separatore nel file.
I tre chek box Dif.quota, Pend. e Dist.incl. se attivati consentono di scrivere nel file i dati di Differenza di quote tra un picchetto ed il precedente, pendenza del tratto e distanza inclinata. Tali valori saranno riportati sul picchetto in fase di restituzione del disegno. Attenzione: questi chek non vanno attivati se si sta eseguendo una estrazione di un profilo di progetto da sovrapporre al file dell'andamento naturale.


Proietta polilinea sul modello

Nome Comando al Prompt: PRO_CLO3D

Questo comando permette di proiettare una linea oppure una polilinea su un modello a falde triangolari. Tecnicamente ogni triangolo definisce un piano nello spazio tridimensionale e con questo comando le linee o le polilinee selezionate vengono proiettate su detti piani.

Il comando visualizza la finestra di dialogo mostrata nella figura dove sono presenti tre riquadri descritti quì di seguito.
Riquadro Crea polilinea 3D: serve per scegliere se generare la polilinea 3D proiettata sul modello, dato che l'utente potrebbe voler generare solo i punti corrispondenti ai vertici.
Riquadro Crea Punti: serve per scegliere se generare i punti corrispondenti ai vertici e alle intersezioni con i lati dei triangoli.
Riquadro Tipologia: serve per indicare a CADPak su quale tipo di oggetti deve basarsi per fare la proiezione, infatti non sempre si hanno a disposizione i triangoli, si potrebbero avere le curve di livello di tipo layered oppure semplicemente degli oggetti tridimensionali.
Nota: Layered è un termine coniato per CADPak e serve per definire un tipo di curve di livello bidimensionali con l'informazione relativa alla quota intrinsecamente definita nel fatto che ogni curva di livello o allocata su di un layer il cui nome esprime la quota. Ad esempio la curva di livello di quota 10.5 è posizionata sul layer P0010_50.


Proietta profilo/sezione in planimetria

Nome Comando al Prompt: PTSEZONPLAN

Questo comando permette di trasportare punti o blocchi prelevati da un profilo, lungo una polilinea.
È molto utile per inserire nel disegno della sezione i punti 3D, rappresentanti la sezione di progetto.
Lanciando il comando PTSEZONPLAN, appare il seguente box di dialogo.

Il riquadro Materializzazione Punto contiene due opzioni che permettono di indicare se si desidera disegnare degli oggetti di tipo Punto o da Blocchi. È possibile ricavare i valori delle coordinate dei vertici della polilinea selezionata e gestirli come attributi di un blocco o come testi (Riquadro Crea testo).

Per inserire tali valori automaticamente nei blocchi, è necessario che i nomi degli attributi del blocco utilizzato corrispondano a quelli indicati nelle seguenti variabili del file TOPAK1.var:
(TP0050 "QUOTA") ;nome dell'attributo quota
(TP0051 "NOME")  ;nome dell'attributo nome
(TP0052 "X")     ;nome dell'attributo X
(TP0053 "Y")     ;nome dell'attributo Y
(TP0054 "COD")   ;nome dell'attributo codice
(TP0055 "DESC")  ;nome dell'attributo descrizione

 | Dopo aver indicato il nome del Blocco, cliccare il pulsante Attributi, apparirà il box a fianco. Nella parte sinistra di esso, sono elencati i nomi degli attributi che sono indicati nelle variabili citate sopra. Nella parte destra, sono invece presenti delle tendine, da cui è possibile scegliere in quali attributi del blocco selezionato saranno inseriti i valori delle coordinate dei punti.
Parametri serve per impostare la scala di stampa (al fine di poter calcolare l'altezza dei testi) e l'altezza dei testi direttamente in millimetri (in funzione della scala) ed un angolo di rotazione per i testi espresso in unità correnti, secondo le impostazioni eseguite con il comando DDUNITS di AutoCAD. |

L'opzione Punti 3D, permette di trasportare i punti o i blocchi in formato tridimensionale, base essenziale per la creazione di modelli digitali del terreno. Sarà utilizzata la quota ricavata dalla posizione dei vertici della polilinea in riferimento alla quota base e al punto d'inizio del profilo indicati

 | Cerchi serve per materializzare i punti con dei cerchi di cui è possibile indicare il raggio[mm] in millimetri stampati (secondo i parametri UdM e Scala: comando IMPOSTA), oltre che con gli oggetti definiti nel riquadro Materilizzazione punto.
Nel riquadro Crea testo è possibile scegliere se e quali testi riportare accanto all'oggetto che materializza il punto: quota, nome, x, y. È indipendente dalla scelta di rappresentare il piano quotato per punti o blocchi. |
 | Gli oggetti creati saranno posti su layer i cui nomi sono gestiti nelle variabili dalla TP1039 alla TP1089 del file TOPak1.var. I punti o blocchi sul layer corrente (*). Il testo del nome sul layer "*-N" Il testo della coordinata X sul layer "*-X" Il testo della coordinata Y sul layer "*-Y" Il testo della coordinata Z sul layer "*-Z" I cerchietti sul layer "*-C"

         Dopo aver impostato i parametri nel box di dialogo, è necessario indicare il valore della quota base e selezionare a video il punto iniziale del profilo e la linea di sezione.

Sarà poi necessario selezionare il percorso lungo il quale saranno disegnati i punti. Attenzione: i punti saranno inseriti a partire dal vertice più vicino al punto in cui si seleziona la polilinea.

La figura a fianco rappresenta il percorso lungo il quale sono stati disegnati i punti 3D e i testi delle relative quote.


Aggiunta intestazione

Nome Comando al Prompt: DT_UNION

Questo comando serve per aggiungere l'intestazione ai dati delle sezioni che ne sono privi.

E' possibile scegliere (Scelta…) ed eventualmente modificare (Modifica…) sia il file dell'intestazione sia quello del profilo a cui l'intestazione andrà aggiunta.
L'operazione modifica il file dei dati aggiungendo le righe dell'intestazione, come sotto evidenziato.


Modifica parametri sezione

Nome Comando al Prompt: MODDT

Il comando permette di modificarne i parametri di un file contenente i dati di una sezione completi di intestazione. E' necessario che il file selezionato contenga l'intestazione (vedi comando DT_UNION).

Con il comando è possibile modificare le scale del disegno della sezione, la quota fondamentale e altri parametri. Inoltre l'utente può modificare l'intestazione del file testo relativo alla sezione. Cliccando sul comando appare il box di dialogo a fianco; con il bottone Unità appare un box di dialogo intitolato Unità di misura attraverso il quale si modificano le caratteristiche legate alle unità di misura e alla posizione dei testi; in particolare sono possibili le seguenti scelte:

Il riquadro Unità di misura (m, cm, mm): permette di scegliere l'unità di misura con cui si rappresenta il profilo;
Layer polilinea: permette di specificare su quale layer di AutoCAD debba essere disegnata la linea del terreno;
Layer l.v. specifica il layer per le linee verticali dei picchetti;
Offset progressiva: permette di aggiungere un valore ad ogni progressiva; è utile quando si hanno dei profili lunghissimi e si rende necessaria una loro frammentazione;
Layer estremi: è il layer sul quale vengono disegnate le linee verticali che rappresentano i picchetti estremi della sezione.
Layer spec.: è il layer sul quale devono essere disegnate le linee che rappresentano i picchetti la cui quota è stata interpolata; in merito si evidenzia come nel file testo della sezione gli eventuali picchetti le cui quote sono state interpolate vengono contrassegnati dal carattere "$".
Il riquadro Quota fondamentale permette di definire i parametri per il disegno del testo della quota fondamentale (sempre pensati in mm stampati).
Il riquadro Ettometriche: permette di definire la lunghezza in metri (cm, mm) delle ettometriche, nonché il layer su cui posizionarle. Sotto si riporta uno schema che evidenzia i valori e variabili appena visti:

Con il bottone Scala… invece è possibile modificare la parte dell'intestazione a cui compete la definizione delle scale di rappresentazione della sezione.

Il bottone Scala… apre il seguente box di dialogo, attraverso il quale si possono variare le scale delle lunghezze, delle altezze ed altri parametri come evidenziato dalla figura seguente. Attenzione: nel disegno delle sezioni il comando IMPOSTA non ha alcun effetto tranne che per il comando OUT_DAT (sezione di progetto). Tutti i parametri in millimetri plottati delle sezioni dipendono esclusivamente dalle scale impostate nei files delle sezioni stesse (e quindi nel box a fianco) e non dalle scale impostate con il comando IMPOSTA. Per il significato dei parametri del dialog box si faccia riferimento alla figura seguente:

Vi sono poi ulteriori parametri che si trovano nel file delle variabili globali TOPak1.var, di cui si riporta di seguito un estratto. Si ricorda ancora che questo file è in formato ASCII e che l'utente con un qualsiasi editor può effettuare le modifiche che ritiene opportune.


Utilità

Posizione menu a tendina

Toolbar

Questa toolbar contiene una serie di comandi di utilità per il disegno topografico i quali permettono di risolvere alcune problematiche tipiche che si registrano nei disegni topografici.


OSNAP:Int-Pickbox:4

Nome Comando al Prompt: _APERTURE

Bottone che imposta la variabili _APERTURE = 8 e PICKBOX =4 ed infine il modo di osnap INT fisso.


OSNAP:Nod-Aperture:4

Nome Comando al Prompt: _APERTURE

Bottone che imposta la variabili _APERTURE = 8 e PICKBOX =4 ed infine il modo di osnap NODO fisso (è' utile quando si disegnano le linee di vincolo per la generazione del modello a falde triangolari).


Disegna barbette

Nome Comando al Prompt: BARBE

Il comando permette di disegnare la rappresentazione grafica delle scarpate.
Date due POLILINEE o SPLINE, rappresentanti il limite superiore ed inferiore di una scarpata, ne disegna le barbette come mostrato nella figura.

Il comando apre il seguente box di dialogo, attraverso il quale si possono indicare i parametri che gestiscono il disegno.

È possibile definire la distanza tra le barbe e tra loro e il limite, indicando dei valori in millimetri stampati (dipende dai parametri di U.d.M. e Scala indicati con il comando IMPOSTA). La lunghezza dei tratti corti è espressa in percentuale, rispetto alla distanza tra le due spline/polilinee.
Attivando il check box 3D, le barbette saranno create come linee 3D.
Dopo aver premuto il bottone OK, il comando chiede prima la linea da cui iniziano le barbe e poi la linea limite.

Nota importante: In AutoCAD vi è differenza fra le POLILINEE-SPLINE e le SPLINE:
- POLILINEE-SPLINE: polilinee con più vertici smussati attraverso l'utilizzo del comando _PEDIT (opzione _S);
- SPLINE: oggetti generati con il comando SPLINE (Curve NURBS).
Per un errore di programmazione di AutoCAD non è possibile applicare il comando BARBE di CADPak alle POLILINEE-SPLINE ma solo alle SPLINE. Selezionando una POLILINEA-SPLINE appare quindi il seguente box di richiesta:

Premendo il bottone Sì, le POLILINEE-SPLINE saranno convertite in SPLINE.


Cancella barbette

Nome Comando al Prompt: BARBE_C

Comando che permette di cancellare le barbette generate con il comando BARBE selezionandone una soltanto.


Progressiva su polilinea

Nome Comando al Prompt: PROGPOLY

Comando che serve per individuare delle progressive su linee, polilinee, archi e spline, digitando le distanze da tastiera.

Il comando chiede di selezionale la linea, polilinea, arco, spline e quindi di digitare da tastiera le progressive che si intendono individuare sull'oggetto selezionato.
Dopo aver selezionato la polilinea in esame, il comando apre il dialog box con il quale si ha la possibilità di selezionare o meno la visualizzazione del testo, inoltre si possono scegliere il Layer e la lunghezza delle linee di sezione.

Nel box Proprietà del Testo si ha la possibilità di fissare l'Altezza testo in millimetri, il Layer per il testo, lo Stile del testo, il numero di Decimali. Il Fattore di scala che è un fattore moltiplicativo delle distanze soltanto ai fini del disegno dei testi; ad esempio se si forniscono le distanze in metri e si vuole che CADPak scriva i testi in metri il fattore di scala dovrà essere uguale a 1000.

Nella parte in basso dei box vengono riportate le unità di misura e scala correntemente impostate con il comando IMPOSTA (vedi) di CADPak.

Le due opzioni riportate a fianco servono per poter esprimere le progressive in millimetri (cioè in dipendenza delle scelte effettuate nel comando IMPOSTA) oppure in unità correnti di AutoCAD, che l'utente avrà cura di far coincidere con quelle di AutoCAD, come ad esempio 1 Unità di disegno di AutoCAD = 1 Metro.


Visualizza vertici

Nome Comando al Prompt: DDMK_INVP

Il comando permette di visualizzare/individuare con dei markers (Virtuale) sensibili al comando RIDIS o RIGEN oppure con degli oggetti punto (Punti) i punti di inizio e fine di linee e polilinee. E' utile per individuare i vertici di polilinee quando essi non sono evidenti. Lanciando questo comando appare il box di dialogo con il quale si può scegliere se visualizzare soltanto dei markers oppure se si vogliono degli oggetti punto (sul layer corrente), la loro dimensione differenziando per colori diversi i vertici di linee o polilinee.


Suddividere polilinea

Nome Comando al Prompt: DIVBLK

Permette di inserire una serie di blocchi lungo una linea/polilinea/arco, utilizzando un blocco presente nel disegno corrente. E' possibile definire la distanza fra i blocchi in millimetri stampati oppure in unità di AutoCAD. Nel riquadro Blocco si può scegliere il nome del blocco da utilizzare e su quale Layer deve essere inserita la serie di blocchi ed inoltre il fattore di ingrandimento del blocco (Valore); il bottone Dimscale imposta automaticamente il relativo valore. Ruota blocchi, se abilitato, forza la rotazione del blocco in modo da assecondare la curvatura di cerchi, archi, spline etc; Inizio e Fine se abilitato inserirà un blocco all'inizio e uno alla fine della linea/polilinea. Il comando chiede dapprima di selezionare la polilinea (o altro) e poi visualizza il box di dialogo mostrato qui a fianco.


Sposta testo ortogonalmente e linea

Nome Comando al Prompt: INLI

Permette di riportare tutti i testi selezionati, su una linea in modo ortogonale e rispetto al punto di inserimento dei testi selezionati. Si possono selezionare entità in generale con i soliti sistemi di AutoCAD. Se nella fase di selezione dei testi da spostare si utilizzano delle finestre comprendenti anche altre entità, ai fini dell'esecuzione di questo comando saranno considerati soltanto i testi.
Esempio:
Si esegua lo spostamento dei testi rispetto alla linea della figura seguente:

Command: INLI (Invio)
Selezionare la linea: (Selezionare S1)
Selezionare oggetti:
Select objects: (Selezionare i testi in S2, S3, S4, S5 oppure anche con finestre di selezione)
4 Entità spostate.
Command:


Taglia linee su cerchi

Nome Comando al Prompt: RIDLC

Permette il taglio di tutte le linee che iniziano o finiscono in un punto interno ad un cerchio. Il taglio viene eseguito al limite del cerchio. Può servire per il taglio delle linee prima di un punto rilevato e/o di una stazione in un piano quotato. Per disegni molto estesi si possono specificare delle finestre di ricerca suddivise in X e Y. Per la modifica del raggio del cerchio, al fine di impostare la distanza di taglio voluta si veda il comando CHGRC. Selez. cerchi su layer consente di forzare CADPak ad utilizzare come limiti di taglio i cerchi appartenenti ad un layer particolare, tralasciando gli altri. Selez. Linee su layer serve per far sì che CADPak agisca soltanto sulle linee appartenenti ad un particolare layer omettendo le altre. Se queste due opzioni vengono disabilitate il comando agisce su tutti i cerchi e tutte le linee del disegno.

Esempio:
Si esegua il taglio sui cerchi che individuano i punti di unione delle linee (vedi figura). Si veda che nel punto 16 il taglio non è corretto. Ciò è dovuto dal fatto che la linea L1 non è composta da due segmenti che terminano nel punto 16, ma da un unico segmento che termina nel punto 15. Nella situazione finale presentata nella figura che segue i cerchi non sono visibili in quanto eliminati.


Progetta oggetti su un piano

Nome Comando al Prompt: SZE

Questo comando serve per stirare entità (punti, blocchi, cerchi, testi, linee, polilinee, 3D faccia), dallo spazio 3D su di un piano XY la cui quota viene stabilita dall'utente. In altre parole, data ad esempio una polilinea 3D o una linea i cui vertici abbiano le coordinate Z diverse, è possibile ridurre tutti i vertici alla stessa coordinata Z (es. Z= 0). Tipicamente questa situazione si verifica quando si restituisce un rilievo utilizzando il comando linea con il modo di osnap nodo inserito in modo che si ottengono delle linee/polilinee nello spazio tridimensionale. Questo comando permette di proiettare tutte le linee/polilinee del rilievo oppure soltanto quelle che giacciono su di un layer particolare (vedi riquadro Layer) nel piano XY a quota stabilita nel box Quota base. Il riquadro Selezione entità permette di deliberare su quali entità AutoCAD il comando debba agire. Premendo il bottone OK il software chiede di selezionare gli oggetti (con un metodo qualsiasi di AutoCAD)


Parametratura

Nome Comando al Prompt: PARAM

Con questo comando è possibile introdurre una parametratura con dei riferimenti personalizzati (blocchi). L'utente ha la facoltà di scegliere il Layer… di inserimento, gli Intervalli e se l'intera parametratura deve diventare un unico blocco (Blocco parametrizzazione attivato) oppure deve essere un insieme di blocchi separati. Lanciando PARAM appare il box di dialogo riportato nella figura nel quale è possibile decidere il passo nelle due direzioni ortogonali x e y. Il nome del blocco viene imposto attraverso l'intervento nel file testo C:\CADPAK\CADPAK1.VAR; di default il nome è TPAR1.DWG ed è contenuto nella directory di CADPak. Quando si preme OK in questo box verrà chiesto di specificare due punti ai vertici estremi di un rettangolo all'interno del quale si vuole ottenere la parametratura; la dimensione del rettangolo sarà indicativa, dato che per effetto dell'arrotondamento dovuto al valore dell'intervallo/i il software lo adatterà.
Per default, CADPak provvede ad ampliare in eccesso la parametratura rispetto al rettangolo definito originariamente dall'utente. Il blocco che CADPak usa per il disegno dei parametri può essere modificato dall'utente a patto che contenga almeno due definizioni di attributo qualsiasi.

Le variabili globali che interessano questo comando sono contenute nel file TOPak1.var e sono le seguenti:
(TP7410 "TPAR1")  ;Nome del blocco per i parametri
(TP7411 "18")     ;Nome layer per il blocco in CP7418
(TP7412 50.0)     ;Intervallo X
(TP7413 50.0)     ;Intervallo Y
(TP7414 1)        ;Creare un blocco della parametrizz. 0=No, 1=Si
(TP7415 "PA")     ;Prefisso blocco

Preparazione del blocco di parametrizzazione:
La preparazione del blocco deve essere fatta secondo la seguente procedura:
1. Entrare in CADPak ed impostare Udm = mm Scala 1 : 1 con il comando IMPOSTA.
2. Quando in un disegno si inserirà la parametratura, il blocco che si sta definendo adesso verrà scalato automaticamente in funzione dei valori correnti di Udm e Scala, per questo motivo dovrà essere disegnato in modo tale che una unità di disegno corrisponda ad un millimetro stampato; ad esempio se si desidera che le due lineette che si incrociano abbiano le dimensioni di 10 mm dovranno essere disegnate di 10 unità di disegno (considerazione valida per testi ed attributi).
3. Inserire gli attributi X ed Y.
4. Il colore delle entità può essere qualunque, ma si consiglia il colore DABLOCCO.
5. Utilizzare il comando _BASE per definire il punto di inserimento.
6. Salvare il file con il nome specificato nella variabile globale CP7410 (vedi file TOPAK1.VAR); il default è TPAR1.DWG.


Correzione vettoriale

Nome Comando al Prompt: CVL

Il comando permette l'adattamento delle mappe su una planimetria di rilievo.
Per il funzionamento è necessario avere due punti battuti che compaiano anche sulla mappa.

Esempio:
Comando:  CVL
Selezionare le linee da correggere      (Selezionare l'intera mappa)
Sezionare oggetti:         (Invio)
Punto fisso:         (Selezionare il punto 1)
Punto errato:         (Selezionare il punto 2)
Punto corretto:         (Selezionare il punto 3)
Elaborazione... 33/33razione... 1/33
Comando:


Sposta attributi

Nome Comando al Prompt: _ATTMOVE

Comando di CADPak (vedasi CADUtility) che permette di spostare gli attributi dei blocchi inseriti nel disegno. Basta digitare il comando, selezionare gli attributi ed indicarne il punto base e il punto finale dello spostamento.
Esempio:


Rototraslazione metodo minimi quadrati

Nome Comando al Prompt: TRANSFORMRTMIN

Attraverso il seguente comando è possibile eseguire una rototraslazione degli oggetti (tipicamente una mappa o un rilievo) facendo riferimento ad un certo numero di punti (minimo tre) di cui se ne conosce la posizione. Il comando eseguirà la trasformazione (cioè riposizionerà i punti e gli oggetti) riducendo l'errore attraverso la minimizzazione dello scarto quadratico medio (secondo le note formule statistiche della teoria degli errori).
Il comando chiederà il 1° punto errato e poi la sua posizione corretta, successivamente il 2° e così via per il numero di punti a discrezione dell'utente (si noti che più punti di riferimento si utilizzano più l'errore in termini di scarto quadratico medio diminuisce, secondo la teoria degli errori in maniera inversamente esponenziale). Terminato di inserire i punti con Invio si prosegue nel comando: il software chiederà se si desidera posizionare i punti nel disegno(cioè visualizzare la posizione dei nuovi punti in base alla elaborazione, che differiranno dai riferimenti per via dell'approssimazione), se eseguire la trasformazione considerando il fattore di scala, di selezionare gli oggetti che si voglio trasformare, se farne una copia. Rispondendo negativamente a questa domanda il software eseguirà la trasformazione degli oggetti selezionati e terminerà il comando. In caso invece di risposta positiva alla domanda se si desidera eseguire una copia degli oggetti, il software chiederà ancora se si desidera eseguire il cambio layer ed in caso di risposta affermativa se tale cambio va eseguito sugli oggetti originali.

Nota: la trasformazione applicata ad oggetti vettoriali sarà rigida cioè senza deformazione degli oggetti stessi che manterranno le dimensioni e forma originali, mentre se la si applica ad oggetti di tipo raster produrrà una deformazione degli stessi attraverso la modifica dei fattori di scala in x e y.

Il software scrive nella finestra di dialogo di AutoCAD (attivabile con F2) un riassunto dell'elaborazione con i dati di riferimento, come quello sotto riportato.

---------------------------------------
   Parametri della trasformazione
---------------------------------------
Rotazione rad/deg.: 0.12221500 / 7.00240372
Traslazione.......: X=-103.290450 Y=57.301507
Sqm...............: 8198.65164749 - 2.84366644
---------------------------------------
      Differenze di lunghezza
Punto       Delta l        Delta L
---------------------------------------
   1        51.1570         0.7155
   2        53.4716         0.6784
   3        52.1766         1.3680
---------------------------------------
        Coordinate finali
---------------------------------------
Punto          X             Y
   1        53.3680       -19.3179
   2        46.9939       -42.5865
   3        47.9979       -30.0085
---------------------------------------


Attributi visibili/invisibili

Nome Comando al Prompt: CHGATTVIS

Comando di CADPak che permette di rendere visibili o meno uno o più attributi del blocco indicato attraverso il pulsante Blocco. Sono consentiti tre tipi di selezione: Seleziona< Selezione manuale con finestra
Sel. Precedente Ripete l'ultima selezione effettuata
Sel. Tutto Selezione automatica di tutto il dwg
E' possibile attivare un filtro sui Layer. Una volta premuto OK, si apre un box di dialogo attraverso il quale è possibile selezionare e/o deselezionare gli attributi che si vogliono rendere visibili/invisibili.

Con il pulsante Applica si rendono visibili le modifiche, con OK si ottiene lo stesso risultato e si chiude il comando
Per ulteriori delucidazioni si rimanda al capitolo CADUtility toolbar Blocchi \ Attributi.


Visualizza/modifica file di testo

Nome Comando al Prompt: TRANSFORMRTM

E' l'editor interno di CADPak che consente di aprire, modificare, stampare i file ASCII.

Cliccando su questa casella si manda in esecuzione l'editor interno di CADPak; attraverso il box che compare è possibile selezionare la directory ed il file da editare.
Una volta selezionato il file desiderato e premuto OK apparirà l'Editor.

I comandi di gestione dell'Editor sono i tasti freccia e i tasti Pagina Su/Pagina Giù della tastiera. Attraverso il menu a tendina, è possibile modificare il file.


Modulo di calcolo dei calcolo volumi

Posizione menu a tendina

Questa voce di menù, priva di toolbar, lancia l'applicazione Cave che permette di elaborare delle analisi di movimentazione attraverso il confronto tra due modelli (o un modello ed un piano) del terreno.
Risulta possibile elaborare l'analisi sui modelli a falde triangolari precedentemente salvati (vedasi toolbar triangoli) e disegnare in AutoCAD il modello iniziale, quello di riferimento e quello ottenuto dalla sovrapposizione dei due (Modello di confronto).


Cosa fa

Il modulo di calcolo dei volumi serve per fare il calcolo del volume compreso fra un modello a falde triangolari ed una superficie di riferimento, che può essere un piano orizzontale, un piano inclinato oppure un altro modello a falde triangolari.

Una volta definita la superficie di cui si vuole ottenere il calcolo (solitamente la superficie di progetto) e la superficie di riferimento, CADPak calcola le superfici ed i volumi di scavo e riporto, fornendo il dettaglio triangolo per triangolo, oltre che i valori totali. Inoltre elabora il modello differenza a falde triangolari utilizzando le quote rosse.
Il modulo di calcolo dei volumi può disegnare i modelli a falde triangolari numerando i triangoli e colorandoli a discrezione dell'utente e per il modello differenza (quote rosse) colora i triangoli con colori diversi a seconda che siano in sterro, riporto, oppure a movimentazione nulla.
Le sezioni e le curve di livello possono essere ottenute utilizzando le normali procedure topografiche di CADPak.
Facendo le curve di livello sul modello basato sulle quote rosse si ottengono le isolinee di scavo/riporto; ossia si individua precisamente dove e quanto si è scavato o riportato.
Facendo le sezioni sul modello basato sulle quote rosse si ottengono inoltre dei grafici di scavo/riporto.


Dati di partenza

Il programma effettua il calcolo su modelli a falde triangolari elaborati con il modulo topografico di CADPak e salvati con il comando TrigonTrSave. Questo comando genera dei files di testo contenenti i modelli su cui si vogliono effettuare i calcoli.


Risultati

- Un file di testo con il calcolo dettagliato triangolo per triangoli di superfici e volumi
- Un file di testo con i risultati totali si superfici e volumi
- Un file di testo con le superfici dettagliate triangolo per triangolo 2D/3D del Modello da calcolare
- Un file di testo con le superfici triangolo per triangolo 2D/3D del Modello di riferimento (superficie di riferimento generica)
- Il disegno delle falde triangolari, numerate, del modello di calcolo
- Il disegno delle falde triangolari, numerate, del modello di riferimento
- Il disegno delle falde triangolari, distinte per colore e layer in funzione del tipo (scavo, riporto, movimentazione nulla).
Nel box principale del modulo vi sono due pulsanti (Info modello) che servono per visualizzare, modificare e stampare i due file di testo che contengono il calcolo delle superfici dettagliate triangolo per triangolo dei modelli.


Come funziona

Il calcolo si basa sulla sovrapposizione di coppie di triangoli, ciascuna coppia è formata da un triangolo del modello di riferimento ed un triangolo del modello di progetto. Se il riferimento, invece di un modello, è un piano, i due triangoli avranno la stessa proiezione nel piano XY: cioè le coordinate XY dei vertici identiche, ma le Z diverse.

Il programma analizza tutto il modello esaminando una coppia di triangoli alla volta e valutando per ciascuna di esse i valori di volume e di superficie. La determinazione di questi valori avviene scomponendo in triangoli "secondari" il poligono derivante dalla sovrapposizione dei triangoli, come mostrato nella figura.
Per ogni coppia di triangoli è calcolato il dettaglio di superfici e volumi, che viene poi scritto nella tabella che può essere visualizzata premendo il bottone come indicato nella figura seguente.


Modelli a falde triangolari

1. Lanciare CADPak e generare i due modelli da confrontare utilizzando i comandi del modulo CADPak.
2. Salvare i due modelli con il comando TrigonTrSave facendo attenzione a fare sì che i due modelli utilizzino il medesimo sistema di riferimento cioè abbiano la stessa origine, come mostrato nella figura seguente

3. Iniziare un nuovo disegno e lanciare il modulo di calcolo dei volumi scegliendo Topografia … Calcolo volumi oppure digitando newcave alla riga di comando di AutoCAD. Effettuare l'elaborazione numerica di superfici e volumi e, inoltre, l'elaborazione grafica dei due modelli con i triangoli numerati con il modello differenza a falde colorate (vedi quì di seguito).

Nota: i modelli possono anche non avere lo stesso perimetro: vengono calcolate le superfici ed i volumi esclusivamente nella zona di sovrapposizione dei due modelli

3.1 Scegliere il modello da calcolare

3.2 Scegliere "La superficie di riferimento è un modello a triangoli" come mostrato nella seguente figura

3.2 Premere il bottone "Calcola volumi" per eseguire il calcolo dei volumi

3.3 Disegnare il modello da calcolare con la numerazione dei singoli triangoli.

3.4 Disegnare il modello di riferimento con la numerazione dei singoli triangoli.

3.5 Disegnare il modello di differenza, cioè il modello basato sulle quote rosse.


Modello e piano di riferimento

1. Lanciare CADPak e generare il modello da confrontare utilizzando i comando del modulo topografico.
2. Salvare il modello con il comando TrigonTrSave.

3. Iniziare un nuovo disegno e lanciare il modulo di calcolo dei volumi scegliendo Topografia ...Calcolo volumi oppure digitando NewCave alla riga di comando di AutoCAD ed effettuare l'elaborazione numerica di superfici e volumi ed inoltre l'elaborazione grafica del modello con i triangoli numerati e con il modello differenza a falde colorate (vedi qui di seguito).

3.1 Scegliere il modello da calcolare

3.2 Impostare la quota del piano di riferimento

3.3 Premere il bottone "Calcola volumi" per eseguire il calcolo dei volumi.

3.4 Disegnare il modello da calcolare con la numerazione dei singoli triangoli.

3.5 Disegnare il modello di differenza, cioè il modello basato sulle quote rosse.


Come preparare i modelli da confrontare

1. Generare con CADPak il piano quotato relativo al modello da calcolare con i punti in 3D e poi fare la stessa cosa per l'eventuale modello di riferimento.
2. Fissare due punti di origine omologhi per i modelli

3. Salvare il modello o i modelli (calcolo e riferimento) utilizzando il comando TrigonTrSave uno alla volta.
4. Lanciare il programma di calcolo dei volumi.


Numerazione singoli triangoli

Dalla fase di calcolo viene prodotta anche una tabella contenente il dettaglio dei calcoli, triangolo per triangolo; si rende necessario quindi poter individuare i triangoli nel disegno.
Una volta effettuato il calcolo, il disegno dei modelli avviene indicando nel disegno, uno alla volta, la posizione in cui inserire il baricentro del modello oppure se si desidera i modelli possono essere disegnati in coordinate originali e quindi sovrapposti e su layers diversi.


Confronto tra modelli

Il modulo cave elabora e disegna il modello basato sulle quote rosse e che rappresenta l'insieme dei triangoli in cui vengono scomposti i poligoni di sovrapposizione dei triangoli come indicato nella figura.

Il modello differenza rappresenta l'entità dei movimenti di terra e se su di esso si disegnano le curve di livello si ottengono le isolinee di scavo o riporto, dove naturalmente la isolinea di quota zero rappresenta la linea di passaggio tra sterro e riporto.


Topografia Procedure

· Restituzione del rilievo
· Come orientare il rilievo
· Piani quotati
· Modellazione a falde triangolari
· DTM
· Carte tematiche - Analisi geomorfologica
· Curve di livello
· Sezioni


Restituzione del rilievo

- Il rilievo dei punti in campagna
- Dal rilievo alla restituzione
- Come stampare i libretti
- Il trattamento del rilievo per chi non ha il registratore dei dati
- Rototraslazione del rilievo


Il rilievo dei punti in campagna

Il rilievo dei punti in campagna

· Si consiglia di assegnare il nome ai punti come consigliato nelle procedure per Pregeo; stazioni 100, 200, 300 … e punti di dettaglio 101, 102, 103….
· Alcune stazioni totali consentono all'operatore di inserire in campagna la dichiarazione delle letture in avanti e indietro; con CADPak la definizione delle poligonali si fa a posteriori, a condizione però che l'operatore in campagna rilevi le battute reciproche fra i punti che ritiene di dover utilizzare come vertici di poligonale.
· Da ogni stazione si deve battere la successiva e la precedente come fossero punti di dettaglio, sarà in un secondo momento che si dovranno specificare i collegamenti fra le stazioni.
· Ad esempio dalla stazione 200 si deve battere un punto di dettaglio che si chiama 300 (stazione avanti) ed anche il punto di dettaglio 100 (stazione indietro).
· Le poligonali non devono incrociarsi! Ad esempio nella figura seguente non dovrebbe esistere la poligonale:

Errata --> 800 700 300 400 500 600

ma al suo posto (all'interno del file *.myt che le compete) dovrebbero esistere :

Corretta --> 300 700 800 900
Corretta --> 300 400 500 600


Dal rilievo alla restituzione

Dal rilievo alla restituzione dei punti nell'editor di AutoCAD.

· Lanciare il comando UniDrv per aprire i file di testo prodotti da uno strumento topografico e convertirli nel formato per CADPak (*.myt). Ad esempio, si supponga di avere un file ottenuto con il software per lo scaricamento dati Geotool che è fornito in dotazione agli strumenti Geotronics/Spectra precision (attuale Trimble); attraverso questo comando si possono trasformare i file in formato JOB in formato MYT adatti a CADPak.
· Lanciare il comando NewPolig per elaborare il file *.MYT ed ottenere oltre ad una serie di libretti, anche il disegno del piano quotato direttamente nell'editor grafico di AutoCAD.

- All'interno del comando NewPolig cliccare sul pulsante Disegna rilievo per visualizzare la finestra di dialogo che permette l'impostazione ed il disegno dei punti


Come stampare i libretti

Come stampare i libretti

Il comando NewPolig oltre a calcolare le coordinate permette la visualizzazione e la stampa dei libretti come mostrato nella figura.


Lista dei libretti

Il comando NewPolig genera i seguenti libretti.

Rilievo.myt         Libretto di campagna originale
Rilievo.log         Registro delle attività e delle anomalie trovate
Rilievo_(1.1).txt         Libretto di campagna con gli azimut originale
Rilievo_(1.2).txt         Libretto di campagna con azimut corretti per trasporto
Rilievo_(1.3).txt         Libretto di campagna con azimut derivati per compensati
Rilievo_(2.1).txt         Libretto delle stazioni
Rilievo_(3.1).txt         Libretto delle poligonali
Rilievo_(4.1).txt         Coordinate cartesiane NON compensate
Rilievo_(4.2).txt         Coordinate cartesiane compensate
Rilievo_(5.1).dat         Libretto delle misure nel formato di Pregeo 7
Rilievo_(5.2).dat          Libretto delle misure nel formato di Pregeo 8
Rilievo_CP(6.1).xyz   Coordinate NON compensate da utilizzare con il comando C2D di CADPak
Rilievo_CP(6.2).xyz   Coordinate compensate da utilizzare con il comando C2D di CADPak

Tra questi libretti, che sono numerati, vi sono i due libretti 5.1 e 5.2 che sono i libretti di Pregeo; questi possono essere importati in forma grafica nell editor di AutoCAD con il comando C2DP (vedi più avanti inn questo manuale).


Il trattamento del rilievo per chi non ha il registratore di dati

Il trattamento del rilievo per chi non ha il registratore di dati

Chi non avesse a disposizione un registratore di dati da collegare allo strumento, potrà inserire il rilievo scrivendo un file di testo (cioè il libretto di campagna) utilizzando il comando Medit.

Questa finestra di dialogo serve per generare o modificare un file di testo con estensione MYT e che è adatto a CADPak e di cui segue un esempio:

<inizio del file>
NEWMYT   à   Indica a CADPak l'inizio dei dati
TITOL Rilievo di prova per Topografia   à   Indica a CADPak il titolo del rilievo
TOLLE           0.05 0.05   à   Tolleranze sulle letture reciproche per distanza e dislivello
TOLLT           0.05 0.05 0.02   à   Tolleranze sulla chiusura Planimetrico, Altimetrico ,Angoli
PUNTI           3   à Linea che indica a CADPak l'inizio dei punti battuti
1000        1      5   1.560     5.6290    96.7275     62.036    1.460
1000        2      5   1.560    10.2170    96.7255     60.581    1.460
. . .
Staz      Punto   Cod   Hs      Azimut     Zenit     Dist. Incl.   Hp
. . .
6000      236      9   1.600    32.1775    91.3440     22.304     1.46
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE   à   Linea che indica a CADPak la fine dei punti battuti
PFISS           1000 0.0 0.0 0.0   à   Coordinate della prima stazione del rilievo – Pfiss Staz x y z
ORIEN           1000 0.0   à   Orientamento della prima stazione – Orien Staz Angolo
POLIG   à   Indica a CADPak che segue una definizione di una poligonale
1000  2000  3000  4000  5000  6000   à   Stazioni che compongono la poligonale
FINE   à   Indica a CADPak che la fine dei dati
<fine del file>

Le righe in grassetto sono obbligatorie e ciascuna viene interpretata da CADPak come un comando (primi 5 caratteri) con i relativi parametri. Ad esempio la riga:

ORIEN 100 0.00

E' interpretata dal programma come l'istruzione per traslare tutto il rilievo di 800 m in quota, cioè a tutte le quote che il programma calcolerà con i dati del file verranno aggiunti 800 metri.
Una volta ottenuto il libretto di campagna in formato MYT (file di testo) lanciare il comando NewPolig per elaborare il file rilievo.myt e ottenere il file rilievo.xyz contenente le coordinate cartesiane dei punti.


Come orientare il rilievo

L'orientamento del rilievo consiste sia nel determinare le coordinate della prima stazione che l'orientamento angolare vero e proprio;
con CADPak esistono tre modi per orientare un rilievo.


Metodo dell'angolo di correzione

1) Metodo dell'angolo di correzione e delle coordinate imposte alla prima stazione

Questo metodo di orientamento prevede di imporre un valore di correzione da applicare a tutti gli azimut letti dalla prima stazione e di imporre le coordinate alla prima stazione.
Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT)
Sintassi:
PFISS <prima stazione> <X stazione> <Y stazione> <Z stazione>
ORIEN <prima stazione> <angolo di correzione>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
ORIEN  100    56.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
L'istruzione PFISS serve, come visto nel punto precedente, per imporre le coordinate della prima stazione
L'istruzione ORIEN serve invece per fare in modo che CADPak aggiunga algebricamente un determinato valore angolare a tutti gli azimut letti dalla prima stazione provocando la rotazione del rilievo a cascata su tutte le stazioni del rilievo.


Metodo dell'azimut imposto

2) Metodo dell'azimut imposto e delle coordinate imposte alla prima stazione

Questo metodo di orientamento prevede di imporre un valore ad una lettura azimutale effettuata dalla prima stazione della prima poligonale del rilievo.
In questo modo CADPak ruota tutto il rilievo di un angolo che risulta dalla differenza tra azimut imposto ed azimut letto realmente.

Angolo di correzione = Azimut Letto – Azimut Imposto

Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT):
Sintassi:
PFISS <prima stazione> <X stazione> <Y stazione> <Z stazione>
AZIMU <prima stazione> <punto letto> <azimut imposto>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
AZIMU  100     102      156.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------


Apertura a terra su due punti noti

3) Apertura a terra plaminetrica su due punti di coordinate note

CASO A
Sono state fatte entrambe le letture complete (Azimut, Zenit, Distanza) con lo strumento.
Come indicato nell esempio si devono aggiungere due righe nel file myt (libretto di campagna)
inserendo in questo modo le coordinate dei punti noti; si evidenzia il fatto che i punti noti devono essere
presenti, con lo stesso nome, anche nella lista dei punti battuti.

Questo metodo di orientamento prevede la conoscenza di due punti di coordinate note battuti dalla prima stazione.
Questa istruzione si può dare aggiungendo nel file MYT, due righe come la seguente:

Sintassi:
PNOTO <prima stazione> <punto battuto> <X punto> <Y punto> <Z punto>

Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS     100      0.000      0.000        856.323
PNOTO     100      125      -82.38972      -76.25983       213.000
PNOTO     100      126      -73.51726      -76.70539     -1000.000
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------

Per imporre la quota della prima stazione del rilievo si può utilizzare il comando PFISS come nella riga dell'esempio:
PFISS     100      0.000      0.000    856.323
In questo modo il programma calcolerà le coordinate planimetriche riferendosi ai due punti noti e le quote verranno calcolate partendo dal fatto che la prima stazione del rilievo è a quota 856.323.
Nota importante:
Se si fa stazione su uno dei due punti di coordinate note di deve utilizzare il metodo dell'imposizione di azimut come nel seguente esempio (si è fatta stazione sul punto 100 e si è collimato il punto 124):
AZIMU   100    124        123.3266
PFISS   100   -154.97245   98.42561   723.3265    (coordinate della stazione)
Il comando NewPolig calcola le coordinare cartesiane dei punti di rilievo.
Se il calcolo avviene nell'ambito di una poligonale chiusa o vincolata le coordinate dei punti si distinguono tra compensate e non compensate; infatti i punti battuti da una stazione le cui coordinate sono compensate avranno coordinate compensate, in altre parole per ogni punto si avranno due terne di coordinate X,Y,Z (non compensate) e Xc,Yc,Zc (compensate).

CASO B
Sono state fatte entrambe le letture di cui una completa e l'altra con la sola lettura Azimutale.
Anche in questo caso, come indicato nell esempio si devono aggiungere due righe nel file myt (libretto di campagna)
inserendo in questo modo le coordinate dei punti noti; si evidenzia il fatto che i punti noti devono essere
presenti, con lo stesso nome, anche nella lista dei punti battuti.

Nota importante:
Se la quota di uno dei due punto noti non è conosiuta o semplicemente non
la si vuole usare nei calcoli la si deve omettere oppure inserire come -1000.000, così
come mostrato nell'esempio.


Piani quotati

- Disegnare piani quotati, partendo da file di coordinate cartesiane, materializzando i punti con dei point di AutoCAD
- Come aggiungere nuovi singoli punti ad un piano quotato esistente
- Come aggiungere i testi di quota e nome a dei punti presenti del disegno
- Disegnare piani quotati sotto forma di blocchi con attributo da file di coordinate cartesiane
- Cambiare l'altezza, la posizione o la rotazione dei testi in un piano quotato già disegnato
- Cambiare altezza, stile, larghezza, layer e rotazione dei testi in un piano quotato copiando il formato da altri testi presenti nel disegno
- Cambiare le quote dei punti aggiornando anche i testi delle quote già presenti a video
- Aggiungere punti ad un piano quotato nel disegno interpolando la quota fra altri punti
- Ottenere un piano quotato partendo da polilinee "in quota"
- Ricavare un piano quotato da una carta tecnica in formato Raster
- Estrazione di coordinate dal disegno in un file di testo


Disegnare piani quotati, partendo da file di coordinate cartesiane, materializzando i punti con dei point di AutoCAD

Disegnare piani quotati, partendo da file di coordinate cartesiane, materializzando i punti con dei point di AutoCAD

- Prima di tutto si deve avere un file ASCII di partenza con le coordinate cartesiane dei punti, contenente tante righe quanti sono i punti da rappresentare.
Tali righe possono essere suddivise in tre, quattro o cinque parti (campi) secondo uno dei seguenti formati:

Significato delle lettere N, X, Y, Z, Layer:

Il carattere separatore fra i campi di ciascuna riga può essere lo spazio (uno o più spazi) oppure il carattere virgola.
Nel campo "Layer" si può introdurre una stringa che deve sottostare alle regole per la nomenclatura dei layer di AutoCAD (caratteri vietati: * ? . ; :).
Per ottenere tale file testo è possibile percorrere una delle seguenti strade:
1) Digitare manualmente le coordinate con un editor qualsiasi.
2) Esportando in un file ASCII le coordinate cartesiane da un altro programma, in questo caso si dovrebbe chiedere all'azienda produttrice del programma eventuali delucidazioni, magari inviando copia della presente pagina.
3) Elaborando i dati di campagna con TOPak Comando: NewPolig, si ottiene il file testo già pronto.
Nella directory C:\CADPAK\UTIPAK esiste un file di esempio di nome RILIEVO.XYZ.
NB: Se il primo carattere di una riga del file è un punto e virgola ";", essa viene ignorata ai fini del disegno. Così facendo si possono inserire dei commenti.
Digitare IMPOSTA sulla riga di comando oppure cliccare sul bottone mostrato nella figura
Impostare le unità di misura a metri e la scala opportuna per il rilievo (scala delle lunghezze).

- Lanciare CADPak e digitare C2D
In questo modo apparirà a video un box di dialogo tramite il quale si ha la facoltà di impostare una serie di parametri del disegno, come ad esempio la scala, l'altezza dei testi in millimetri stampati, il tipo di file dati da cui si attinge e così via.
Dopo aver effettuato le scelte opportune nel box, cliccare sul bottone OK ed a video comparirà il disegno del piano quotato (eventualmente utilizzare lo Zoom estensione).
Importante! Se il piano quotato serve per generare le curve di livello è necessario attivare l'opzione Punti 3D nel riquadro di dialogo di quest'ultimo comando.
NB: Nel file testo TOPAK1.VAR contenuto nella directory di CADPak, vi sono le variabili globali che regolano sia i valori di default per la finestra di dialogo del comando C2D, che ulteriori parametri per il disegno. Le variabili globali interessate sono quelle comprese fra TP1000 e TP1083.


Come aggiungere nuovi punti ad un piano quotato esistente

Come aggiungere nuovi punti ad un piano quotato esistente

Il comando che assolve a questo scopo è CP_PUNTO.

Questo comando presenta il seguente messaggio sul prompt dei comandi con il quale chiede di specificare la posizione del punto:

Coordinate-posizione punto o [Box/Selezione punti]:

scegliendo l'opzione B visualizza una finestra di dialogo in cui si possono determinare i parametri per l'inserimento di nuovi punti.

Le scelte effettuate in questa finestra di dialogo sono adatte al caso in cui si intendono aggiungere nuovi punti definendo la posizione XY con il mouse e la quota la si vuole digitare con la tastiera.


Come aggiungere i testi di quota e nome a dei punti presenti del disegno

Come aggiungere i testi di quota e nome a dei punti presenti del disegno

Il comando che assolve a questo scopo è CP_PUNTO come nel caso precedente ma con delle modalità leggermente diverse.

L'utilizzo del comando passa attraverso le seguenti fasi
1) Lanciare il comando e fare le stesse scelte fatte nella figura e premere OK
2) Alla domanda che segue
Coordinate-posizione punto o [Box/Selezione punti]:
scegliere l'opzione Selezione Punti attivabile con la lettera chiave S
3) Selezionare i punti presenti nel disegno


Disegnare piani quotati sotto forma di blocchi con attributo da file di coordinate cartesiane

Disegnare piani quotati sotto forma di blocchi con attributo da file di coordinate cartesiane

Il meccanismo è simile al caso appena visto, con la variante che l'utente dovrebbe definirsi il blocco personalizzato (vedasi il blocco di esempio PUNTI.DWG nella cartella di CADPak) con relativi attributi.
Si utilizza poi il comando C2D nel seguente modo:

Si possono definire quali attributi debbano rappresentare che cosa.
Nel caso della figura si è deciso che l'attributo QUOTA debba reppresentare la quota, che l'attributo NOME debba rappresentare il nome del punto, l'attributo COD rappresenti il codice descrittivo ed infine l'attributo DESC la descrizione del punto. Si vedano le variabili globali TP0050 fino a TP0055 nel file TOPak1.var per la definizione del default degli attributi da utilizzare.

E' possibile controllare la visibilità dei vari attributi con il comando CHGATTVIS che si trova nella toolbar Attributi.


Cambiare l'altezza, la posizione o la rotazione dei testi in un piano quotato già disegnato

Cambiare l'altezza, la posizione o la rotazione dei testi in un piano quotato già disegnato

Se si vogliono effettuare delle modifiche "a monte", cioè prima di disegnare il piano quotato, e fare in modo che queste diventino permanenti (cioè il nuovo default) è necessario modificare le variabili globali da TP1051 a TP1083 nel file TOPAK1.VAR che si trova nella cartella di installazione di CADPak.
Se invece si vogliono modificare i testi dopo averli già inseriti ed "accomodati" nel disegno si può utilizzare il comando CHGTXT che consente di ruotare, spostare, cambiare l'altezza in millimetri in funzione della scala impostata dal comando "Imposta" ed inoltre di sommare un certo numero a dei testi numerici.


Cambiare altezza, stile, larghezza, layer e rotazione dei testi in un piano quotato copiando il formato da altri testi presenti nel disegno

Cambiare altezza, stile, larghezza, layer e rotazione dei testi in un piano quotato copiando il formato da altri testi presenti nel disegno

Si immagini di avere un gruppo di testi A che hanno delle caratteristiche corrette ed avere un secondo gruppo di testi B con caratteristiche indesiderate; il comando TXTLTXT (vedi figura) consente di copiare il formato di un testo su un gruppo di altri testi, diversificando per altezza, stile, layer etc.


Cambiare le quote dei punti aggiornando anche i testi delle quote già presenti a video

Cambiare le quote dei punti aggiornando anche i testi delle quote già presenti a video

Questa operazione implica due azione:

1) Spostare fisicamente gli oggetti lungo l'asse Z -->Utilizzare il comando Z-MOVE
2) Aggiornare i testi con le quote dei punti --> Utilizzare il comando CHGTXT

Per cambiare l'elevazione degli oggetti Punto che materializzano i punti del piano quotato, si utilizza il comando Z-MOVE (vedi figura) oppure il comando Sposta di AutoCAD standard, utilizzando come punto di partenza quello di coordinate 0,0,0 e quello di arrivo 0,0,Dz con Dz = valore dello spostamento.
Per aggiornare anche i valori dei testi che rappresentano le quote occorre utilizzare il comando CHGTXT (vedi figura).

offs nUm.co/Offs x,y/Pre-postfisso/……./Alt./Stile/aNgolo/Incl./Giustif./<scala alt.>: U
Offs nUm.co = offset numerico


Aggiungere punti ad un piano quotato nel disegno interpolando la quota fra altri punti

Aggiungere punti ad un piano quotato nel disegno interpolando la quota fra altri punti

Per inserire dei nuovi punti in un piano quotato interpolando la quota fra altri punti già presenti si può utilizzare il comando PXY che esegue materialmente l'operazione ed eventualmente il comando PxyDat permette di impostare il funzionamento del comando PXY.


Ottenere un piano quotato partendo da polilinee "in quota"

Ottenere un piano quotato partendo da polilinee "in quota"

Tipicamente, si ha questa necessità quando sono state digitalizzate le curve di livello da un raster, e da queste si vuole ottenere un piano quotato al fine di rifare il modello a falde triangolari e quindi la rappresentazione a griglia tridimensionale.

Si veda anche il comando EPM compreso nella toolbar delle curve di livello, che permette l'assegnazione della quota nel caso di polilinee digitalizzate con elevazione zero e che devono diventare curve di livello in 3D.


Ricavare un piano quotato da una carta tecnica in formato Raster

Ricavare un piano quotato da una carta tecnica in formato Raster

In alcune situazioni si ha a disposizione un'immagine raster del territorio da cui si intende ricavare un modello a triangoli o a maglia quadrata, per farne un'analisi altimetrica o cliviometrica, oppure ottenere in AutoCAD delle curve di livello più fitte delle originali.
Di seguito, è indicata la strada più breve per fare in modo che da un'immagine Raster a curve di livello, si riesca a ricostruire il piano quotato sotto forma di punti e quote, per eseguire poi le operazioni appena menzionate.
- Dal menu INSERISCI di AutoCAD scegliere IMMAGINE RASTER. Cliccare sul bottone ATTACCA e selezionare l'immagine per inserire la carta tecnica.
- Dopo averla inserita è necessario che essa venga ingrandita o rimpiccolita, in modo tale che una unità di lunghezza in AutoCAD corrisponda ad un metro sul terreno.
- Digitalizzare le linee di livello della zona di interesse con delle polilinee 2D.
- Staccare il raster: dal menu INSERISCI di AutoCAD scegliere GESTIONE IMMAGINI e dopo aver selezionato il raster premere STACCA
- Elevare le curve di livello digitalizzate, con il comando EPM
- Il comando DDMK_INVP, posiziona dei punti in corrispondenza dei vertici delle polilinee

Premere OK e selezionare le polilinee d'interesse.
In questo modo si ottengono dei punti in 3D sui quali si può sviluppare il modello a falde triangolari, la maglia quadrata, le curve di livello, le sezioni etc.
I punti così ottenuti possono essere esportati utilizzando il comando EXPDAT come indicato di seguito.


Estrazione di coordinate dal disegno in un file di testo.

Estrazione di coordinate dal disegno in un file di testo.

E' possibile estrarre le coordinate della posizione di punti, linee, polilinee, blocchi, testi, in un file ASCII. Questa possibilità è utile quando da un disegno s'intendono ricavare le coordinate dei punti per operazioni di tracciamento con una stazione totale. E' possibile inoltre convertire questi file di estrazione, nel formato proprio degli strumenti topografici (es. Wild, Topcon, Geotronics, ecc.).
Il comando da utilizzare è EXPDAT, che si può utilizzare anche per estrarre i dati delle sezioni sui punti battuti.


Modellazione a falde triangolari

La modellazione è un processo che genera il modello del terreno, attraverso un'opportuna unione dei punti, formando dei triangoli.
Per definizione, il modello è un oggetto che rappresenta il terreno, su cui, teoricamente, dovrebbe aderire perfettamente.
In realtà si tratta sempre di un'approssimazione, tanto più precisa, quanto più i punti sono rappresentativi e numerosi. Pertanto, la restituzione deve essere effettuata con la massima accuratezza.
Sul modello, se questo è sufficientemente rappresentativo, si possono fare operazioni di analisi altimetrica, cliviometriva e di calcolo dei volumi, con risultati veramente apprezzabili ed aderenti alla realtà.


Definizione delle linee di vincolo

Definizione delle linee di vincolo

Le linee di vincolo possono essere:
Contorni esterni: definiti con il comando 3DPOLI (3DPOLI passanti per i punti) oppure con il comando PLINEA (Polilinee 2D non passanti per i punti) che delimitano esternamente il
modello

Contorni interni: definiti con il comando 3DPOLI (3DPOLI passanti per i punti) che delimitano zone interne al modello ove non si desidera venga sviluppato il modello
Discontinuità: definite con il comando 3DPOLI (3DPOLI passanti per i punti) che descrivono delle direttrici che non devono essere intersecate dai lati dei triangoli (es. ciglio di una rampa).

Nota importante: Se, per varie esigenze, le linee di vincolo sono costruite a pezzi, possono essere unite a formare un unico elemento con il comando POLY_JOIN.


Unire contorni e linee di vincolo quando sono frammentati

Unire contorni e linee di vincolo quando sono frammentati

Non sempre si riesce a chiudere un contorno che delimita un'area dove si vuole elaborare il modello a falde triangolari, con una singola polilinea 3D chiusa.
La situazione più comune è che il contorno sia costituito da due o più polilinee 3D con un vertice in comune. Con il comando POLY_JOIN è possibile unirle ottenendo un'unica polilinea.


Come disegnare il modello a falde triangolari partendo da un piano quotato a punti

Come disegnare il modello a falde triangolari partendo da un piano quotato a punti

Si presuppone che esistano i punti in AutoCAD sotto forma di Punti 3D. La procedura per generare il modello si compone dei seguenti comandi:
- Comando 3DPOLI per disegnare le linee di vincolo, contorni esterni, interni e discontinuità.
- Comando TRIGON per definire le modalità della restituzione e generare il modello a falde triangolari.


Come disegnare il modello a falde triangolari partendo da un piano quotato a blocchi

Come disegnare il modello a falde triangolari partendo da un piano quotato a blocchi

E' possibile materializzare i punti in AutoCAD utilizzando dei blocchi con attributo, dove gli attributi possono rappresentare i valori definiti dalle variabili definite di seguito (TOPak1.var):
(TP0050 "QUOTA") ;nome dell'attributo quota
(TP0051 "NOME")  ;nome dell'attributo nome
(TP0052 "X")     ;nome dell'attributo X
(TP0053 "Y")     ;nome dell'attributo Y
(TP0054 "COD")   ;nome dell'attributo codice
(TP0055 "DESC")  ;nome dell'attributo descrizione

E' possibile

Nella cartella di CADPak vi è un blocco d'esempio PUNTI.DWG che può essere utilizzato nel comando C2D, come mostrato già in precedenza:

E' possibile definire quali attributi debbano rappresentare che cosa.
Nel caso della figura si è deciso che l'attributo QUOTA debba rappresentare la quota, che l'attributo NOME debba rappresentare il nome del punto, l'attributo COD rappresenti il codice descrittivo ed infine l'attributo DESC la descrizione del punto.

Il comando TRIGON utilizza le quote definite negli attributi, se queste non ci sono, utilizza come quota la posizione Z del blocco.


Aggiunta di singoli triangoli al modello

Aggiunta di singoli triangoli al modello

Il comando TRIGONTRADD permette di aggiungere singoli triangoli nel disegno assecondando le impostazioni fatte con il comando TRIGON


Modifica dei triangoli del modello

Modifica dei triangoli del modello

Nel caso in cui, nonostante fossero state inserite sufficienti linee di vincolo, qualche falda triangolare fosse errata è possibile correggere coppie di triangoli con il comando TRIGONTRINV.


Eliminare triangoli dal modello

Eliminare triangoli dal modello

Per eliminare triangoli, é possibile utilizzare il comando CANCELLA di AutoCAD; tuttavia il comando TRIGONTRDEL permette di cancellare i triangoli cliccando nel loro interno anziché selezionando il bordo che potrebbe essere in comune con un altro triangolo e impedire la cancellazione di altri triangoli.


Trasformare falde triangolari da 3DFACCIA a 3DPOLI e viceversa

Trasformare falde triangolari da 3DFACCIA a 3DPOLI e viceversa

Con TOPak i triangoli possono essere rappresentati sia con 3DFACCE che con 3DPOLI.
Con il comando D3F2PLV si possono trasformare le une nelle altre.
Se si vogliono fare le sezioni, basandosi sulle falde triangolari, occorre che queste siano delle 3DPOLI. Avendo triangoli già disegnati come 3DFACCE, con questo comando è possibile immediatamente in polilinee 3D. Le sezioni saranno trattate più avanti, in questo manuale.


Aggiungere dei punti contenuti in un piano definito da tre punti

Aggiungere dei punti contenuti in un piano definito da tre punti

Si immagini di dover aggiungere dei punti complanari ad un triangolo, interni o esterni ad esso.
Il comando PTPLAN richiede di indicare i tre vertici del triangolo (utilizzare modo di Osnap opportuno) e di indicare con il mouse i punti da inserire. Il punto verrà disegnato utilizzando le coordinate XY indicate a video, mentre la coordinata Z sarà calcolata in funzione dei tre punti dati.
Nel caso in cui il punto indicato non sia posto all'interno del triangolo, la sua quota sarà calcolata ugualmente in modo che esso sia complanare al triangolo.

Vedere anche il comando CPPTONDTM spiegato al punto seguente.


Aggiungere dei punti complanari ad un triangolo

Aggiungere dei punti complanari ad un triangolo

Dovendo aggiungere dei punti che debbano giacere sul piano/piani di uno/più triangolo, si può utilizzare il comando CPPTONDTM che chiede di selezionare un modello e di indicare dei punti (X,Y) con il mouse da aggiungere; la coordinata Z di ciascun punto aggiunto verrà calcolata in modo che sia complanare con il triangolo in cui giace.
Se il punto indicato non ricade all'interno di un triangolo, la sua quota sarà zero.

Vedere anche il comando PTPLAN spiegato al punto precedente.


Spostare dei punti o dei blocchi in modo che diventino complanari a dei triangoli

Spostare dei punti o dei blocchi in modo che diventino complanari a dei triangoli

Si immagini di avere un modello a falde triangolari e di voler fare in modo che una serie di punti e/o blocchi vengano spostati in quota in modo che diventino complanari con i triangoli come mostrato nella figura.

Il dialogo del comando è il seguente:
Comando:
Selezionare i triangoli...
Selezionare oggetti: <selezionare i triangoli>
Selezionare oggetti: <invio per terminare la selezione dei triangoli>
Numero di triangoli...: 80
N. Triangoli: 80

Punto [Selezionare oggetti]: S
Selezionare testi/punti/blocchi
Selezionare oggetti: <selezionare i blocchi o gli oggetti che si vogliono spostare>

Vedere anche il comando PTPLAN spiegato al punto precedente.


DTM

- Disegno di una rappresentazione 3D a maglia quadrata partendo dal modello a falde triangolari
- Disegno di una rappresentazione 3D a maglia quadrata partendo da un supporto cartaceo a curve di livello


Disegno di una rappresentazione 3D a maglia quadrata partendo dal modello a falde triangolari

Disegno di una rappresentazione 3D a maglia quadrata partendo dal modello a falde triangolari

Spesso è richiesta una rappresentazione tridimensionale di un terreno rilevato, oppure una situazione di progetto per fare rappresentazioni tipo render.

Per ottenere questo risultato occorre partire dal modello a falde triangolari (vedere il comando TRIGON già esaminato nelle pagine precedenti).
Dopo aver ottenuto i triangoli in AutoCAD si puo elaborare il DTM a maglia quadrata con il comando CPGRID.

Per informazioni dettagliate sul funzionamento del comando CPGRID si rimanda al manuale di riferimento ai comandi.


Disegno di una rappresentazione 3D a maglia quadrata partendo da un supporto cartaceo a curve di livello

Disegno di una rappresentazione 3D a maglia quadrata partendo da un supporto cartaceo a curve di livello

Procedura:
- Acquisizione della carta con uno scanner;
- Digitalizzazione, in AutoCAD oppure con un vettorializzatore automatico, delle curve di livello, in modo che esse diventino delle polilinee; (vedere il comando MKP che si usa nel caso in cui siano linee invece di polilinee).
- In questo modo si ottengono delle polilinee che non sono ancora curve di livello perché non hanno la quota, ma possono diventare tali attraverso il comando EPM di CADPak, come mostrato nella figura seguente.

- Ora è necessario ottenere dei punti (entità punto) che permettano in seguito di sviluppare il modello a falde triangolari. Per raggiungere questo scopo si può utilizzare il comando DDMK_INVP.

- Con il comando TRIGON (vedi toolbar Triangoli) si ottiene il disegno del modello a falde triangolari.

- Con il comando CPGRID si ottiene il disegno del modello a maglia quadrata.


Carte tematiche - Analisi geomorfologica

- Carta altimetrica
- Carta clivometrica
- Carta degli orientamenti
- Carta dell'esposizione


Carta altimetrica

Carta altimetrica

Data la rappresentazione di un terreno attraverso un modello a falde triangolari, o attraverso una maglia quadrata, è possibile fare l'analisi numerica delle facce che discretizzano il terreno in funzione delle quote.
Nella procedura che segue si presuppone di avere già in AutoCAD il modello.

Cliccando su TRIGONCOLOR appare la seguente finestra:

Quando si preme il bottone OK avrà inizio la colorazione del modello e la richiesta del punto di inserimento della legenda.


Carta Clivometrica

Carta clivometrica

In modo analogo alla carta altimetrica è possibile sviluppare la carta clivometrica; i comandi da utilizzare sono gli stessi con la differenza che nel box si dovrà scegliere Pendenza massima.


Carta degli orientamenti

Carta degli orientamenti

Vedere la procedura adottata per la carta altimetrica


Carta dell'esposizione

Carta dell'esposizione

Vedere la procedura adottata per la carta altimetrica


Curve di livello

I comandi per il disegno delle curve di livello sono raggruppati nella seguente toolbar.


Dallo strumento alle curve di livello in sintesi

Dallo strumento alle curve di livello in sintesi

Segue una breve dei passi necessari per arrivare al disegno delle curve di livello partendo dal libretto di campagna.

Passo 1. Dati in formato Strumento (Trimble, Leica, Nikon ecc) ---> UNIDRV ---> Libretto di campagna in formato CADPak (<file>.myt)
Passo 2. Libretto di campagna in formato CADPak (<file>.myt) ---> NEWPOLIG ---> Libretti vari + disegno in AutoCAD (Punti 3D)
Passo 3. Punti 3D in AutoCAD ---> TRIGON ---> Modello a falde triangolari
Passo 4. Modello a falde triangolari ---> TRIGONCL ---> Curve di livello


Linee di livello, significato di Layered e 3D

Linee di livello, significato di Layered e 3D

Solitamente i programmi di topografia generano dei disegni in cui le curve di livello hanno un'elevazione (Z di AutoCAD) pari alla quota che devono rappresentare.
La rappresentazione a curve tridimensionali può causare delle difficoltà nella gestione e nell'editazione del disegno, come ad esempio nell'individuazione di intersezioni con gli snap ad oggetto o nella misura delle distanze e delle aree: inconvenienti ben conosciuti da chi lavora nel settore topografico con AutoCAD.
TOPak permette di aggirare l'ostacolo introducendo un nuovo concetto: le curve possono essere contenute nel piano cartesiano xy (ad elevazione zero) senza perdere l'informazione sulla quota. Questo è possibile facendo in modo che ciascuna curva sia posta su un layer particolare, il cui nome ne rappresenti la quota, seguendo una codifica ben definita.
Esempio:
P0010_50 è il nome del layer che contiene la curva di livello +10.50.
M0025_75 è il nome del layer che contiene la curva di livello -25.75.

Questa codifica, causa ovviamente la generazione di molti layers, che tuttavia possono essere gestiti in serie tramite le funzioni di CADUtility per la gestione dei layers oppure con i comandi di TOPak in CLONOFF per attivare e disattivare e CLDELLYD per cancellare selettivamente soltanto le linee di livello di questo tipo.
Qualora l'utente abbia la necessità di avere le curve in 3D, TOPak permette di trasformare le curve di livello da layered a 3D e viceversa.
Come trasformare delle linee o polilinee in curve di livello con quota
Ci si trova in questa situazione quando le curve di livello sono soltanto linee o polilinee, ma non hanno alcuna informazione relativa alla quota; esse rappresentano le curve di livello soltanto graficamente.
Per assegnare la quota alle linee che ne sono prive si utilizza il comando EPM.


Cambiare il colore e il tipo di linea delle curve di livello

Cambiare il colore e il tipo di linea delle curve di livello

Per cambiare il colore o il tipo di linea delle curve di livello che corrispondono alla codifica Layered oppure 3D, si può utilizzare il comando CLDATCOL.


Smussare le curve di livello sotto forma di polilinee a spigoli

Smussare le curve di livello sotto forma di polilinee a spigoli

E' possibile smussare le curve di livello, e più in generale le polilinee, con il comando SMOOTHMPL. Questo comando asseconda le impostazioni fatte con il comando CURLIV_DAT.


Disegnare le curve di livello per tre punti (caso di punti 2D + testo quota)

Disegnare le curve di livello per tre punti (caso di punti 2D + testo quota)

In questo caso si devono avere a video i punti anche con elevazione nulla e i testi delle quote di ciascun punto.
- Cliccare su CURLIV_DAT e nel riquadro Selezione punti scegliere - 2D + Testo

- Cliccare su CURLIV_T e specificare tre volte la sequenza:
Primo punto: selezionare punto a video
Selezionare il testo: selezionare il testo della quota
Secondo punto: selezionare punto a video
Selezionare il testo: selezionare il testo della quota
Terzo punto: selezionare punto a video
Selezionare il testo: selezionare il testo della quota
Ovviamente i tre punti devono individuare un triangolo!
A conclusione di questa sequenza si ottiene il disegno di linee di livello sulla falda individuata dai tre punti secondo le impostazioni di equidistanza e di colore effettuate con il comando CURLIV_DAT.


Disegnare le curve di livello per tre punti (caso di punti 3D)

Disegnare le curve di livello per tre punti (caso di punti 3D)

- Cliccare su R07,08C01 - CURLIV_DAT e nel riquadro Selezione punti scegliere 3D

- Cliccare su R07C03 - CURLIV_T e specificare tre volte la sequenza:
Primo punto: selezionare punto a video
Secondo punto: selezionare punto a video
Terzo punto: selezionare punto a video
Ovviamente i tre punti devono individuare un triangolo e non essere allineati!
A conclusione di questa sequenza, come avviene nel caso precedente, si ottiene il disegno di linee di livello sulla falda individuata dai tre punti secondo le impostazioni di equidistanza e di colore effettuate con il comando R07,08C01 - CURLIV_DAT.


Trasformare le curve di livello sotto forma di "Linea" in "Polilinea"

Trasformare le curve di livello sotto forma di "Linea" in "Polilinea"

TOPak disegna le curve di livello in polilinee, tuttavia ci si può trovare nella situazione di avere dei rilievi costruiti con altri software che invece disegnano soltanto spezzate di livello con delle linee. TOPak è in grado di unire queste linee a formare delle polilinee con il comando MKP. Si sconsiglia di non selezionare insiemi troppo grandi di linee, per evitare durate eccessive del processo.


Trasformare le curve di livello da Layered a 3D e viceversa

Trasformare le curve di livello da Layered a 3D e viceversa

Il comando per eseguire questa trasformazione è LAY23DLAY.


Disegnare le curve di livello partendo da un modello a falde triangolari

Disegnare le curve di livello partendo da un modello a falde triangolari

La procedura per ottenere il modello è già stata spiegata nelle pagine prededenti; in questo caso si presuppone di avere già il modello a falde triangolari in AutoCAD, dove le falde sono rappresentate con 3DFACCE oppure con 3DPOLI.
- Cliccare su CURLIV_DAT per impostare la modalità di disegno delle linee di livello.
- Cliccare su TRIGONCL Questo comando chiederà di selezionare i triangoli su cui tracciare le curve di livello.


Come inserire le quote delle curve di livello

Come inserire le quote delle curve di livello

Per inserire le quote nelle cirve di livello si utilizza il comando CLOPER che si trova nella toolbar delle sezioni; il conando Cloper permette sia di ricavare i dati per generare le sezioni che per quotare le curve di livello.


Sezioni


Ricavare una sezione da una carta tecnica in formato raster

Ricavare una sezione da una carta tecnica in formato raster

- Dalla barra degli strumenti Gestione Immagini Raster nel menu I&S CAD ->CADUtility ->Gestione Immagini,

utilizzare il comando IMAGEATTACH per inserire il raster nel disegno.
- Digitalizzare le linee di livello della zona/fascia di interesse con delle linee/polilinee 2D
- Assegnare la quota alle curve di livello digitalizzate con il comando EPM
- Tracciare la linea/polilinea di sezione in modo che intersechi le linee di livello digitalizzate
- Cliccare il bottone CLOPER

Copiare le impostazioni dalla figura
- Cliccare su OK, oppure lanciare il comando S2D per ottenere il disegno della sezione, premere sul bottone parametri per verificare la scala di rappresentazione prima di premere OK.


Significato di Raster e Vettoriale

Significato di Raster e Vettoriale

AutoCAD memorizza i suoi disegni scrivendo file contenenti le coordinate cartesiane delle varie entità, punti, linee, archi, cerchi con l'aggiunta delle caratteristiche quali il colore, il tipo di linea e altre informazioni numeriche e non; i disegni memorizzati in questo modo si dicono vettoriali.
Per fare un esempio una linea in AutoCAD è individuata attraverso le coordinate dei suoi vertici, con il suo colore ed il suo tipo di linea.
I disegni in formato Raster invece possono essere assimilati a dei mosaici formati da tessere colorate rettangolari o quadrate, più o meno grandi. Per ogni tessera sono memorizzate le informazioni relative alla posizione nel contesto del mosaico e del colore. Una linea in un file Raster è un insieme di tessere (pixel) più o meno allineate.
AutoCAD è un programma che tipicamente tratta disegni in formato vettoriale, ma, dalla versione 14, riesce anche ad importare nel disegno delle immagini Raster e fare degli interventi limitati su di esse. Notevole è la possibilità di stampare anche un'immagine mista raster/vettoriale; stampa ibrida. Questo è il caso ad esempio di una carta tecnica acquisita con lo scanner ed importata, dopo di che, su di essa, vengano inseriti dei retini in formato vettoriale; vedi carte geologiche, idrogeologiche e tematiche in generale.


Sezioni del terreno sulle curve di livello layered, 2D ed anche 3D

Sezioni del terreno sulle curve di livello layered, 2D ed anche 3D

Premessa.
Il comando S2D legge i numeri generatori da un file di testo e produce il disegno della sezione in AutoCAD.
La parte del file testo contenente i dati della sezione può essere in due diversi formati:

(1° formato)
N DP Q
1 0.00 25.326
2 25.326 28.326
3 12.326 30.326
4 10.547 29.326

(2° formato)
N X Y Y
1 -45.236 15.326 15.32
2 -58.145 8.326 18.326
3 -62.326 12.326 19.641
4 -63.321 10.547 18.987

Dove:

N Nome del picchetto.
DP Distanza fra due picchetti consecutivi.
Q Quota del picchetto di destra.
X Coordinata X.
Y Coordinata Y.
Z Coordinata Z.

Esempio di file testo (CADPak usa l'estesione *.sez per questi file) con i dati nel primo formato n, dp, quota:
1000
Q = ,0.0, m s.l.m.,70,2,ISO,35,4,2
40,10,0,20,12100,20
Scala lunghezze 1:,200," ",100,20,ISO,35,5,0
Scala altezze 1:,100," ",100,30,ISO,35,5,0
1 0.00 25.326
2 25.326 28.326
3 12.326 30.326
4 10.547 29.326

Esempio di file testo (CADPak usa l'estesione *.sez per questi file) con i dati nel secondo formato n, x, y, z:

1000
Q = ,0.0, m s.l.m.,70,2,ISO,35,4,2
40,10,0,20,12
100,20
Scala lunghezze 1:,200," ",100,20,ISO,35,5,0
Scala altezze 1:,100," ",100,30,ISO,35,5,0
1 -45.236 15.326 15.32
2 -58.145 8.326 18.326
3 -62.326 12.326 19.641
4 -63.321 10.547 18.987

Per ottenere il disegno della sezione è necessario partire da un file dati in uno dei due formati possibili.
Trattandosi di un file ASCII, può essere prodotto con qualsiasi editor, oppure derivato da Excel.
Procedura.
- Si parte dal presupposto che esistano a video le curve di livello in modalità layered e cioè che le curve di livello siano 2D oppure anche 3D ma soprattutto che rispondano alla codifica layered.
- Se non fosse così (3D oppure 2D e layered), si può utilizzare il comando EPM per assegnare la quota.
- Tracciare la linea (o una polilinea) di sezione in modo che essa intersechi le curve.
- Lanciare il comando CLOPER che visualizzerà una finestra di dialogo nella quale si effettueranno le scelte mostrate nella figura seguente:

Dopo aver premuto OK, TOPak chiederà di selezionare la linea di sezione ed inizierà la ricerca di tutte le intersezioni fra questa e le linee di livello (soltanto quelle layered !!), elaborando automaticamente le eventuali interpolazioni necessarie sui vertici delle linee di sezione spezzate. Il risultato finale è la creazione di un file testo in cui le prime sei righe sono parametri (intestazione) e le rimanenti sono dati relativi alla sezione.
Nota: Le caselle Distanza ricerca e Suddivisioni sono dei parametri necessari per il calcolo delle interpolazioni, e per il loro significato si rimanda alla descrizione del comando CLOPER nella parte del manuale di TOPak in cui vengono descritti i comandi nel dettaglio.
- Lanciare il comando S2D che disegna la sezione partendo dal file prodotto dal comando CLOPER. Verrà visualizzata una finestra di dialogo in cui si potrà scegliere il nome del file dati, il nome di un eventuale file testo con i dati di una sezione di progetto (vedi oltre) ed un file testo denominato File tabella che determina la fincatura. I bottoni Modifica... consentono di editare i files corrispondenti.

- Cliccare OK e indicare con il mouse a TOPak dove si desidera la sezione nel disegno.


Sezioni su curve di livello 3D e non layered

Sezioni su curve di livello 3D e non layered

La sezione in questo caso va fatta selezionando gli oggetti 3D che intersecano la linea di sezione.


Sezioni su curve di livello che tengano conto anche delle linee di vincolo (discontinuità e contorni)

Sezioni su curve di livello che tengano conto anche delle linee di vincolo (discontinuità e contorni)

Questo caso si presenta quando si devono sezionare, oltre le curve di livello, anche le linee di discontinuità che sono state utilizzate per sviluppare il modello a falde triangolari.

Per raggiungere quest'obiettivo occorre che le curve di livello siano tridimensionali (polilinee a Z diverse); nel caso in cui esse siano soltanto polilinee layered e bidimensionali sarà necessario trasformarle in 3D con il comando LAY23DLAY.
E' necessario che anche le linee di vincolo siano tridimensionali, normalmente 3D Poli di AutoCAD.
Nota: I contorni esterni potrebbero anche essere delle polilinee 2D, il che potrebbe dare qualche difficoltà, eventualmente si potrà rifare il contorno con una 3DPOLI.

- Quando le condizioni di base, cioè che gli oggetti da sezionare siano 3D, sono soddisfatte, si dovrà tracciare la linea di sezione avendo cura che essa non intersechi oggetti che non dovranno essere sezionati (linee di indicazione, simbolismi grafici, ecc.).
- Lanciare il comando CLOPER

Il comando Cloper permette di ricavare in un file ASCII i dati della sezione semplicemente selezionando la linea di sezione.

- Lanciare il comando S2D per ottenere il disegno della sezione in AutoCAD.

Nota importante:
Nella figura seguente le linee di livello sono di tipo layered e bidimensionali. In questa situazione non si possono ottenere sezioni con le quote dei cigli della strada (cioè le discontinuità) e con le quote del contorno esterno; pertanto si possono ottenere soltanto sezioni dove i picchetti rappresentano l'intersezione tra la linea di sezione e le curve di livello.

Per fare una sezione che intersechi sia le curve di livello che le linee di discontinuità ed i contorni occorre che anche le curve siano 3D; per trasformare le curve da layered+2D a layered+3D si può utilizzare il comando LAY23DLAY.


Sezioni su modello a falde triangolari

Sezioni su modello a falde triangolari

Per ottenere la sezione sulle falde triangolari lanciare il comando CLOPER effettuare le impostazioni mostrate nella figura.

Lanciare poi il comando S2D per ottenere il disegno della sezione.


Sezione su curve di livello prive di quota; non layered e non 3D.

Sezione su curve di livello prive di quota; non layered e non 3D.

In questo caso non sarebbe possibile ricavare le sezioni, non avendo l'informazione relativa a ciascuna curva di livello. Tuttavia è possibile con un comando assegnare la quota alle curve di livello: è sufficiente che esse siano delle linee/polilinee in AutoCAD.
Il comando è EPM e richiede la quota delle prima curva e l'equidistanza.

Si possono ottenere delle curve di tipo layered con le quali poi si possono ottenere le sezioni come descritto nelle pagine precedenti.


Profilo o sezione lungo una polilinea 3D passante per i punti battuti

Profilo o sezione lungo una polilinea 3D passante per i punti battuti

- Disegnare una Polilinea 3D passante per i punti battuti.
- Lanciare il comando CLOPER e copiare le impostazioni della figura seguente:

- Lanciare il comando S2D per ottenere il disegno della sezione.

Con quest'ultima operazione apparirà una finestra (come sopra) in cui impostare le opzioni come mostrato nella figura. Il file di intestazione può essere modificato dall'utente: per queste spiegazioni si rimanda la manuale di riferimento ai comandi.


Profilo o sezione passante per i punti battuti (punti 2D con testo quota)

Profilo o sezione passante per i punti battuti (punti 2D con testo quota)

Ci si trova a seguire questa procedura quando i punti del piano quotato non sono tridimensionali, di conseguenza sorge il problema di ricavare la quota.
Se la quota dei punti è scritta sotto forma di testi accanto ai punti è possibile recuperarla al fine di produrre il profilo. L'obiettivo principale è produrre un file ASCII contenente le coordinate dei punti, in modo che poi questo sia trasformato nel disegno di un profilo con il comando S2D.

Per ricavare il file ASCII con le coordinate dei punti, si deve utilizzare il comando EXPDAT che visualizza la finestra di dialogo mostrata nella figura seguente.

- Impostare le varie opzioni come mostrato nella figura.
- Premere OK e poi, per ogni punto, dare in sequenza il punto (osnap nodo) e poi selezionare il testo della quota.
- Nota: Se in AutoCAD, oltre che la quota, abbiamo anche il nome del punto, si può utilizzare la numerazione manuale nell'apposita sezione della finestra di dialogo. In questo caso la sequenza sarà la seguente:
Indicare punto
Selezionare testo nome
Selezionare testo quota.


Sezioni passanti per i punti battuti, metodo di numerazione dei picchetti

Sezioni passanti per i punti battuti, metodo di numerazione dei picchetti

La numerazione dei picchetti può avvenire:
- Automaticamente da un numero di partenza a scelta "m" con incremento "n"
- Manualmente, selezionando con il mouse i testi dei nomi nel disegno

Determinazione automatica

Selezione manuale del nome con il mouse


Sezione di progetto

Sezione di progetto

Premessa.
Affinché il comando S2D riesca a disegnare il profilo di progetto assieme al profilo del terreno naturale si devono verificare le seguenti condizioni:
1. Deve esistere un file testo con i dati del terreno naturale con relativa intestazione.
2. Deve esistere un file testo con i dati della sezione di progetto (anche senza intestazione).
3. La lunghezza (proiezione sull'asse delle distanze) delle due sezioni deve essere uguale.

Procedura.
Il punto di partenza è il disegno di una sezione del terreno naturale in AutoCAD; su questo disegno si traccia una polilinea che rappresenta la linea di progetto; eventualmente utilizzando il comando di PLINEA di AutoCAD oppure con il comando LINESLOPE di CADPak.
La lunghezza della proiezione orizzontale della sezione di progetto deve essere uguale a quella del terreno naturale (in caso contrario il programma dà un messaggio d'errore).

- Il punto 1. della premessa appena fatta dovrebbe essere già soddisfatto, infatti la sezione del terreno naturale è già stata prodotta e per produrla si è dovuto partire da un file di testo (ASCII) con Intestazione e dati come il seguente:

1000,3
"Q = ",0.0,"m.s.l.m.",70,2,ISO,35,4,2
40,10,0,20,12
100,20
"Scala lunghezze 1:",100," ",100,20,ISO,35,5,0
"Scala altezze 1:",100," ",100,30,ISO,35,5,0
1   0.0000   3.5000
2   1.4443   3.0000
3   1.6630   3.5000
4   1.5706   2.0000
5   1.5706   1.5000
6   0.9459   1.0000
7   2.7184   0.5000
8   4.0555   0.0000
9   4.5715   -0.5000
10   3.1383   -1.0000
11   20.1641   -1.5000

- Il punto 2. consiste nel generare il file con i dati della sezione di progetto partendo dalla "polilinea progettata" dall'utente; per raggiungere questo obiettivo si deve utilizzare il comando OUT_DAT.

Questo file è scritto nella forma: Num. Picchetto – Dist.Parziale – Quota.
Esempio:

1    0.0000    2.3741
2    8.8154    1.5236
3    7.4334    0.5598
4    9.6465   -0.7442
5    11.689    -1.1411
6    4.2576   -1.5000

- Per quanto riguarda la condizione di cui al punto 3. è controllata automaticamente dal programma.
La sezione basata su questi due file di esempio è:


Modificare i parametri di disegno della sezione; Scala, Quota base etc.

Modificare i parametri di disegno della sezione; Scala, Quota base etc.

Per modificare i parametri della sezione occorre intervenire sui dati che l'hanno generata; la sezione non viene aggiornata nel disegno ma deve essere inserita ex-novo nel disegno.
Per modificare i parametri si può utilizzare il comando MODDT oppure nella finestra di dialogo visualizzata dal comando S2D si può premere il bottone Modifica come mostrato nella figura.


Importare una tabella di coordinate nel disegno

Importare una tabella di coordinate nel disegno

Il comando TEXTIMP, permette di inserire un file ASCII qualsiasi nel disegno; chiede di selezionare il nome di un file e poi, dopo il settaggio di alcuni parametri inserisce i testi nel disegno.


Trasformare una polilinea in un disegno di una sezione

Trasformare una polilinea in un disegno di una sezione

Si parte da una polilinea disegnata in AutoCAD e che rappresenta una linea di sezione

- Si disegna la polilinea che deve essere trasformata in una sezione
- Si disegna l'origine come mostrato nella figura
- Si lancia il comando OUT_DAT e si fanno le impostazioni come nella figura

Quando si preme OK, CADPak chiede di indicare il punto di inizio, cioè l'origine indicata nella figura e poi di selezionare la polilinea che rappresenta la sezione
- Si lancia il comando S2D e dopo aver modificato eventualmente i valori di scala o altro si preme OK


.topic 19002
Posizione del menu a tendina.

Per il caricamento di Menu Topografia accedere al menu 'I&S CAD' e cliccare su ' Menu Topografia':

.topic 19003
Posizione menu a tendina

Toolbar

Questa toolbar contiene i comandi per:

Trasferimento dati rilevati da strumento topografico a PC.
Acquisizione dei dati di campagna da files di testo generati da software in dotazione agli strumenti topografici  come stazioni totali e GPS.
Calcolo dei rilievi e praparazione dei libretti, compreso quello di Pregeo.
Materializzazione dei punti direttamente nell'editor di AutoCAD.
Preparazione dei file da trasferire agli strumenti per il tracciamento.

.topic 19004
  Nome Comando al Prompt: UniDrv

Questo comando permette alternativamente di :
a) Scaricare i dati da stazioni totali direttamente per le strumentazioni che supportano la trasmissione attiva, cioè lo strumento spedisce i dati ed il computer li riceve.
b) Se lo strumento non permette l'accesso diretto alla memoria, permette di trasformare i file scaricati con il software in dotazione allo strumento nel formato adatto a CADPak <nomefile>.MYT (libretto di campagna con coordinate polari) che si devono poi elaborare con il comando NewPolig.

Nel caso a) in cui lo strumento è in grado di inviare attivamente i dati si deve procedere nel seguente modo.
1.	Premere il pulsante Porta per impostare i parametri della porta seriale attaverso la quale lo strumento invia attivamente i dati al computer.
2.	Premere il pulsante NomeFile per fornire il nome di un fileda generare ex novo (ricordarsi di selezionare il tipo di strumento corretto) in cui scaricare i dati provenienti dallo strumento.
3.	Premere Ricevi (che si trasforma in Stop) per mettere il programma in attesa dei dati dallo strumento.
4.	A questo punto spedire i dati dallo strumento (vedi manuale dello strumento) e nella finestra di dialogo si devono veder scorrere i dati in via di ricezione.
5.	Quando la trasmissione è terminata premere il pulsante Stop.
6.	Premere il pulsante File Grezzo per vedere i dati scaricati. (Facoltativo)
7.	Premere il pulante Converti! per convertire il libretto grezzo nel formato di CADPak (Estensione <nomefile>.myt).

Nel caso b) invece lo strumento non dispone della possibilità di spedire i dati al PC ma è dotato di un software che permette di prelevare i dati e di generare sul computer un file di testo contenente i dati.
I questo caso la procedura è la seguente:
2.	Premere il pulsante NomeFile per selezionare il nome di un file esistente generato dal programma si scarico dati dello strumento, ricordarsi di selezionare lo strumento corretto (vedi figura).
6.	Premere il pulsante File Grezzo per vedere i dati scaricati. (Facoltativo)
7.	Premere il pulante Converti! per convertire il libretto grezzo nel formato di CADPak (Estensione <nomefile>.myt).

Qualsiasi sia la procedura al termine si deve avere un file con estensione myt contenente i dati di rilievo, simile al seguente:

TOLLE   0.05  0.05  0.05
TOLLT   0.05  0.05  0.05
PUNTI   3
1000   101       15      1.518    125.3320  101.4997     31.836  1.530
1000   102       15      1.518    107.2360   99.1235     14.615  1.530
1000   103       15      1.518      3.1471   99.0781      9.646  1.530
1000   104       15      1.518    361.4932  100.2724     23.166  1.530
1000   105       15      1.518    350.1567  100.3656     37.719  1.530
(... punti rilevati ...)
1000   3000     101      1.530    331.1818   99.2467    397.853  1.530

3000   1000      02      1.575    131.1833  100.7673    397.843  1.530
3000   3001      02      0.000    158.4230  100.0000   1000.000  0.000
3000   3002      02      0.000    158.2560  100.0000   1000.000  0.000
3000   3003      02      0.000    296.7433  100.0000   1000.000  0.000
3000   3004      02      0.000    240.4866  100.0000   1000.000  0.000
(... punti rilevati ...)
3000   9000     101      0.000     31.3091  100.0000    817.708  0.000

9000   3000     100      0.000    231.3091  100.0000    817.708  0.000
9000   9001     100      0.000    128.4411  100.0000     30.872  0.000
(... puntirilevati ....)
FINE
PFISS    1000  0.00   0.00   0.00
ORIEN    1000  0.00
POLIG
 1000 3000 9000
FINE

Si possono trovare alcuni esempi di files *. myt nella cartella

C:\Programmi\IeS\CADPak\Esempi\Topografia\RilieviTopografici\

.topic 19005
  Nome Comando al Prompt: Medit

Questo comando permette la creazione da zero e/o la modifica dei libretti di campagna nel formato di CADPak (<nomefile>.myt), ed è stato pensato principalmente per gli utenti che hanno strumenti privi di registratore di dati; permette di generare, visualizzare e modificare i libretti di campagna.

La finalità di questo comando è quella di generare un file myt (libretto di camoagna) da elaborare con il comando NewPolig; il libretto di campagna contiene i dati riulevati ma anche le istruzioni su come elaborare il rilievo.
Queste istruzioni sono allocate in coda al file e possono essere diverse da rilievo a rilievo a seconda del meotodo di orientamente come spiegato quì di seguito.

Il libretto di campagna (<nomewfile>.myt ), che dovrà essere elaborato con il comando NewPolig (poco più avanti in questo manuale), contiene dati, istruzioni e può essere strutturato in tre possibili formati:

Formato 1 – Azimut, Distanza Orizzontale, Dislivello strumentale (centro strumento - centro prisma)
Estratto del file myt
....
PUNTI       1
100   101  21   1.460    14.6640   10.248   0.8480     1.460
100   102  20   1.460    18.7428   12.519   0.7900     1.460
....
St    Pt   Cod    Hs     Az        Do     Disl.Strum.    Hp

Formato 2 – Azimut, Distanza Orizzontale, Dislivello topografico
Estratto del file myt
....
PUNTI       2
100   101  21   1.460    14.6640   10.248   0.8480      1.460
100   102  20   1.460    18.7428   12.519   0.7900      1.460
....
St    Pt   Cd    Hs      Az        Do      Disl.top.      Hp

Formato 3 – Azimut, Distanza Inclinata, Zenit
Estratto del file myt
....
PUNTI        3
100   101   10    1.51   13.5555   104.1375   91.2900   2.000
100   102    3    1.51   16.9535   104.2130   90.7399   2.000
....
St    Pt   Cod     Hs    Az         Zenit     Dist.Inc.   Hp

Nella scheda Punti contenuta nella finestra di dialogo di questo comando vi è la possibilità di scegliere il tipo di formato; la scelta, nel caso di inserimento manuale dei dati, deve avvenire prima dell' inserimento dei dati.
Se questo comando viene utilizzato per visualizzare un file esistente il tipo di formato viene riconosciuto automaticamente in base alla seguente riga che è presente nel file myt:

PUNTI       n

Dove n può assumere i valori 1, 2, 3 a seconda del tipo di formato.

I pulsanti contenuti in questa maschera sono:
Nuovo	- Azzera i campi della maschera e consente di iniziare un nuovo libretto
Apri	- Comando che permette di aprire libretti esistenti
Ultimo File	- Apre l'ultimo libretto utilizzato o prodotto con il comando UniDrv
Salva	- Salva il libretto correntemente aperto con il nome attuale
Salva come	- Permette di salvare il libretto con un nuovo nome
Vista file	- Apre il libretto corrente con il programma blocco note di Windows

oltre ai pulsanti appena descritti vi sono delle schede:
Punti	 - permette la visualizzazione e/o modificare delle letture
Poligonali                   - permette la definizione delle poligonali del rilievo
Tolleranze      		- permette la definizione delle tolleranze per i calcoli
Orientamento	rilievo	- permette di definire l'orientamento del rilievo
Punti fissi       	- permette di definire dei punti di coordinate fisse nel rilievo

Scheda Punti
Questa scheda contiene i comandi per aggiungere e/o modificare la lista delle letture sui punti rilevati;
Nella parte in basso vi è la tabella contenente tutte le letture, nella parte in alto vi sono le caselle di testo che contengono i dati relativi alla lettura selezionata nella tabella sottostante.
Il pulsante Aggiungi aggiunge una nuova lettura utilizzando i dati contenuti nelle caselle di testo.
Il pulsante Rimuovi elimina la lettura correntemente selezionata.
Il pulsante Memorizza aggiorna la lettura selezionata con i valori contenuti nelle caselle di testo.
Il pulsante Aggiungi un libretto permette di selezionare un'altro file myt ed aggiungere in coda al libretto presente le letture in esso contenute.
La lista a discesa Formato dei dati serve per selezionare il formato dei dati; questa scelta va fatta prima di iniziare la digitazione dei dati.

Scheda Poligonali
In questa scheda si definiscono le poligonali dei rilievo.
Aggiungi riga serve per aggiungere una riga, cioè un poligonale.
Aggiunti colonna serve per aggiungere una stazione.

Scheda Tolleranze
Questa scheda permette di fissare i parametri di tolleranze espressi in metri per il controllo delle letture reciproche tra le stazioni ed anche per definire gli errori massimi di chiusura.
Quando poi il comando NewPolig (vedi oltre) effettuerà l'elaborazione del libretto utilizzerà questi valori per il calcoli.

Scheda Orientamento rilievo
Questa scheda contiene gli strumenti per orientare il rilievo.

I modi per orientare un rilievo sono 3:

1) Fissare le coordinate della prima stazione ed un angolo di correzzione da applicare a tutti i valori azimutali letti dalla prima stazione; di conseguenza in fase di calcolo con il comando NewPolig tutto il rilievo verrà ruotato e traslato.
Si deve utilizzare l'opzione Coordinate+ correzione, scrivere le coordinate da imporre alla stazione e poi inserire l'angolo di correzione.
Alla fine in coda al file myt le righe sono come le seguenti:
6000      245     17   1.600   189.4540   105.1050     47.560    1.460
6000      246     17   1.600   186.8035   104.9615     53.383    1.460
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE
PFISS           1000   0.0    0.0     0.0
Significato --> Prima stazione     Est    Nord  Quota
ORIENTAMENTO    1000   -12.326
Significato --> Prima stazione     Correzzione azimutale da applicare a tutte le letture fatte dalla prima stazione
POLIGONALE
1000 2000 3000 4000 5000 6000
FINE

2) Fare stazione su di un punto di coordinate note PN1 e poi collimare ad altro punto di coordinate note PN2.
Si deve utilizzare l'opzione Coordinate+ correzione e poi premere il pulsante in corrispondenza di Corr.angolare da applicare in modo da far apparire la seguente maschera dove si devono inserire le coordinate dei due punti noti ed in basso scegliere la lettura dal pu to PN1 al PN2 come schematizzato nella figura.

6000      245     17   1.600   189.4540   105.1050     47.560    1.460
6000      246     17   1.600   186.8035   104.9615     53.383    1.460
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE
PFISS           100   0.0    0.0     0.0
Significato --> Prima stazione     Est    Nord  Quota
ORIENTAMENTO    100   82.5040
Significato --> Prima stazione     Correzzione azimutale da applicare a tutte le letture fatte dalla prima stazione
POLIGONALE
100 200 300 400 5000 6000
FINE

3) Battere due punti di coordinate note dalla prima stazione del rilievo.
Si deve utilizzare l'opzione Battute su punti noti, selezionare il nome dei punti noti con gli appositi pulsanti e poi inserire le relative coordinate.
400    460    25    1.42    30.6660     93.1880     32.5700     1.3200
400    461    25    1.42    35.2135     96.6294     71.2800     1.3200
FINE
PNOTO   100  125  -82.38972 -76.25983 0.00000
Significato --> Prima stazione      Punto noto    Est    Nord    Quota
PNOTO   100  126  -73.51726 -76.70539 0.00000
Significato --> Prima stazione      Punto noto    Est    Nord    Quota
POLIG
100 200 300 400
FINE

Scheda Punti Fissi
Questa scheda serve per inserire dei punti fissi.
I punti fissi possono esser costituiti da:

1) La prima stazione del rilievo
2) L'ultima stazione della poligonale (o delle poligonali)

.topic 19006
  Nome Comando al Prompt: NewPolig

Questo comando esegue il calcolo delle poligonali effettuando, laddove ne esistano i requisiti, la compensazione.
Le tipologie di poligonale gestite sono:

Aperta non vincolata
Chiusa
Aperta e vincolata

Per utilizzare il comando è necessario avere il libretto (si tratta di un file di testo), contenente i dati rilevati in campagna.
Il libretto di campagna è un file di testo, con estensione *.myt, che si può ottenere trasformando il file di scarico proveniente dalla stazione totale utilizzando il comando UniDrv (vedi sopra), che trasforma i dati dei più diffusi strumenti sul mercato.
Nel caso in cui lo strumento o il formato del file di scarico non rientrasse nella lista è possibile richiedere dei convertitori specifici rivolgendosi telefonicamente ai nostri tecnici oppure via e-mail all'indirizzo ltsupport@ies.it inviando in allegato anche un esempio di file scaricato contenente un rilievo con almeno due stazioni.

Il comando visualizza la seguente finestra di dialogo:

Il formato del libretto di campagna è il consueto formato *.myt come mostrato quì di seguito:

NEWMYT	à	Indica a CADPak l'inizio dei dati
TITOL Rilievo di prova per Topografia	à	Indica a CADPak il titolo del rilievo
TOLLE           0.05 0.05	à	Tolleranze sulle letture reciproche per distanza e dislivello
TOLLT           0.05 0.05 0.02	à	Tolleranze sulla chiusura Planimetrico, Altimetrico ,Angoli
PUNTI           3	à	Linea che indica a CADPak l'inizio dei punti battuti
1000        1      5   1.560     5.6290    96.7275     62.036    1.460
1000        2      5   1.560    10.2170    96.7255     60.581    1.460
. . .
Staz      Punto   Cod   Hs      Azimut     Zenit     Dist. Incl.   Hp
. . .
6000      236      9   1.600    32.1775    91.3440     22.304     1.46
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE	à	Linea che indica a CADPak la fine dei punti battuti
PFISS           1000 0.0 0.0 0.0	à	Coordinate della prima stazione del rilievo – Pfiss  Staz   x   y   z
ORIEN           1000 0.0	à	Orientamento della prima stazione  –   Orien Staz    Angolo
TRASL    0.00    0.00   516.326	à	Linea che indica a CADPak di traslare il rilievo di Dx, Dy, Dz
POLIG	à	Indica a CADPak che segue una definizione di una poligonale
1000  2000  3000  4000  5000  6000	à	Stazioni che compongono la poligonale
FINE	à	Indica a CADPak che la fine dei dati
Il formato del file con i codici (chiamato anche tabelle dei codici) descrittivi è il seguente (le righe che iniziano con il carattere punto e virgola [ ; ] sono trascurate da CADPak).
CADPak inizia a leggere i codici contenuti nella tabella dei codici dalla riga contenente la parola CODICI e termina con la riga contenente la parola parola FINE.
Il file è modificabile a piacere dall'utente che potrà personalizzarlo secondo le proprie esigenze

CODICI
;-----------------------------------------------
;Codici con descrizione geometrica
;-----------------------------------------------
 0     Stazione
 1     Base
 2     Sommità
 3     Ciglio
 4     Spigolo
 5     Bordo
 6     Allineamento
 7     Vertice
 8     Incrocio
 9     Inizio
 10    Fine
 11    Estremità
 12    Punto
;-----------------------------------------------
;Morfologia terreno
;-----------------------------------------------
 40    Scarpata
 41    Impluvio
 42    Conpluvio
 43    Displuvio
 44    Rampa di accesso
 45    Sommità
;-----------------------------------------------
;Elementi
;-----------------------------------------------
 50    Fiume
 51    Sentiero
 52    Ferrovia
 53    Massicciata
 54    Muretto
 55    Recinzione
 56    Argine destro
 57    Argine sinistro
 56    Asse fluviale
 58    Canale irriguo
59	Chiodo miniato
 60    Linea elettrica
 61    Linea telefonica
 62    Traliccio
 63    Palo di sostegno
FINE

Il comando NewPolig gestisce anche i codici combinati come ad esempio
9 + 51 significa "Inizio Sentiero".
Per utilizzare i codici combinati si deve già in fase di rilievo in campagna utilizzare la combinazione, cioè quando è il momento di inserire il codice descrittivo nello strumento si inserisce direttamente la combinazione 9.51 (che CADPak poi riconoscerà come "Inizio Sentiero" visto che nella tabella 9= Inizio 51=Sentiero) come nell'esempio appena menzionato.
Alcuni strumenti non danno la possibilità di inserire il carattere punto nel codice e pertanto nel caso dell'esempio precedente si dovrebbe utilizzare 0951 dove 09= Inizio 51=sentiero.
Per indicare a CADPak quale tipo di codifica si è utilizzata, cioè per scegliere il tipo di codifica tra "9.51" e "0951" è necessario premere il pulsante Tipo Codifica nella finestra di dialogo visualizzata da questo comando.

Quando si hanno a disposizione sia il file con i dati ed il file con i codici si può utilizzare il pulsante "Calcola" per avviare la procedura di calcolo.
Definizione della struttura delle poligonali del rilievo
Nella fase di calcolo il comando NewPolig apre il libretto di campagna (formato *.myt mostrato nelle pagine precedenti) leggendo le letture ai punti ed anche le istruzioni in esso presenti; ad esempio se trova la parola POLIG si aspetta la dichiarazione di una poligonale e che la riga successiva contenga l'elenco delle stazioni contenute nella poligonale.

POLIG
100 200 300 400 500 600 100

In questo caso le due righe (del file) indicano a CADPak che il rilievo contiene una poligonale chiusa (l'ultima stazione della poligonale coincide con la prima) composta dalle stazioni descritte.
Se una poligonale avesse una poligonale collegata la definizione sarebbe

POLIG
100 200 300 400 500 100
POLIG
200 700 800 900

Se le poligonali sono collegate, le poligonali "figlie" devono avere la prima stazione coincidente con una qualsiasi stazione della poligonale "madre". Nel figura la poligonale "madre" sarebbe quella definita dalle stazioni 100 200 300 400 500 600.
Imposizione dell'origine del rilievo
Imporre l'origine del rilievo significa fissare le coordinate della prima stazione del rilievo che si fa aggiungendo e/o modificando la seguente riga nel file dei dati *.myt.
PFISS     <prima stazione>      <X  stazione>     <Y stazione>        <Z stazione>
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
dove la seguente riga
PFISS  100   123.326    236.124     345.802
È composta da
100	= Nome della prima stazione del rilievo
123.326	= coordinata EST della prima stazione del rilievo
236.124	= coordinata NORD della prima stazione del rilievo
345.802	= coordinata QUOTA della prima stazione del rilievo
L'origine del rilievo può essere anche imposta attraverso un'apertura a terra, con il metodo spiegato poco più avanti in questo manuale.

Imposizione delle coordinate dell'ultima stazione di una poligonale (aperta vincolata)
E' possibile imporre le coordinate dell'ultima stazione del rilievo aggiungendo la seguente riga nel file dei dati *.myt, in aggiunta a quella che eventualmente definisce le coordinate della prima stazione come visto nel punto precedente con la stessa sintassi.

PFISS     <ultima stazione>      <X stazione>     <Y stazione>        <Z stazione>

Orientamento del rilievo e apertura a terra
L'orientamento del rilievo consiste sia nel determinare le coordinate della prima stazione che l'orientamento angolare vero e proprio; con CADPak esistono tre modi per orientare un rilievo:
1)  Metodo dell'angolo di correzione e delle coordinate imposte alla prima stazione
Questo metodo di orientamento prevede di imporre un valore di correzione da applicare a tutti gli azimut letti dalla prima stazione e di imporre le coordinate alla prima stazione.
Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT)
Sintassi:
PFISS     <prima stazione>      <X  stazione>     <Y stazione>        <Z stazione>
ORIEN   <prima stazione>   <angolo di correzione>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
ORIEN  100    56.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
L'istruzione PFISS serve, come visto nel punto precedente, per imporre le coordinate della prima stazione
L'istruzione ORIEN serve invece per fare in modo che CADPak aggiunga algebricamente un determinato valore angolare a tutti gli azimut letti dalla prima stazione provocando la rotazione del rilievo a cascata su tutte le stazioni del rilievo.
2)  Metodo dell'azimut imposto e delle coordinate imposte alla prima stazione
Questo metodo di orientamento prevede di imporre un valore ad una lettura azimutale effettuata dalla prima stazione della prima poligonale del rilievo.
In questo modo CADPak ruota tutto il rilievo di un angolo che risulta dalla differenza tra azimut imposto ed azimut letto realmente.
Angolo di correzione = Azimut Letto – Azimut Imposto
Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT):
Sintassi:
PFISS     <prima stazione>      <X  stazione>     <Y stazione>        <Z stazione>
AZIMU  <prima stazione>      <punto letto>    <azimut imposto>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
AZIMU  100     102      156.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
3)  Apertura a terra plaminetrica su due punti di coordinate note
Questo metodo di orientamento prevede la conoscenza di due punti  di coordinate note battuti dalla prima stazione.
Questa istruzione si può dare aggiungendo nel file MYT, due righe come la seguente:
Sintassi:
PNOTO  <prima stazione>  <punto battuto>  <X punto>  <Y punto>  <Z punto>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS     100      0.000      0.000        856.323
PNOTO     100      125      -82.38972      -76.25983      0.00000
PNOTO     100      126      -73.51726      -76.70539      0.00000
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
Per imporre la quota della prima stazione del rilievo si può utilizzare il comando PFISS come nella riga dell'esempio:
PFISS     100      0.000      0.000    856.323
In questo modo il programma calcolerà le coordinate planimetriche riferendosi ai due punti noti e le quote verranno calcolate partendo dal fatto che la prima stazione del rilievo è a quota 856.323.
Nota importante:
Se si fa stazione su uno dei due punti di coordinate note di deve utilizzare il metodo dell'imposizione di azimut come nel seguente esempio (si è fatta stazione sul punto 100 e si è collimato il punto 124):
AZIMU   100    124        123.3266
PFISS   100   -154.97245   98.42561   723.3265    (coordinate della stazione)
Il comando NewPolig calcola le coordinare cartesiane dei punti di rilievo.
Se il calcolo avviene nell'ambito di una poligonale chiusa o vincolata le coordinate dei punti si distinguono tra compensate e non compensate; infatti i punti battuti da una stazione le cui coordinate sono compensate avranno coordinate compensate, in altre parole per ogni punto si avranno due terne di coordinate X,Y,Z (non compensate) e Xc,Yc,Zc (compensate).
Inoltre vengono generati alcuni libretti che tecnicamente sono dei file di testo, con dei nomi particolari per renderne agevole il riconoscimento.

Rilievo.myt			Libretto di campagna originale
Rilievo.log			Registro delle attività e delle anomalie trovate
Rilievo_(1.1).txt			Libretto di campagna con gli azimut originale
Rilievo_(1.2).txt			Libretto di campagna con azimut corretti per trasporto
Rilievo_(1.3).txt			Libretto di campagna con azimut derivati per compensati
Rilievo_(2.1).txt			Libretto delle stazioni
Rilievo_(3.1).txt			Libretto delle poligonali
Rilievo_(4.1).txt			Coordinate cartesiane NON compensate
Rilievo_(4.2).txt			Coordinate cartesiane compensate
Rilievo_(5.1).dat			Libretto delle misure nel formato di Pregeo 7
Rilievo_(5.2).dat 			Libretto delle misure nel formato di Pregeo 8
Rilievo_CP(6.1).xyz	Coordinate NON compensate da utilizzare con il comando C2D di CADPak
Rilievo_CP(6.2).xyz	Coordinate compensate da utilizzare con il comando C2D di CADPak

Tra questi libretti, che sono numerati, vi sono i due libretti 5.1 e 5.2 che sono i libretti di Pregeo; questi possono essere importati in forma grafica nell editor di AutoCAD con il comando C2DP (vedi più avanti inn questo manuale).

.topic 19007
   Nome Comando al Prompt: CreaStrum

Questo comando serve per trasformare dei file di coordinate cion n,x,y,z in file dati nel formato dei alcuni strumenti topografici
ai fini del tracciamento, cioè permette di caricare nello strumento i punti da tracciare prelevandoli da AutoCAD.

La procedura, a partire da AutoCAD, è la seguente:

1) Esportare in un file di testo (*.xyz) i punti, vertici di linee, vertici di polilinee, centri di cerchi, punti di inserimento di blocchi con il comando
EXPDAT di CADPak.

Esempio:
    1     119.51     123.68       12.126
    2     122.05     118.59       14.498
    3     123.33     106.71       10.326
    4     118.23      97.80       18.629
    5     106.35     103.74       20.674
    6     103.38     120.28        8.123
    7     137.34     143.20       19.045
    8      92.76     112.65       24.788

2) Utilizzare il comando CreaStrum per trasformare il file nel formato adatto allo strumento.

Esempio strumento Trimble --> File *.are
5=1
4=0
37=123.680000
38=119.510000
39=0.000000
5=2
4=0
37=118.590000
38=122.050000
39=0.000000

I riquadri presentio nella finestra di dialogo sono i seguenti
Strumento: in questa sezione è possibile scegliere lo strumento per il quale si vuole generare il file;
File di testo: Riquadro per la Scelta e/o la Modifica del file con i dati sotto forma di coordinate cartesiane (.xyz) generato con il comando ExpDat;
File Strumento: Riquadro per la Scelta del nome del file che deve essere generato contenente le coordinate cartesiane nel formato della stazione totale, pronto per essere trasferito nella memoria interna dello strumento; il nome del file si deve fornire e non scegliere perchè questo riquadro serve per fornire un nome di un file che deve essere generato da zero.

.topic 19008
Posizione menu a tendina

Toolbar

Questa barra degli strumenti contiene i comandi per la gestione dei piani quotati.
Si possono importare piani quotati partendo da file di coordinate cartesiane, oppure esportare dei piani quotati sotto forma di files ASCII in vari formati.
E' possibile inoltre modificare i piani stessi aggiungendo dei nuovi punti ricavati per interpolazione.

.topic 19009
   Nome Comando al Prompt: PXYDAT

Questo comando è complementare al comando "Pxy" che serve per calcolare la quota e disegnare un punto interpolato (vedi figura nella descrizione del comando Pxy). Lo scopo del comando Pxy è il seguente: dati due punti, individuabili eventualmente con gli osnap di AutoCAD, si desidera ricavare la quota di un terzo punto fra i due, scrivendo anche il testo della quota ed il numero del punto.
La seguente finestra di dialogo viene visualizzata dal comando PxyDat e serve per impostare il funzionamento del comando Pxy.

.topic 19010
   Nome Comando al Prompt: PXY

Questo comando consente di generare dei nuovi punti in un piano quotato ricavando la sua quota per interpolazione fra altri due, di quota nota.
Prima di utilizzare questo comando si devono impostare i parametri attraverso il comando PxyDat. Se si intende evitare l'impostazione dei parametri ogni volta con il comando PxyDat, si possono modificare le variabili globali comprese fra TP7465 e TP7499 nel file TOPAK1.VAR, vedi comando Imposta.
Esempio:

Segue esempio di funzionamento del comando:
Command: PXY (Invio)
Selezione quota: da testo
Punto num. 1 - Punto da interpolare: 	(selezionare la crocetta del punto da interpolare)
Primo punto: 	(selezionare la crocetta del primo punto di riferimento)
Selezionare la quota:	(selezionare il testo della quota di tale punto)
Secondo punto: 	(selezionare la crocetta del secondo punto di riferimento)
Selezionare la quota:	(selezionare il testo della quota di tale punto)
1->	p1	9.91	-21.31	-0.27
    p2	13.51	-16.95	-1.06
    pi	12.01	-19.16	-0.69
Punto num.   2 - Punto da interpolare: (Invio)
Command:

.topic 19012
    Nome Comando al Prompt: CP_PUNTO

Comando che consente di inserire nuovi punti in un piano quotato presente nel disegno, oppure di generare un nuovo piano quotato un punto alla volta, inserendo accanto all'oggetto che materializza i punti anche i testi con quota e nome.
I punti possono essere materializzati con degli oggetti PUNTO di AutoCAD oppure con dei BLOCCHI, possono essere tridimensionali oppure posti tutti a quota zero.
Attraverso l'opzione in linea BOX , viene visualizzato il box con il quale l'utente controlla la modalità di disegno dei punti.
Il funzionamento è il seguente:

Comando: CP_PUNTO
Box/<coordinate-posizione punto>: B (Invio)

.topic 19013
   Nome Comando al Prompt: EXPDAT

Comando che permette di esportare in un file di tipo ASCII, piani quotati presenti nel disegno corrente
Le coordinate dei punti da esportare vengono ricavate da vari oggetti di AutoCAD. Il comando apre il seguente box di dialogo:

I formati possibili per i file testo da produrre sono i seguenti:

Il riquadro Separatore permette la scelta del carattere separatore fra le colonne di dati (virgola o spazio).
Coord. Permette di decidere il sistema di riferimento delle coordinate cartesiane da estrarre, fra un sistema di riferimento personalizzato (vedi comando UCS di AutoCAD) e il sistema di riferimento globale di AutoCAD (WCS).
Selezionare permette di individuare gli elementi AutoCAD su cui filtrare la selezione: linee, polilinee, punti, testi, blocchi, cerchi. La selezione poi avverrà attraverso un finestra di AutoCAD.
Selezione manuale: attiva la selezione manuale dei singoli punti da esportare. In questo caso è possibile deliberare come effettuare la nominazione dei punti attivando il chek Nome:
opzione Manuale: richiede la selzione del testo del punto,
opzione Automatica permette di numerare automaticamente i punti esportati in base ai parametri impostati nel riquadro Numero.
L'opzione Quota (attiva nella modalità Selezione Manuale) permette di indicare le quote dei punti selezionadone i relativi testi (con ciò posso ricavare l'informazione tridimensionale da punti a video 2D);

Filtro serve per decidere di filtrare gli oggetti da interessare per layer singolo o per layered (vedi curve di livello layered).
Formato Dati serve per decidere la lunghezza dei campi con i dati esportati ed il numero di decimali
Le variabili globali che regolano questo box di dialogo sono nel file TOPAK1.VAR e sono quelle comprese fra TP7500 e TP7531.
Nel caso siano presenti punti doppi nel gruppo di selezione, solamente uno sarà esportato.
Numerazione dei punti esportati
La numerazione dei punti dipende del gruppo di selezione e può essere:
Casuale 	se l'operatore sceglie i punti da esportare attraverso finestre di selezione, CADPak numera gli oggetti a seconda dell'ordine con cui AutoCAD gli trasmette il gruppo di selezione generato dall'utente
Progressiva 	se l'operatore seleziona gli oggetti da esportare uno alla volta, AutoCAD fornisce a CADPak gli oggetti nello stesso ordine con cui l'operatore li ha selezionati e la numerazione dei punti segue tale ordine. Inoltre se l'utente seleziona una polilinea o una linea disegnata in AutoCAD secondo un certa sequenza di vertici, la numerazione avverrà secondo la stessa sequenza. Se l'utente desidera numerare i punti secondo una numerazione progressiva a partire da un certo numero può utilizzare l'opzione Nome Manuale e le impostazioni del riquadro Numero.

.topic 19014
   Nome Comando al Prompt: C2D

Questo comando permette di disegnare dei piani quotati partendo dalle coordinate cartesiane contenute in file di testo (ASCII). Il file testo che l'utente deve avere a disposizione può essere ottenuto in più modi: utilizzando le funzioni per la celerimensura di CADPak (ConvStrum, NewPolig); tramite un programma di topografia in grado di esportare file ASCII; inserendo una tabella di coordinate cartesiane utilizzando un editor qualsiasi.
Il file testo deve corrispondere ad uno dei seguenti formati:

I campi di ciascuna riga possono essere separati da uno o più spazi oppure da un carattere virgola; non sono ammesse condizioni miste.

Il riquadro "Contorni" abilita o disabilita la possibilità di unire i punti di contorno automaticamente. Nel file delle coordinate è possibile inserire dei simboli ">" e "<" per indicare a CADPak quali sono i punti di contorno da unite con delle linee.

(>)	Unire con il punto precedente
(<)	Termina unione punti
(&)	Chiudi su primo punto della polilinea
Esempio:
    >1      65.23      34.36       0.00  CONTORNI
    >2      42.82      71.05       0.00  CONTORNI
    >3      81.39      85.58       0.00  CONTORNI
    <4     131.74      76.35       0.00  CONTORNI
     5     136.82      53.74       0.00  CONTORNI
    >6      98.48      50.05       0.00  CONTORNI
    >7      78.85      47.05       0.00  CONTORNI
    &8      76.77      37.82       0.00  CONTORNI
Il carattere ">" indica l'inizio di un nuovo contorno o un punto da collegare mentre il carattere "<" indica la fine di una polilinea.
Le opzioni "File Pregeo" e  "Linee Stazione -> Punto" servono per la restituzione finalizzata a  Pregeo e pertanto si rimanda al manuale Procedure Pregeo.
Utilizzo di blocchi per la materializzazione dei punti nel disegno
Nel riquadro Materializzazione punto del box di dialogo, abbiamo visto che è possibile scegliere di materializzare i punti con dei blocchi anziché con dei punti.

Determinazione dei layer nel disegno dei piani quotati

Esempio:
Il comando "CalcPolig" produce, tra gli altri, un file come il seguente che è la forma ideale per poter sfruttare al meglio le possibilità del comando "C2D" in questione:
    101      19.251      89.040      -6.419  TP-025  Marciapiede
    102      23.828      87.350      -6.491  TP-025  Marciapiede
    103      19.451      74.765      -6.409  TP-025  Marciapiede
    104      14.297      76.168      -6.364  TP-025  Marciapiede
    109      15.755      59.839      -6.076  TP-027  Ciglio strada
    110      15.907      57.913      -6.000  TP-027  Ciglio strada
    111      15.510      55.008      -5.699  TP-027  Ciglio strada
    112      13.540      54.883      -5.725  TP-026  Linea di confine
    113       9.179      61.481      -6.041  TP-025  Marciapiede
    114       4.715      47.922      -4.728  TP-025  Marciapiede
Se l'opzione "Codice" del comando "C2D" è abilitata, il punto 103 di questo esempio verrà disegnato utilizzando i layer nel modo descritto quì di seguito.

Il prefisso "tp-" viene aggiunto automaticamente e significa Tipo di Punto; l'utente ha la possibilità di modificare a piacere il prefisso modificando la variabile globale (TP7970 "TP-") nel file topak1.var, tenendo presente che questa variabile viene utilizzata dal comando CalcPolig nella fase di generazione del file di coordinate e non da questo comando
Se l'opzione "Codice" non è abilitata i punti vengono materializzati con l'uso dei seguenti layers:

Alcune regole per il file dati di input per il comando "C2D":
Il file deve avere uno dei formati:

Non ci devono essere spazi tra una coordinata e l'altra se si utilizza la virgola come separatore e non ci devono essere virgole tra una coordinata e l'altra se si utilizza lo spazio come separatore;
Opzionalmente si possono scambiare le X con le Y: N°, X, Y, Z oppure N°, Nord, Est, Z;
Il carattere separatore può essere virgola o spazio;
Il carattere per le cifre decimali è il punto e non la virgola (es. 10.236 e non 10,236);
Le righe che iniziano con il carattere ";" vengono ignorate
Eventuali linee vuote vengono trascurate;

Le variabili globali che regolano questo box di dialogo sono nel file TOPAK1.VAR e sono quelle comprese fra TP1000 e TP1083.

.topic 19015
   Nome Comando al Prompt: TextOverlap

Questo comando permette di eliminare oppure di spostare su altro layer i testi che si sovrappongono.
Spesso accade che nei piani quotati i testi associati ai punti battuti si sovrappongono e quindi l'operatore deve spostare o eliminare manualmente i testi; questo comando aiuta in questo operazione permettendo di eliminare automaticamente i testi secondo delle regole dettate proprio dall'utente.

Tecnicamente il comando individua l'area di ingombro dei testi che ha forma rettangolare, e su questa si basa per confrontare i rettangoli e stabilire se si sovrappongono, quindi valutare eventualmente di quanto.
L'utente ha la possibilità di fissare una percentuale massima di sovrapposizione ed eventualmente di maggiorare la figura di ingombro per fare in modo che i testi oltre a non sovrapporsi debbano anche essere distanziati di un certo numero di millimetri (in funzione della scala di stampa impostata- vedi comando IMPOSTA).
Una volta individuati i testi da eliminare il programma permette di decidere se eliminarli oppure se spostarli su di un altro layer il cui nome viene costruito utilizzando il nome del layer originale con l'aggiunta del suffisso specificato nella finestra di dialogo.

.topic 19016
Posizione menu a tendina

Toolbar

Questa toolbar contiene i comandi per la generazione e la gestione del modello del terreno.
Si possono generare dei modelli partendo da piani quotati, introducendo anche delle linee di vincolo. I modelli generati possono essere materializzati con triangoli a polilinee 3D oppure con 3Dfacce ed eventualmente trasformare le une nelle altre. Vi sono dei comandi che consentono la modifica delle falde triangolari dopo averle generate oppure colorarle in funzione della quota o della pendenza.
E' possibile importare le maglie quadrate, nonché generale partendo dal modello a falde triangolari.

.topic 19017
   Nome Comando al Prompt: _3DPOLY

E' il comando _3DPOLY di AutoCAD standard ed è stato inserito in questa toolbar per comodità.
Le polilinee 3D, infatti, sono utilizzate per definire le linee di vincolo come contorni esterni, isole, discontinuità.

.topic 19018
   Nome Comando al Prompt: Clop3D

Questo comando permette di proiettare una linea oppure una polilinea su un modello a falde triangolari. Tecnicamente ogni triangolo definisce un piano nello spazio tridimensionale e con questo comando le linee o le polilinee selezionate vengono proiettate su detti piani.

Il comando visualizza la finestra di dialogo mostrata nella figura dove sono presenti tre riquadri descritti quì di seguito.
Riquadro Crea polilinea 3D: serve per scegliere se generare la polilinea 3D proiettata sul modello, dato che l'utente potrebbe voler generare solo i punti corrispondenti ai vertici.
Riquadro Crea Punti: serve per scegliere se generare i punti corrispondenti ai vertici e alle intersezioni con i lati dei triangoli.
Riquadro Tipologia: serve per indicare a CADPak su quale tipo di oggetti deve basarsi per fare la proiezione, infatti non sempre si hanno a disposizione i triangoli, si potrebbero avere le curve di livello di tipo layered oppure semplicemente degli oggetti tridimensionali.
Nota: Layered è un termine coniato per CADPak e serve per definire un tipo di curve di livello bidimensionali con l'informazione relativa alla quota intrinsecamente definita nel fatto che ogni curva di livello o allocata su di un layer il cui nome esprime la quota. Ad esempio la curva di livello di quota 10.5 è posizionata sul layer P0010_50.

.topic 19019
   Nome Comando al Prompt: Poly_Join

Questo comando unisce entità linea, polilinea o arco che abbiano almeno un vertice in comune, creando un'unica polilinea con le caratteristiche (layer, colore, tipo linea) della prima selezionata. Il funzionamento richiede di selezionare la prima entità e poi di seguito le altre. Il comando successivo, che genera il modello a falde triangolari, chiede all'utente di individuare con il mouse un poligono tutto d'un pezzo sotto forma di 3D polilinea che descrive il contorno esterno del modello da generare. Molto spesso, soprattutto se il piano quotato è molto grande, non si riesce a disegnare in autocad una polilinea 3D unica, ma delle spezzate disgiunte che se separate non delimitano un contorno, da quì la necessità di unirle. Si evidenzia il fatto che le estremità comuni tra le varie spezzate devono coincidere perfettamente, anche in quota.

.topic 19020
   Nome Comando al Prompt: Trigon

Icona	Voce di Menu	Comando tastiera
Il comando genera il modello del terreno a falde triangolari sulla scorta dei punti tridimensionali presenti nel disegno.
I dati necessari sono solamente i punti in 3D a video.
I dati facoltativi sono i vincoli, cioè:
Contorni: Polilinee 3D (3dpoly) che definiscono i contorni esterni delle aree in cui si desidera ottenere l'elaborazione del modello.
Isole: Polilinee 3D (3dpoly) che definiscono dei contorni interni al modello che si desiderano escludere dall'elaborazione (Edifici, Strade ecc..)
Discontinuita': Polilinee 3D (3dpoly) che definiscono le linee di interruzione, es. ciglio strada, base rampa ecc.
Questi vincoli devono essere delle polilinee 3D che passano per i punti, da individuare con il modo di osnap NODO.
Lanciando il comando apparirà il box di seguito descritto:

Se, nel riquadro Selezionare, l'opzione Blocchi è abilitata, il comando TRIGON, che genera i triangoli e che quindi necessita delle quote, cerca nei blocchi l'attributo QUOTA (specificato dalla variabile TP0050); se esiste ne acquisisce il valore e lo utilizza come quota, mentre se non esiste utilizza la coordinata Z del punto di inserimento dei blocchi.
E' inoltre possibile determinare il dislivello massimo tra le quote dei punti (Parametri)e su quale Layer creare il modello (Layer…).
Dopo aver cliccato OK, il programma chiederà di selezionare gli oggetti, secondo la sequenza (per passare da un dato all'altro digitare Invio):
Contorni: Con il pickbox toccando le 3dpoly opportune.
Punti: Se esistono i contorni è sufficiente selezionarli nuovamente, se invece i contorni non ci sono, la selezione dei punti avviene per finestre (come per il comando cancella di AutoCAD).
Isole: Con il pickbox toccando le 3dpoly opportune.
Discontinuità: Con il pickbox toccando le 3dpoly opportune.

.topic 19022
   Nome Comando al Prompt: TrigonTrDwg

Questo comando permette di caricare e visualizzare un modello a falde triangolari, precedentemente salvato in un file di testo con il comando TrigonTrSave.
Dopo aver selezionato il file, il comando apre lo stesso box di dialogo del precedente a cui si rimanda per la spiegazione.
Quando si preme OK verrà chiesto il punto base di inserimento, che, in caso di risposta nulla (Invio: scelta consigliata), coinciderà con il punto di origine del sistema di riferimento del modello.
Se si desidera inserire il modello in una posizione diversa si dovranno specificare sia il punto base che un secondo punto.

.topic 19023
   Nome Comando al Prompt: TrigonTrSave

Salva il modello a triangoli (3Dface oppure 3Dpoly) in un file testo con estensione *.tri.
Il comando chiede di specificare un punto da assumere come origine del sistema di riferimento rispetto al quale calcolare le coordinate.

.topic 19024
   Nome Comando al Prompt: TrigonTrVis

Questo comando serve per far disegnare dei punti tipo grdraw (che vengono eliminati con un Ridis o Rigen) in corrispondenza
del baricentro dei triangoli allo scopo di verificarne l'esistenza.

.topic 19025
   Nome Comando al Prompt: TrigonTrOnOff

Questo comando spegne/accende il Layer su cui è stato creato il modello del terreno.
Il Layer di default, è indicato nella variabile TP7291 nel file Topak1.var.

.topic 19026
   Nome Comando al Prompt: TrigonTrAdd

Comando per aggiungere nuovi triangoli nel disegno. È possibile scegliere il tipo di triangolo da creare: 3DFACE o 3DPOLY, scegliendo l'opzione opportuna alla riga di comando (F/P). Di default è proposta l'ultima utilizzata dal comando TRIGON o TRIGONTRADD.

.topic 19027
   Nome Comando al Prompt: TrigonTrDel

Comando per l'eliminazione delle falde triangolari del terreno.
Chiede di selezionare l'area su cui intervenire e poi di individuare con il mouse dei punti interni ai triangoli da cancellare.
N.B. L'eliminazione dei triangoli deve essere eseguita pertendo dai triangoli esterni dell'area selezionata.

.topic 19028
   Nome Comando al Prompt: TrigonTrInv

Dato un quadrilatero formato da due triangoli è possibile variare la disposizione del lato comune semplicemente toccandolo con il cursore.

Così facendo è possibile variare la geometria del modello per meglio adattarla a situazioni particolari che si possono verificare sul terreno naturale.

.topic 19029
   Nome Comando al Prompt: D3F2PLV

.topic 19030
   Nome Comando al Prompt: PTPLAN

Il comando permette di determinare la quota di un punto, di cui si conoscono solo le coordinate X e Y, giacente su un piano definito dai vertici di un triangolo.
Una volta lanciato il comando PTPLAN, è richiesto di selezionare i tre punti di riferimento; in seguito si deve indicare la posizione del quarto punto: questa operazione può essere effettuata tramite il mouse o digitando le coordinate X e Y.

Esempio:
Comando: PTPLAN
Primo punto: (102.616,66.117,-2.500) 	(individuare il vertice del triangolo)
Secondo punto: (91.976,65.560,-2.500) 	(individuare il vertice del triangolo)
Terzo punto: (94.432,42.739,-1.545) 	(individuare il vertice del triangolo)
Punto da interpolare: 	(individuare il punto di cui si vuole conoscere la quota)
Intersezione = (96.089,58.292,-2.189)
Comando:

.topic 19032
   Nome Comando al Prompt: CpPtOnDtm

Questo comando permette di definire la quota di un punto posto all'interno del modello. Le coordinate x,y devono essere indicate nel disegno con il mouse, mentre la quota è calcolata in automatico.
E' possibile utilizzare questo comando per spostare punti o blocchi sul modello utilizzando l'opzione [Selezionare oggetti].

Esempio:

Comando:
Selezionare i triangoli...
Selezionare oggetti: Specificare angolo opposto: trovato(i) 90
Selezionare oggetti:
Numero di triangoli...:    90
N. Triangoli: 90
Punto [Selezionare oggetti]:
Punto interno alla triangolazione: (198.656324, 44.584764, 59.657079).

.topic 19033
   Nome Comando al Prompt: CpGrid

Questo comando permette di creare una griglia 3D, partendo dalla selezione di un modello a falde triangolari. Viene visualizzato un box di dialogo dove è possibile scegliere i parametri di creazione della griglia 3D.

.topic 19034
   Nome Comando al Prompt: DtmIn

Questo comando permette di importare nel disegno corrente una griglia 3D da un file con estensione *.dtm , *.asc. o file *.dat dell'IGM.

.topic 19035
   Nome Comando al Prompt: TriangColor

Questo comando permette di colorare i triangoli, o la maglia quadrata in funzione della quota del baricentro, della pendenza massima, dell'orientamento o dell'esposizione.
Il comando apre una finestra di dialogo da dove è possibile impostare i parametri della tipologia di colorazione che si vuole ottenere.

Dopo aver indicato nel riquadro Selezione Oggetti con che tipo di entità (3D Facce o Polilinee 3D) è rappresentato il modello, si deve procedere alla Selezione degli oggetti.
Attraverso il riquadro Operazione, è possibile scegliere il tipo di colorazione che si desidera effettuare: per Quota media, per Pendenza massima, per Orientamento o per Esposizione.
Riquadro Parametri
Titolo: indicare il titolo dell'eventuale legenda.
Prefisso: indicare il prefisso per i nomi dei Layer che verranno creati.
Attivando Inserimento legenda, verrà inserita la legenda della colorazione in un punto che l'utente dovrà definire a video al termine dell'elaborazione.
Riquadro Identificativo di classe
Attivando il check box Crea, verrà inserito in ciascun trinagolo un testo identificativo: il suo contenuto potrà essere l'Intervallo dei valori che indica la classe di appartenenza o un numero Progressivo, secondo l'opzione attivata.
Riquadro Vettore Direzione/Intensità
Se nel riquadro Operazione si è scelto di effettuare una colorazione in base alla pendenza massima, all'orientamento o all'esposizione, le opzioni contenute in questo riquadro saranno attive.
Attivando l'opzione Disegno, per ogni falda del modello, sarà disegnato un vettore, rappresentante il rapporto tra le diverse situazioni. Questa linea avrà origine nel baricentro del triangolo, e sarà ortogonale ad esso (nello spazio). La lunghezza massima, che si indica nel box Lungh. max. (mm), rappresenta il massimo valore del vettore associato al dato maggiore; gli altri dati saranno rappresentati da vettori proporzionali ad esso. In Layer è visualizzato il nome del Layer su cui saranno disegnati i vettori: somma tra il Prefisso (definito sopra), e il testo indicato nella variabile TP7335 nel file TOPak1.var (di default "Direzione").
Riquadro Esposizione
Se nel riquadro Operazione si è scelto di effettuare una colorazione in base all'esposizione, è necessario indicare l'Azimut e lo Zenit nei due box.
Dopo aver impostato i parametri ci cui sopra e selezionato le entità su cui effetturae l'operazione, si deve provvedere alla Classificazione, attraverso il punsante Creazione.

.topic 19036
  Nome Comando al Prompt: TriangSolid

Comando che permette di colorare i triangoli con un retino solido. Richiede soltanto di selezionare i triangoli. Questo comando risente delle impostazioni effettuate con il comando Trigon: dal gruppo di selezione verranno filtrati solamente i triangoli specificati.

.topic 19037
  Nome Comando al Prompt: TriangSol3D

Questo comando permette la creazione di un modello del terreno creato da solidi, sulla base di un modello a falde triangolari esistente.
Ogni triangolo, che può essere un oggetto 3DFACE o 3DPOLY, sarà proiettato lungo l'asse z fino all'intersezione con il piano XY individuato dalla quota base indicata. Saranno quindi creati deglii oggetti 3DSOLID di Autocad che geometricamente sono dei solidi prismatici a base triangolare.
Dopo aver lanciato il comando, appare il seguente box di dialogo.

.topic 19038
Posizione menu a tendina

Toolbar

Questa barra degli strumenti contiene i comandi per la generazione e la gestione delle curve di livello.
CADPak può generare le curve di livello in diverse modalità: a spezzate, a curve, bidimensionali, tridimensionali, di tipologia layered.
Vi sono dei comandi di conversione da una modalità ad un'altra per consentire flessibilità di gestione, anche quando le curve di livello provengono, via files dxf, da altri programmi.

.topic 19039
   Nome Comando al Prompt: CURLIV_DAT

Questo comando richiama una finestra di dialogo con cui impostare le modalità di disegno delle curve di livello. Deve essere effettuato prima di disegnare le curve di livello, perché non agisce sulle curve già disegnate, ma soltanto su quelle disegnate in seguito; le impostazioni influiscono sui comandi che seguono.

Layered è un termine coniato dai programmatori di CADPak per indicare un particolare tipo di curve di livello bidimensionali, la cui quota viene definita attraverso il nome del layer al quale appartengono. Esisterà un layer per ogni quota delle curve di livello; ad esempio le curve di livello di quota +10.00, saranno poste sul layer P0010_00, mentre quelle di quota -10.00 sul layer M0010_00.
Nel riquadro Offset Quota è possibile indicare un valore che sarà sommato alla quota del modello, cioè di "spostare" altimetricamente il modello a curve rispetto al modello triangolare del terreno.
Nella sezione Parametri Layered (attivo se la tipologia selezionate è Layered) è possibile definire il colore delle curve (bottone Col. a sinistra). Attivando l'opzione Mult. è consentito differenziare il colore delle multiple (bottone Col. a destra) ed il passo tra una multipla e la successiva attraverso il box Val. Il passo va indicato quale dislivello tra una multipla e la successiva.

Selezione punti serve per governare il funzionamento del comando Curliv_T, per la generazione delle linee di livello triangolo per triangolo (puntando con il puntatore sui punti del piano quotato). In tal caso le possibilità sono:
a)	I punti a video sono in 3D. Selezionare i vertici del triangolo.
b)	I punti a video sono in 2D con il testo della quota accanto. Selezionare i vertici del triangolo e i testi che ne definiscono la quota. Per maggiori informazioni vedere la descrizione dettagliata del comando.

Il riquadro "Parametri" serve per decidere se si devono generare le curve di livello come delle Spezzate a spigoli o Smussate. Si possono impostare delle variabili che governano il modo in cui CADPak smussa le linee.

L'opzione Spezzate invece abilita il disegno delle curve di livello a segmento rettilinei.
Attenzione: selezionado l'opzione Smussate è ulteriormente possibile selezionare anche l'opzione Spezzate (e viceversa) e posizionare la seconda visualizzazione su di un altro layer (ad esempio spento e/o non stampabile), in questa maniera si riesce ad evidenziare sia la restituzione rigorosa( spezzata) sia la sua approssimazione.
I pulsanti Layer che vi sono in questa area del box sono abilitati quando la restituzione delle curve non è di tipo Layered, oppure quando si è fatta la doppia selezione.
L'utente ha la inoltre facoltà di determinare l'ampiezza dei tratti di discretizzazione intervenendo sulla formula matematica che governa il calcolo della lunghezza dei tratti (vedi pulsante Avanzati):

Dove:
a	=	angolo in radianti
L	=	lunghezza dei tratti
L0	=	lunghezza dei tratti per a < angolo minimo
E	=	coefficiente numerico a discrezione dell'utente
K	=	coefficiente numerico a discrezione dell'utente

Le variabili globali che regolano la generazione delle curve di livello sono nel file TOPAK1.VAR e sono comprese fra TP7250 e TP7285.

.topic 19040
   Nome Comando al Prompt: TRIGONCL

Disegna le curve di livello sulla base del modello a falde triangolari e secondo le specifiche introdotte con il comando Curliv_Dat.
Il comando verifica se esiste nella memoria del computer un modello elaborato ma mai disegnato; se esiste chiede all'utente di poterlo disegnare con il box di dialogo della figura.

Se TRIGONCL non trova modelli ancora residenti in memoria significa che sono già stati disegnati oppure salvati in un file (vedi comando TRIGONTRSAVE) e pertanto chiede direttamente di selezionare i triangoli nel disegno.

.topic 19042
   Nome Comando al Prompt: CURLIV_T

.topic 19043
   Nome Comando al Prompt: TRIGONCLPINT

Dato un modello a falde triangolari, con questo comando è possibile disegnare le linee di livello nei singoli triangoli (uno alla volta), selezionandone un punto interno.
Questo comando risente delle impostazioni effettuate con CURLIV_DAT.

.topic 19044
   Nome Comando al Prompt: CLONOFF

.topic 19045
   Nome Comando al Prompt: SMOOTHMPL

.topic 19046
   Nome Comando al Prompt: CLDELLYD

Cancella tutte le curve di livello, ricadenti in una o più finestre di selezione, che rispondano alla codifica layered. In pratica il comando esegue un filtro sui soli oggetti layered tralasciando altri eventuali oggetti selezionati.

.topic 19047
   Nome Comando al Prompt: CLDATCOL

.topic 19048
   Nome Comando al Prompt: EPM

Questo comando permette di impostare la quota delle curve di livello, cioè di tradurre delle semplici polilinee e/o segmenti in curve di livello con una quota.
Spesso accade che, importando delle curve via file DXF da un programma di topografia (oppure digitalizzandole su un raster), si ottengano delle curve di livello prive di elevazione e quindi non utilizzabili per estrarre sezioni.
È necessario conoscere la quota di almeno una curva all'estremità di una intera planimetria (o di una porzione) e l'equidistanza tra le curve di livello: con questi dati è possibile elevare le linee e/o convertirle nella codifica Layered.
Cliccando su EPM appare il box di dialogo rappresentato nella figura seguente:

Il riquadro Tipo di creazione permette di scegliere come crere le curve:
Layered	Le curve diventano layered.
Normale (3D e layer corrente)	Le curve diventano 3D e vengono spostate nel 	layer corrente.
Layer (3D e cambio layer)	Le curve diventano 3D e vengono spostate nel layer che viene deciso con il bottone "Scelta" sottostante.
Layered e 3D	Le curve diventano 3D e contemporaneamente con la codifica layered cioè posizionate su layer che ne indicano la quota.

.topic 19049
   Nome Comando al Prompt: LAY23DLAY

.topic 19050
   Nome Comando al Prompt: MKP

.topic 19052
   Nome Comando al Prompt: _PEDIT

E' il comando _PEDIT di AutoCAD standard che consente di modificare le polilinee presenti nel disegno.

.topic 19053
Posizione menu a tendina

Toolbar

Questa toolbar contiene i comandi per la generazione, la modifica, il disegno delle sezioni direttamente nell'editor grafico di AutoCAD.
CADPak può generare le sezioni basandosi sulle curve di livello, sulle falde triangolari, sui punti battuti secondo le necessità dell'utente.
CADPak ricava automaticamente i numeri generatori delle sezioni dal disegno lungo la linea di sezione indicata dell'utente e li memorizza sotto forma di file a ASCII. Con un secondo comando poi disegna la sezione leggendo i dati memorizzati in file ASCII ed eventualmente modificati dall'utente.

.topic 19054
   Nome Comando al Prompt: CLOPER

Attraverso questo comando, che visualizza inizialmente un box di dialogo, si estraggono in un file ASCII le coordinate dei picchetti di una sezione semplicemente tracciando sopra le linee di livello LAYERED o 3D oppure anche sulle falde triangolari 3Dpoly una linea o una polilinea (anche curva) qualsiasi che ne definisce la traccia.
Per utilizzare questo comando, è necessario avere le curve di livello in 3D oppure in modalità LAYERED oppure ancora le falde triangolari sotto forma di 3DPoly, in modo che esse contengano l'informazione sulla quota.
L'obiettivo della funzione CLOPER è quello di individuare, estrarre, e scrivere in un file ASCII i dati necessari al disegno della sezione, che avverrà in un secondo momento tramite il comando S2D; il file ASCII che viene generato consta di due parti, la prima denominata INTESTAZIONE individuata nelle prime sei righe del file, contiene una serie di parametri che serviranno poi per il disegno della sezione, la seconda parte invece contiene i dati veri e propri della sezione, cioè una serie di righe scritte nella forma seguente:

Dove:

Con questa funzione CADPak trova le coordinate cartesiane dei punti di intersezione fra la linea di sezione e le linee di livello, le traduce in DISTANZE PARZIALI e QUOTE ed infine scrive questi valori calcolati in un file testo. Il comando S2D acquisisce i dati da questo file e disegna la sezione corrispondente.
Le variabili globali che regolano questo comando sono nel file TOPAK1.VAR e sono quelle comprese fra TP7350 e TP7392.
Le opzioni disponibili nel comando sono:
riquadro Operazione permette di scegliere se lungo la linea o spezzata che interseca le linee di livello, si vogliono estrarre i dati di una sezione oppure inserirne le quote (Estrarre o Quotare).

Di seguito vengono esplicitati i parametri relativi all'operazione di estrazione di una sezione:

Il riquadro Tipologia serve per indicare a CADPak la tipologia delle linee di livello su cui si intende operare: la scelta permette di scegliere tra le curve di tipo Layered, 3D oppure di effettuare la sezione o la quotatura sui Triangoli.
Riquadro Selezione serve a definire come si intende definire la linea lungo la quale eseguire la sezione, ossia se si desidera selezionare una linea/polilinea di sezione presente nel disegno e che interseca gli oggetti da sezionare, o se il riferimento è una polilinea 3D, oppure se si vuole tracciare una linea di sezione al momento che però è virtuale e sparisce con l'utilizzo del comando RIDIS o RIGEN.

Segue una esemplificazione di cosa si intende per Intestazione  e Tabella:

Di seguito riportiamo un tipico file dati di una sezione:

Le prime sei righe costituiscono l'intestazione, mentre le rimanenti righe rappresentano i dati numerici relativi alla sezione.

Un altro compito che il comando CLOPER è in grado di svolgere è quello di inserire le quote nelle linee di livello semplicemente tracciando una linea/polilinea che le intercetta; quest'ultima operazione si esegue selezionando Quotare nel riquadro Operazione e selezionando i parametri adeguati allo scopo nel riquadro Quotatura; tali parametri sono:
Posizione: permette di inserire il testo della quota o Lungo la sezione oppure alla fine della curva di livello (Finale);
Opzioni: permettono di effettuare il Taglio curve, cioè se la quotatura deve avvenire tagliando ed inserendo il testo di quota lungo una curva di livello oppure no, ed eventualmente di Quotare solo le multiple stabilendone il passo (Valore);
Altezza testo direttamente in millimetri stampati; risente della scala impostata attraverso il box di dialogo del comando IMPOSTA.
Fattore di larghezza per il testo, che utilizza lo stile corrente.
Distanza laterale determina la distanza in millimetri stampati fra il testo e le due porzioni di curva fra i quali viene inserito (se attivato taglio curve). Questa opzione risente delle impostazioni IMPOSTA.
Il bottone Layer serve per stabilire il nome del piano su cui inserire il testo di quota.
Quanto ai parametri dei riquadri Tipologia e Selezione si rimanda a quanto già descritto nella sezione relativa all'estrazione del profilo.

Profili longitudinali su polilinee curve .

Se la linea di sezione è una polilinea contenente degli archi o dei settori circolari CADPak determina i punti di intersezione fra la linea di sezione e le curve di livello (o triangoli) ed inoltre i punti iniziali e finali delle curve quindi lo sviluppo, il raggio e l'angolo al centro delle curve.
Si riporta lo stampato di un file di sezione eseguita su di un profilo contenete una curva:

.topic 19055
   Nome Comando al Prompt: S2D

La funzione che interagisce con questo box di dialogo serve per produrre il disegno di una sezione partendo da un file ASCII con intestazione e dati, ottenuto con il comando CLOPER oppure manualmente con un editor.

Le due caselle Invertire che si trovano sia nel riquadro File terreno che in File progetto servono per far sì che CADPak disegni le sezioni con la disposizione dei picchetti invertita.

Se le righe del file con i dati della sezione iniziano con il carattere asterisco *, vengono ignorate ai fini del disegno delle linee verticali della sezione, delle quote e delle distanze relative però la presenza del picchetto rimane al fine del calcolo delle progressive dei picchetti successivi.

Le righe in grassetto e corsivo differiscono per il simbolo asterisco all'inizio della riga che, se presente, impone a CADPak il disegno della sezione come mostrato nella figura.

Le variabili globali interessate da questo comando sono comprese fra TP1210 e TP1290 nel file TOPak1.var.

Specifiche per Intestazione e File tabella.
Intestazione - specifiche per la personalizzazione.
Per intestazione si intende una porzione di file testo, composta da 6 righe, che permette a CADPak di reperire le informazioni su come disegnare la sezione.
Esempio di file testo con i dati di una sezione:

Se una riga nel file testo inizia con un carattere "*", come (nell'esempio il picchetto 3), il picchetto non viene disegnato, mentre la sua presenza viene conteggiata nelle distanze e nelle quote.
L'intestazione può essere aggiunta automaticamente dal comando CLOPER; oppure, nei casi in cui essa non è inserita automaticamente, aggiunta dall'utente con il comando  DT_UNION.
L'intestazione di default fornita con CADPak è il file testo di nome PROXY.INT contenuto nella cartella C:\…\…\CADPAK7\UTIPAK.
    File intestazione:

Di seguito si riporta la definizione dei parametri che governano ognuna delle righe dell'intestazione (si rammenta che ogni riga di un file testo è denominata record, ed ogni record è suddiviso in campi).
Significato delle righe del file di intestazione:
INT = Numero intero		REA = Numero con virgola (obbligatorio)		STR = Stringa
01, 02, 03, 04, 05, 06 . . .=Numero del campo all'interno della riga.
Le stringhe devono essere racchiuse tra una coppia di " "
Queste regole sono descritte nel file REG-TAB.TXT e si possono leggere con un qualsiasi editor.
ð	Riga 01	(1000,3) -----> (01,02)
Campo 01  INT  Unita' di misura: 1=mm  10=cm  100=dm  1000=m  ecc.
Campo 02  INT  Tipo di dati:
1 se file con: Nome picch., X, Y, Z			Riga 7	(1)
3 se file con: Nome picch., Dist. parz., Quota 	Riga 7	(3)
Nella versione 4.20 questo campo viene ignorato, perché il riconoscimento del tipo di file avviene automaticamente.
ð	Riga 02	("Quota = ",0.0,"m.s.l.m.",70,2,ISO,35,4,2) ---->(01,02, . . . . ,08)
Campo 01  STR	Prefisso per stringa quota fondamentale.   es. "Quota="
Campo 02  REA	Quota fondamentale.  es.  930.00
Campo 03  STR	Postfisso per stringa quota fondamentale.  es. "m.s.l.m."
Campo 04  REA	Distanza X in mm dall'origine per posiz. testo quota fondamentale.
Campo 05  REA	Distanza Y in mm dall'origine per posiz. testo quota fondamentale
Campo 06  STR	Stile testo per quota fondamentale (max 8 caratteri)
Campo 07  STR	Piano testo per quota fondamentale
Campo 08  REA	Altezza testo fondamentale in mm
Campo 09  INT	Numero decimali per fondamentale
ð	Riga 03	(40,10,0,20,12) ---->(01,02,03,04,05)
Campo 01  STR	Piano per la polilinea profilo terreno
Campo 02  STR	Piano linee verticali
Campo 03  STR	Offset alla quotatura progressiva (aggiunge)
Campo 04  STR	Piano per le linee verticali estreme della sezione.
Campo 05  STR	Piano per le linee verticali delle eventuali quote interpolate.
ð	Riga 04	(100,20) ---->(01,02)
Campo 01  REA	Distanza per le ettometriche (es.: 100)
Campo 02  STR	Piano per le ettometriche
ð	Riga 05	("Scala lunghezze 1:",100," ",100,20,ISO,35,5,0) ---->(01,02, . . . ,09)
Campo 01  STR	Prefisso per stringa scala lunghezze (orizz.)
Campo 02  REA	Denominatore di scala lunghezze.
Campo 03  STR	Postfisso per stringa scala lunghezze (orizz.). es. " " oppure " Come da planimetria"
Campo 04  REA	Distanza X in mm dall'origine per posiz. testo scala lunghezze
Campo 05  REA	Distanza Y in mm dall'origine per posiz. testo scala lunghezze
Campo 06  STR	Stile testo per scala lunghezze (max 8 caratteri)
Campo 07  STR	Piano testo per scala lunghezze
Campo 08  REA	Altezza testo per scala lunghezze
Campo 09  INT	Numero decimali per scala lunghezze
ð	Riga 06	("Scala altezze 1:",100," ",100,30,ISO,35,5,0) ---->(01,02, . . . ,09)
Campo 01  STR	Prefisso per stringa scala altezze (vert.)
Campo 02  REA	Denominatore di scala altezze
Campo 03  STR	Postfisso per stringa scala altezze
Campo 04  REA	Distanza X in mm dall'origine per posiz. testo scala altezze
Campo 05  REA	Distanza Y in mm dall'origine per posiz. testo scala altezze
Campo 06  STR	Stile testo per scala altezze (max 8 caratteri)
Campo 07  STR	Piano testo per scala altezze
Campo 08  REA	Altezza testo per scala altezze
Campo 09  INT	Numero decimali per scala altezze

File tabella - specifiche per la personalizzazione.
Il file tabella PRO.TAB viene fornito con CADPak ed è contenuto nella sotto directory C:\CADPak\UTIPAK.

Come si legge il file:
    Ogni riga del file corrisponde ad una riga nella tabella della sezione.
    Ogni riga deve contenere 15 elementi (campi) separati dal carattere virgola ",".
Di seguito si forniscono le definizioni per ognuno dei 15 elementi, con l'indicazione del tipo: INTero, REAle, STRinga.
Le stringhe devono essere racchiuse da una coppia di apici doppi " ".
Descrizione dei campi di ogni riga (hanno tutte lo stesso numero di campi):

L'utente può aggiungere, se necessario, alcune righe vuote e da completare manualmente, del tipo:

Vi sono inoltre altri parametri di gestione della tabella, che si trovano nel file delle variabili globali TOPak1.var di cui si riporta di seguito un estratto.

.topic 19056
   Nome Comando al Prompt: OUT_DAT

Lo scopo di questo comando è duplice:
ð	Creare un file testo contenente i numeri generatori (n, d.parz., quota) di una linea/polilinea di progetto disegnata su una sezione del terreno naturale presente nel disegno.
oppure
ð	Creare un file dati di un terreno naturale da una linea/polilinea digitalizzata.

La sequenza dei comandi da seguire è:
1.	Disegnare la linea/polilinea 2D (da sinistra verso destra), che potrebbe anche essere una polilinea di progetto sopra una sezione già presente nel disegno, che è il caso più frequente.
2.	Determinare il punto di inizio (vedi figura sopra) che serve solo ai fini del calcolo delle quote.
3.	Conoscere la quota di base (vedi figura sopra).
4.	Dare avvio al comando OUT_DAT.

Se la linea/polilinea è una situazione di progetto rispetto ad una sezione già esistente, non è necessario aggiungere alcuna intestazione, dato che già esiste quella nel file del terreno naturale, e quindi nel box di dialogo la casella Intestaz. dovrà rimanere disattivata (senza crocetta). E' importante notare che CADPak esclude l'intestazione della sezione di progetto ed utilizza sempre quella del terreno naturale, pertanto anche se l'utente ritiene opportuno includere l'intestazione nel file della sezione di progetto CADPak la ignorerà.
Al contrario, se la linea/polilinea rappresenta una linea del terreno, come potrebbe essere quella digitalizzata ricalcando un vecchio profilo su carta, sarà necessario aggiungere l'intestazione attivando la casella Intestaz. ed in questo caso naturalmente diventa indispensabile.
E' anche possibile ricavare le coordinate attraverso la selezione di punti con il puntatore procedendo da sinistra verso destra; in tal caso si dovrà attivare la casella Punti nel riquadro Selezione.
I pulsanti Scelta… hanno lo scopo di permettere la scelta e posizione nel disco, del file dati da creare e dell'intestazione da utilizzare.
L'opzione Aggiungi, se abilitata inibisce l'aggiunta automatica dell'intestazione al file ASCII che viene generato e serve a fare in modo che l'utente possa aggiungere ad un file già esistente dei nuovi dati in coda anziché sovra scrivere il file; il bottone Modifica permette di editare tale file.
Il box Quota base consente di inserire il valore di base per il calcolo delle quote (si veda disegno. sopra), mentre i chek Spazio e Virgola nel riquadro Separatore indicano al programma quale carattere utilizzare come separatore nel file.
I tre chek box Dif.quota, Pend. e Dist.incl. se attivati consentono di scrivere nel file i dati di Differenza di quote tra un picchetto ed il precedente, pendenza del tratto e distanza inclinata. Tali valori saranno riportati sul picchetto in fase di restituzione del disegno. Attenzione: questi chek non vanno attivati se si sta eseguendo una estrazione di un profilo di progetto da sovrapporre al file dell'andamento naturale.

.topic 19057
   Nome Comando al Prompt: PRO_CLO3D

Questo comando permette di proiettare una linea oppure una polilinea su un modello a falde triangolari. Tecnicamente ogni triangolo definisce un piano nello spazio tridimensionale e con questo comando le linee o le polilinee selezionate vengono proiettate su detti piani.

Il comando visualizza la finestra di dialogo mostrata nella figura dove sono presenti tre riquadri descritti quì di seguito.
Riquadro Crea polilinea 3D: serve per scegliere se generare la polilinea 3D proiettata sul modello, dato che l'utente potrebbe voler generare solo i punti corrispondenti ai vertici.
Riquadro Crea Punti: serve per scegliere se generare i punti corrispondenti ai vertici e alle intersezioni con i lati dei triangoli.
Riquadro Tipologia: serve per indicare a CADPak su quale tipo di oggetti deve basarsi per fare la proiezione, infatti non sempre si hanno a disposizione i triangoli, si potrebbero avere le curve di livello di tipo layered oppure semplicemente degli oggetti tridimensionali.
Nota: Layered è un termine coniato per CADPak e serve per definire un tipo di curve di livello bidimensionali con l'informazione relativa alla quota intrinsecamente definita nel fatto che ogni curva di livello o allocata su di un layer il cui nome esprime la quota. Ad esempio la curva di livello di quota 10.5 è posizionata sul layer P0010_50.

.topic 19058
   Nome Comando al Prompt: PTSEZONPLAN

Questo comando permette di trasportare punti o blocchi prelevati da un profilo, lungo una polilinea.
È molto utile per inserire nel disegno della sezione i punti 3D, rappresentanti la sezione di progetto.
Lanciando il comando PTSEZONPLAN, appare il seguente box di dialogo.

Per inserire tali valori automaticamente nei blocchi, è necessario che i nomi degli attributi del blocco utilizzato corrispondano a quelli indicati nelle seguenti variabili del file TOPAK1.var:
(TP0050 "QUOTA") ;nome dell'attributo quota
(TP0051 "NOME")  ;nome dell'attributo nome
(TP0052 "X")     ;nome dell'attributo X
(TP0053 "Y")     ;nome dell'attributo Y
(TP0054 "COD")   ;nome dell'attributo codice
(TP0055 "DESC")  ;nome dell'attributo descrizione

L'opzione Punti 3D, permette di trasportare i punti o i blocchi in formato tridimensionale, base essenziale per la creazione di modelli digitali del terreno. Sarà utilizzata la quota ricavata dalla posizione dei vertici della polilinea in riferimento alla quota base e al punto d'inizio del profilo indicati

.topic 19059
   Nome Comando al Prompt: DT_UNION

Questo comando serve per aggiungere l'intestazione ai dati delle sezioni che ne sono privi.

E' possibile scegliere (Scelta…) ed eventualmente modificare (Modifica…) sia il file dell'intestazione sia quello del profilo a cui l'intestazione andrà aggiunta.
L'operazione modifica il file dei dati aggiungendo le righe dell'intestazione, come sotto evidenziato.

.topic 19060
   Nome Comando al Prompt: MODDT

Il comando permette di modificarne i parametri di un file contenente i dati di una sezione completi di intestazione. E' necessario che il file selezionato contenga l'intestazione (vedi comando DT_UNION).

Vi sono poi ulteriori parametri che si trovano nel file delle variabili globali TOPak1.var, di cui si riporta di seguito un estratto. Si ricorda ancora che questo file è in formato ASCII e che l'utente con un qualsiasi editor può effettuare le modifiche che ritiene opportune.

.topic 19062
Posizione menu a tendina

Toolbar

Questa toolbar contiene una serie di comandi di utilità per il disegno topografico i quali permettono di risolvere alcune problematiche tipiche che si registrano nei disegni topografici.

.topic 19063
   Nome Comando al Prompt: _APERTURE

Bottone che imposta la variabili _APERTURE = 8 e PICKBOX =4 ed infine il modo di osnap INT fisso.

.topic 19064
   Nome Comando al Prompt: _APERTURE

Bottone che imposta la variabili _APERTURE = 8 e PICKBOX =4 ed infine il modo di osnap NODO fisso (è' utile quando si disegnano le linee di vincolo per la generazione del modello a falde triangolari).

.topic 19065
    Nome Comando al Prompt: CP_PUNTO

Comando che consente di inserire nuovi punti in un piano quotato presente nel disegno, oppure di generare un nuovo piano quotato un punto alla volta, inserendo accanto all'oggetto che materializza i punti anche i testi con quota e nome.
I punti possono essere materializzati con degli oggetti PUNTO di AutoCAD oppure con dei BLOCCHI, possono essere tridimensionali oppure posti tutti a quota zero.
Attraverso l'opzione in linea BOX , viene visualizzato il box con il quale l'utente controlla la modalità di disegno dei punti.
Il funzionamento è il seguente:

Comando: CP_PUNTO
Box/<coordinate-posizione punto>: B (Invio)

.topic 19066
   Nome Comando al Prompt: BARBE

Il comando permette di disegnare la rappresentazione grafica delle scarpate.
Date due POLILINEE o SPLINE, rappresentanti il limite superiore ed inferiore di una scarpata, ne disegna le barbette come mostrato nella figura.

È possibile definire la distanza tra le barbe e tra loro e il limite, indicando dei valori in millimetri stampati (dipende dai parametri di U.d.M. e Scala indicati con il comando IMPOSTA). La lunghezza dei tratti corti è espressa in percentuale, rispetto alla distanza tra le due spline/polilinee.
Attivando il check box 3D, le barbette saranno create come linee 3D.
Dopo aver premuto il bottone OK, il comando chiede prima la linea da cui iniziano le barbe e poi la linea limite.

Nota importante: In AutoCAD vi è differenza fra le POLILINEE-SPLINE e le SPLINE:
-	POLILINEE-SPLINE: polilinee con più vertici smussati attraverso l'utilizzo del comando _PEDIT (opzione _S);
-	SPLINE: oggetti generati con il comando SPLINE (Curve NURBS).
Per un errore di programmazione di AutoCAD non è possibile applicare il comando BARBE di CADPak alle POLILINEE-SPLINE ma solo alle SPLINE. Selezionando una POLILINEA-SPLINE appare quindi il seguente box di richiesta:

.topic 19067
   Nome Comando al Prompt: BARBE_C

Comando che permette di cancellare le barbette generate con il comando BARBE selezionandone una soltanto.

.topic 19068
   Nome Comando al Prompt: PROGPOLY

Comando che serve per individuare delle progressive su linee, polilinee, archi e spline, digitando le distanze da tastiera.

Il comando chiede di selezionale la linea, polilinea, arco, spline e quindi di digitare da tastiera le progressive che si intendono individuare sull'oggetto selezionato.
Dopo aver selezionato la polilinea in esame, il comando apre il dialog box con il quale si ha la possibilità di selezionare o meno la visualizzazione del testo, inoltre si possono scegliere il Layer e la lunghezza delle linee di sezione.

Nella parte in basso dei box vengono riportate le unità di misura e scala correntemente impostate con il comando IMPOSTA (vedi) di CADPak.

.topic 19069
   Nome Comando al Prompt: DDMK_INVP

.topic 19070
   Nome Comando al Prompt: DIVBLK

.topic 19072
   Nome Comando al Prompt: INLI

Permette di riportare tutti i testi selezionati, su una linea in modo ortogonale e rispetto al punto di inserimento dei testi selezionati. Si possono selezionare entità in generale con i soliti sistemi di AutoCAD. Se nella fase di selezione dei testi da spostare si utilizzano delle finestre comprendenti anche altre entità, ai fini dell'esecuzione di questo comando saranno considerati soltanto i testi.
Esempio:
Si esegua lo spostamento dei testi rispetto alla linea della figura seguente:

Command: INLI (Invio)
Selezionare la linea: (Selezionare S1)
Selezionare oggetti:
Select objects: (Selezionare i testi in S2, S3, S4, S5 oppure anche con finestre di selezione)
4 Entità spostate.
Command:

.topic 19073
   Nome Comando al Prompt: RIDLC

Esempio:
Si esegua il taglio sui cerchi che individuano i punti di unione delle linee (vedi figura). Si veda che nel punto 16 il taglio non è corretto. Ciò è dovuto dal fatto che la linea L1 non è composta da due segmenti che terminano nel punto 16, ma da un unico segmento che termina nel punto 15. Nella situazione finale presentata nella figura che segue i cerchi non sono visibili in quanto eliminati.

.topic 19074
   Nome Comando al Prompt: SZE

.topic 19075
   Nome Comando al Prompt: PARAM

Le variabili globali che interessano questo comando sono contenute nel file TOPak1.var e sono le seguenti:
(TP7410 "TPAR1")  ;Nome del blocco per i parametri
(TP7411 "18")     ;Nome layer per il blocco in CP7418
(TP7412 50.0)     ;Intervallo X
(TP7413 50.0)     ;Intervallo Y
(TP7414 1)        ;Creare un blocco della parametrizz. 0=No, 1=Si
(TP7415 "PA")     ;Prefisso blocco

Preparazione del blocco di parametrizzazione:
La preparazione del blocco deve essere fatta secondo la seguente procedura:
1.	Entrare in CADPak ed impostare Udm = mm Scala 1 : 1 con il comando IMPOSTA.
2.	Quando in un disegno si inserirà la parametratura, il blocco che si sta definendo adesso verrà scalato automaticamente in funzione dei valori correnti di Udm e Scala, per questo motivo dovrà essere disegnato in modo tale che una unità di disegno corrisponda ad un millimetro stampato; ad esempio se si desidera che le due lineette che si incrociano abbiano le dimensioni di 10 mm dovranno essere disegnate di 10 unità di disegno (considerazione valida per testi ed attributi).
3.	Inserire gli attributi X ed Y.
4.	Il colore delle entità può essere qualunque, ma si consiglia il colore DABLOCCO.
5.	Utilizzare il comando _BASE per definire il punto di inserimento.
6.	Salvare il file con il nome specificato nella variabile globale CP7410 (vedi file TOPAK1.VAR); il default è TPAR1.DWG.

.topic 19076
   Nome Comando al Prompt: CVL

Il comando permette l'adattamento delle mappe su una planimetria di rilievo.
Per il funzionamento è necessario avere due punti battuti che compaiano anche sulla mappa.

Esempio:
Comando:  CVL
Selezionare le linee da correggere		(Selezionare l'intera mappa)
Sezionare oggetti:			(Invio)
Punto fisso:			(Selezionare il punto 1)
Punto errato:			(Selezionare il punto 2)
Punto corretto:			(Selezionare il punto 3)
Elaborazione... 33/33razione... 1/33
Comando:

.topic 19077
   Nome Comando al Prompt: _ATTMOVE

Comando di CADPak (vedasi CADUtility) che permette di spostare gli attributi dei blocchi inseriti nel disegno. Basta digitare il comando, selezionare gli attributi ed indicarne il punto base e il punto finale dello spostamento.
Esempio:

.topic 19078
   Nome Comando al Prompt: TRANSFORMRTMIN

Attraverso il seguente comando è possibile eseguire una rototraslazione degli oggetti (tipicamente una mappa o un rilievo) facendo riferimento ad un certo numero di punti (minimo tre) di cui se ne conosce la posizione. Il comando eseguirà la trasformazione (cioè riposizionerà i punti e gli oggetti) riducendo l'errore attraverso la minimizzazione dello scarto quadratico medio (secondo le note formule statistiche della teoria degli errori).
Il comando chiederà il 1° punto errato e poi la sua posizione corretta, successivamente il 2° e così via per il numero di punti a discrezione dell'utente (si noti che più punti di riferimento si utilizzano più l'errore in termini di scarto quadratico medio diminuisce, secondo la teoria degli errori in maniera inversamente esponenziale). Terminato di inserire i punti con Invio si prosegue nel comando: il software chiederà se si desidera posizionare i punti nel disegno(cioè visualizzare la posizione dei nuovi punti in base alla elaborazione, che differiranno dai riferimenti per via dell'approssimazione), se eseguire la trasformazione considerando il fattore di scala, di selezionare gli oggetti che si voglio trasformare, se farne una copia. Rispondendo negativamente a questa domanda il software eseguirà la trasformazione degli oggetti selezionati e terminerà il comando. In caso invece di risposta positiva alla domanda se si desidera eseguire una copia degli oggetti, il software chiederà ancora se si desidera eseguire il cambio layer ed in caso di risposta affermativa se tale cambio va eseguito sugli oggetti originali.

Nota: la trasformazione applicata ad oggetti vettoriali sarà rigida cioè senza deformazione degli oggetti stessi che manterranno le dimensioni e forma originali, mentre se la si applica ad oggetti di tipo raster produrrà una deformazione degli stessi attraverso la modifica dei fattori di scala in x e y.

Il software scrive nella finestra di dialogo di AutoCAD (attivabile con F2) un riassunto dell'elaborazione con i dati di riferimento, come quello sotto riportato.

---------------------------------------
   Parametri della trasformazione
---------------------------------------
Rotazione rad/deg.: 0.12221500 / 7.00240372
Traslazione.......: X=-103.290450 Y=57.301507
Sqm...............: 8198.65164749 - 2.84366644
---------------------------------------
      Differenze di lunghezza
Punto       Delta l        Delta L
---------------------------------------
   1        51.1570         0.7155
   2        53.4716         0.6784
   3        52.1766         1.3680
---------------------------------------
        Coordinate finali
---------------------------------------
Punto          X             Y
   1        53.3680       -19.3179
   2        46.9939       -42.5865
   3        47.9979       -30.0085
---------------------------------------

.topic 19079
   Nome Comando al Prompt: CHGATTVIS

Con il pulsante Applica si rendono visibili le modifiche, con OK si ottiene lo stesso risultato e si chiude il comando
Per ulteriori delucidazioni si rimanda al capitolo CADUtility toolbar Blocchi \ Attributi.

.topic 19080
   Nome Comando al Prompt: TRANSFORMRTM

E' l'editor interno di CADPak che consente di aprire, modificare, stampare i file ASCII.

Cliccando su questa casella si manda in esecuzione l'editor interno di CADPak; attraverso il box che compare è possibile selezionare la directory ed il file da editare.
Una volta selezionato il file desiderato e premuto OK apparirà l'Editor.

I comandi di gestione dell'Editor sono i tasti freccia e i tasti Pagina Su/Pagina Giù della tastiera. Attraverso il menu a tendina, è possibile modificare il file.

.topic 19082
Posizione menu a tendina

Questa voce di menù, priva di toolbar, lancia l'applicazione Cave che permette di elaborare delle analisi di movimentazione attraverso il confronto tra due modelli (o un modello ed un piano) del terreno.
Risulta possibile elaborare l'analisi sui modelli a falde triangolari precedentemente salvati (vedasi toolbar triangoli) e disegnare in AutoCAD il modello iniziale, quello di riferimento e quello ottenuto dalla sovrapposizione dei due (Modello di confronto).

.topic 19083
Il modulo di calcolo dei volumi serve per fare il calcolo del volume compreso fra un modello a falde triangolari ed una superficie di riferimento, che può essere un piano orizzontale, un piano inclinato oppure un altro modello a falde triangolari.

Una volta definita la superficie di cui si vuole ottenere il calcolo (solitamente la superficie di progetto) e la superficie di riferimento, CADPak calcola le superfici ed i volumi di scavo e riporto, fornendo il dettaglio triangolo per triangolo, oltre che i valori totali. Inoltre elabora il modello differenza a falde triangolari utilizzando le quote rosse.
Il modulo di calcolo dei volumi può disegnare i modelli a falde triangolari numerando i triangoli e colorandoli a discrezione dell'utente e per il modello differenza (quote rosse) colora i triangoli con colori diversi a seconda che siano in sterro, riporto, oppure a movimentazione nulla.
Le sezioni e le curve di livello possono essere ottenute utilizzando le normali procedure topografiche di CADPak.
Facendo le curve di livello sul modello basato sulle quote rosse si ottengono le isolinee di scavo/riporto; ossia si individua precisamente dove e quanto si è scavato o riportato.
Facendo le sezioni sul modello basato sulle quote rosse si ottengono inoltre dei grafici di scavo/riporto.

.topic 19084
Il programma effettua il calcolo su modelli a falde triangolari elaborati con il modulo topografico di CADPak e salvati con  il  comando TrigonTrSave. Questo comando genera dei files di testo contenenti i modelli su cui si vogliono effettuare i calcoli.

.topic 19085
-	Un file di testo con il calcolo dettagliato triangolo per triangoli di superfici e volumi
-	Un file di testo con i risultati totali si superfici e volumi
-	Un file di testo con le superfici dettagliate triangolo per triangolo 2D/3D del Modello da calcolare
-	Un file di testo con le superfici triangolo per triangolo 2D/3D del Modello di riferimento (superficie di riferimento generica)
-	Il disegno delle falde triangolari, numerate, del modello di calcolo
-	Il disegno delle falde triangolari, numerate, del modello di riferimento
-	Il disegno delle falde triangolari, distinte per colore e layer in funzione del tipo (scavo, riporto, movimentazione nulla).
Nel box principale del modulo vi sono due pulsanti (Info modello) che servono per visualizzare, modificare e stampare i due file di testo che contengono il calcolo delle superfici dettagliate triangolo per triangolo dei modelli.

.topic 19086
Il calcolo si basa sulla sovrapposizione di coppie di triangoli, ciascuna coppia è formata da un triangolo del modello di riferimento ed un triangolo del modello di progetto. Se il riferimento, invece di un modello, è un piano, i due triangoli avranno la stessa proiezione nel piano XY: cioè le coordinate XY dei vertici identiche, ma le Z diverse.

Il programma analizza tutto il modello esaminando una coppia di triangoli alla volta e valutando per ciascuna di esse i valori di volume e di superficie. La determinazione di questi valori avviene scomponendo in triangoli "secondari" il poligono derivante dalla sovrapposizione dei triangoli, come mostrato nella figura.
Per ogni coppia di triangoli è calcolato il dettaglio di superfici e volumi, che viene poi scritto nella tabella che può essere visualizzata premendo il bottone come indicato nella figura seguente.

.topic 19087
1.	Lanciare CADPak e generare i due modelli da confrontare utilizzando i comandi del modulo CADPak.
2.	Salvare i due modelli con il comando TrigonTrSave facendo attenzione a fare sì che i due modelli utilizzino il medesimo sistema di riferimento cioè abbiano la stessa origine, 	come mostrato nella figura seguente

3.	Iniziare un nuovo disegno e lanciare il modulo di calcolo dei volumi scegliendo Topografia … Calcolo volumi oppure digitando newcave alla riga di comando di AutoCAD. 	Effettuare l'elaborazione numerica di superfici e volumi e, inoltre, l'elaborazione grafica dei due modelli con i triangoli numerati con il modello differenza a falde colorate (vedi quì 	di seguito).

3.1 Scegliere il modello da calcolare

        3.2 Scegliere "La superficie di riferimento è un modello a triangoli" come mostrato nella seguente figura

        3.2 Premere il bottone "Calcola volumi" per eseguire il calcolo dei volumi

3.3 Disegnare il modello  da calcolare con la numerazione dei singoli triangoli.

3.4 Disegnare il modello di riferimento con la numerazione dei singoli triangoli.

3.5 Disegnare il modello di differenza, cioè il modello basato sulle quote rosse.

.topic 19088
1.	Lanciare CADPak e generare il modello da confrontare utilizzando i comando del modulo topografico.
2.	Salvare il modello con il comando TrigonTrSave.

3.	Iniziare un nuovo disegno e lanciare il modulo di calcolo dei volumi scegliendo Topografia ...Calcolo volumi oppure digitando NewCave alla riga di comando di AutoCAD ed 	effettuare l'elaborazione numerica di superfici e volumi ed inoltre l'elaborazione grafica del modello con i triangoli numerati e con il modello differenza a falde colorate (vedi qui di 	seguito).

        3.1 Scegliere il modello da calcolare

    3.2 Impostare la quota del piano di riferimento

     3.3 Premere il bottone "Calcola volumi" per eseguire il calcolo dei volumi.

         3.4 Disegnare il modello da calcolare con la numerazione dei singoli triangoli.

      3.5 Disegnare il modello di differenza, cioè il modello basato sulle quote rosse.

.topic 19089
1.		Generare con CADPak il piano quotato relativo al modello da calcolare con i punti in 3D e poi fare la stessa cosa per l'eventuale modello di riferimento.
2.		Fissare due punti di origine omologhi per i modelli

3.		Salvare il modello o i modelli (calcolo e riferimento) utilizzando il comando TrigonTrSave uno alla volta.
4.	Lanciare il programma di calcolo dei volumi.

.topic 19090
Dalla fase di calcolo viene prodotta anche una tabella contenente il dettaglio dei calcoli, triangolo per triangolo; si rende necessario quindi poter individuare i triangoli nel disegno.
Una volta effettuato il calcolo, il disegno dei modelli avviene indicando nel disegno, uno alla volta, la posizione in cui inserire il baricentro del modello oppure se si desidera i modelli possono essere disegnati in coordinate originali e quindi sovrapposti e su layers diversi.

.topic 19092
Il modulo cave elabora e disegna il modello basato sulle quote rosse e che rappresenta l'insieme dei triangoli in cui vengono scomposti i poligoni di sovrapposizione dei triangoli come indicato nella figura.

Il  modello differenza rappresenta l'entità dei movimenti di terra e se su di esso si disegnano le curve di livello si ottengono le isolinee di scavo o riporto, dove naturalmente la isolinea di quota zero rappresenta la linea di passaggio tra sterro e riporto.

.topic 19093

Restituzione del rilievo
Come orientare il rilievo
Piani quotati
Modellazione a falde triangolari
DTM
Carte tematiche - Analisi geomorfologica
Curve di livello
Sezioni

.topic 19094

-  Il rilievo dei punti in campagna
-  Dal rilievo alla restituzione
-  Come stampare i libretti
-  Il trattamento del rilievo per chi non ha il registratore dei dati
-  Rototraslazione del rilievo

.topic 19095

Il rilievo dei punti in campagna

Si consiglia di assegnare il nome ai punti come consigliato nelle procedure per Pregeo; stazioni 100, 200, 300 … e punti di dettaglio 101, 102, 103….
Alcune stazioni totali consentono all'operatore di inserire in campagna la dichiarazione delle letture in avanti e indietro; con CADPak la definizione delle poligonali si fa a posteriori, a condizione però che l'operatore in campagna rilevi le battute reciproche fra i punti che ritiene di dover utilizzare come vertici di poligonale.
Da ogni stazione si deve battere la successiva e la precedente come fossero punti di dettaglio, sarà in un secondo momento che si dovranno specificare i collegamenti fra le stazioni.
Ad esempio dalla stazione 200 si deve battere un punto di dettaglio che si chiama 300 (stazione avanti) ed anche il punto di dettaglio 100 (stazione indietro).
Le poligonali non devono incrociarsi! Ad esempio nella figura seguente non dovrebbe esistere la poligonale:

Errata -->     800   700   300   400   500   600

ma al suo posto (all'interno del file *.myt che le compete) dovrebbero esistere :

Corretta --> 300  700  800  900
Corretta --> 300  400  500  600

.topic 19096

Dal rilievo alla restituzione dei punti nell'editor di AutoCAD.

Lanciare il comando UniDrv per aprire i file di testo prodotti da uno strumento topografico e convertirli nel formato per CADPak (*.myt). Ad esempio, si supponga di avere un file ottenuto con il software per lo scaricamento dati Geotool che è fornito in dotazione agli strumenti Geotronics/Spectra precision (attuale Trimble); attraverso questo comando si possono trasformare i file in formato JOB in formato MYT adatti a CADPak.
Lanciare il comando NewPolig per elaborare il file *.MYT ed ottenere oltre ad una serie di libretti, anche il disegno del piano quotato direttamente nell'editor grafico di AutoCAD.

-	All'interno del comando NewPolig cliccare sul pulsante Disegna rilievo per visualizzare la finestra di dialogo che permette l'impostazione ed il disegno dei punti

.topic 19097

Come stampare i libretti

Il comando NewPolig oltre a calcolare le coordinate permette la visualizzazione e la stampa dei libretti come mostrato nella figura.

.topic 19098

Il comando NewPolig genera i seguenti libretti.

Rilievo.myt			Libretto di campagna originale
Rilievo.log			Registro delle attività e delle anomalie trovate
Rilievo_(1.1).txt			Libretto di campagna con gli azimut originale
Rilievo_(1.2).txt			Libretto di campagna con azimut corretti per trasporto
Rilievo_(1.3).txt			Libretto di campagna con azimut derivati per compensati
Rilievo_(2.1).txt			Libretto delle stazioni
Rilievo_(3.1).txt			Libretto delle poligonali
Rilievo_(4.1).txt			Coordinate cartesiane NON compensate
Rilievo_(4.2).txt			Coordinate cartesiane compensate
Rilievo_(5.1).dat			Libretto delle misure nel formato di Pregeo 7
Rilievo_(5.2).dat 			Libretto delle misure nel formato di Pregeo 8
Rilievo_CP(6.1).xyz	Coordinate NON compensate da utilizzare con il comando C2D di CADPak
Rilievo_CP(6.2).xyz	Coordinate compensate da utilizzare con il comando C2D di CADPak

Tra questi libretti, che sono numerati, vi sono i due libretti 5.1 e 5.2 che sono i libretti di Pregeo; questi possono essere importati in forma grafica nell editor di AutoCAD con il comando C2DP (vedi più avanti inn questo manuale).

.topic 19099

Il trattamento del rilievo per chi non ha il registratore di dati

Chi non avesse a disposizione un registratore di dati da collegare allo strumento, potrà inserire il rilievo scrivendo un file di testo (cioè il libretto di campagna) utilizzando il comando Medit.

Questa finestra di dialogo serve per generare o modificare un file di testo con estensione MYT e che è adatto a CADPak e di cui segue un esempio:

<inizio del file>
NEWMYT	à	Indica a CADPak l'inizio dei dati
TITOL Rilievo di prova per Topografia	à	Indica a CADPak il titolo del rilievo
TOLLE           0.05 0.05	à	Tolleranze sulle letture reciproche per distanza e dislivello
TOLLT           0.05 0.05 0.02	à	Tolleranze sulla chiusura Planimetrico, Altimetrico ,Angoli
PUNTI           3	à	Linea che indica a CADPak l'inizio dei punti battuti
1000        1      5   1.560     5.6290    96.7275     62.036    1.460
1000        2      5   1.560    10.2170    96.7255     60.581    1.460
. . .
Staz      Punto   Cod   Hs      Azimut     Zenit     Dist. Incl.   Hp
. . .
6000      236      9   1.600    32.1775    91.3440     22.304     1.46
6000     7000      4   1.600   183.4660   104.9875     51.365    1.460
FINE	à	Linea che indica a CADPak la fine dei punti battuti
PFISS           1000 0.0 0.0 0.0	à	Coordinate della prima stazione del rilievo – Pfiss  Staz   x   y   z
ORIEN           1000 0.0	à	Orientamento della prima stazione  –   Orien Staz    Angolo
POLIG	à	Indica a CADPak che segue una definizione di una poligonale
1000  2000  3000  4000  5000  6000	à	Stazioni che compongono la poligonale
FINE	à	Indica a CADPak che la fine dei dati
<fine del file>

Le righe in grassetto sono obbligatorie e ciascuna viene interpretata da CADPak come un comando (primi 5 caratteri) con i relativi parametri. Ad esempio la riga:

ORIEN     100   0.00

E' interpretata dal programma come l'istruzione per traslare tutto il rilievo di 800 m in quota, cioè a tutte le quote che il programma calcolerà con i dati del file verranno aggiunti 800 metri.
Una volta ottenuto il libretto di campagna in formato MYT (file di testo) lanciare il comando NewPolig per elaborare il file rilievo.myt e ottenere il file rilievo.xyz contenente le coordinate cartesiane dei punti.

.topic 19100

L'orientamento del rilievo consiste sia nel determinare le coordinate della prima stazione che l'orientamento angolare vero e proprio;
con CADPak esistono tre modi per orientare un rilievo.

.topic 19102

1)  Metodo dell'angolo di correzione e delle coordinate imposte alla prima stazione

Questo metodo di orientamento prevede di imporre un valore di correzione da applicare a tutti gli azimut letti dalla prima stazione e di imporre le coordinate alla prima stazione.
Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT)
Sintassi:
PFISS     <prima stazione>      <X  stazione>     <Y stazione>        <Z stazione>
ORIEN   <prima stazione>   <angolo di correzione>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
ORIEN  100    56.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------
L'istruzione PFISS serve, come visto nel punto precedente, per imporre le coordinate della prima stazione
L'istruzione ORIEN serve invece per fare in modo che CADPak aggiunga algebricamente un determinato valore angolare a tutti gli azimut letti dalla prima stazione provocando la rotazione del rilievo a cascata su tutte le stazioni del rilievo.

.topic 19103

2)  Metodo dell'azimut imposto e delle coordinate imposte alla prima stazione

Questo metodo di orientamento prevede di imporre un valore ad una lettura azimutale effettuata dalla prima stazione della prima poligonale del rilievo.
In questo modo CADPak ruota tutto il rilievo di un angolo che risulta dalla differenza tra azimut imposto ed azimut letto realmente.

Angolo di correzione = Azimut Letto – Azimut Imposto

Il metodo prevede l'aggiunta di due righe nel libretto di campagna (cioè il file MYT):
Sintassi:
PFISS     <prima stazione>      <X  stazione>     <Y stazione>        <Z stazione>
AZIMU  <prima stazione>      <punto letto>    <azimut imposto>
Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS  100   123.326    236.326     245.326
AZIMU  100     102      156.2365
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------

.topic 19104

3)  Apertura a terra plaminetrica su due punti di coordinate note

CASO A
Sono state fatte entrambe le letture complete (Azimut, Zenit, Distanza) con lo strumento.
Come indicato nell esempio si devono aggiungere due righe nel file myt (libretto di campagna)
inserendo in questo modo le coordinate dei punti noti; si evidenzia il fatto che i punti noti devono essere
presenti, con lo stesso nome, anche nella lista dei punti battuti.

Questo metodo di orientamento prevede la conoscenza di due punti  di coordinate note battuti dalla prima stazione.
Questa istruzione si può dare aggiungendo nel file MYT, due righe come la seguente:

Sintassi:
PNOTO  <prima stazione>  <punto battuto>  <X punto>  <Y punto>  <Z punto>

Esempio:
A titolo di esempio segue un estratto da un libretto di campagna:
-------------------------------------------
400       458     25    1.42   333.8495    75.4190     9.0299   1.3200
400       459     25    1.42    22.6955    91.4210    25.4600   1.3200
400       460     25    1.42    30.6660    93.1880    32.5700   1.3200
400       461     25    1.42    35.2135    96.6294    71.2800   1.3200
FINE
PFISS     100      0.000      0.000        856.323
PNOTO     100      125      -82.38972      -76.25983       213.000
PNOTO     100      126      -73.51726      -76.70539     -1000.000
POLIGONALE
100 200 300 400
FINE
--------  fine del file  -----------------

Per imporre la quota della prima stazione del rilievo si può utilizzare il comando PFISS come nella riga dell'esempio:
PFISS     100      0.000      0.000    856.323
In questo modo il programma calcolerà le coordinate planimetriche riferendosi ai due punti noti e le quote verranno calcolate partendo dal fatto che la prima stazione del rilievo è a quota 856.323.
Nota importante:
Se si fa stazione su uno dei due punti di coordinate note di deve utilizzare il metodo dell'imposizione di azimut come nel seguente esempio (si è fatta stazione sul punto 100 e si è collimato il punto 124):
AZIMU   100    124        123.3266
PFISS   100   -154.97245   98.42561   723.3265    (coordinate della stazione)
Il comando NewPolig calcola le coordinare cartesiane dei punti di rilievo.
Se il calcolo avviene nell'ambito di una poligonale chiusa o vincolata le coordinate dei punti si distinguono tra compensate e non compensate; infatti i punti battuti da una stazione le cui coordinate sono compensate avranno coordinate compensate, in altre parole per ogni punto si avranno due terne di coordinate X,Y,Z (non compensate) e Xc,Yc,Zc (compensate).

CASO B
Sono state fatte entrambe le letture di cui una completa e l'altra con la sola lettura Azimutale.
Anche in questo caso, come indicato nell esempio si devono aggiungere due righe nel file myt (libretto di campagna)
inserendo in questo modo le coordinate dei punti noti; si evidenzia il fatto che i punti noti devono essere
presenti, con lo stesso nome, anche nella lista dei punti battuti.

Nota importante:
Se la quota di uno dei due punto noti non è conosiuta o semplicemente non
la si vuole usare nei calcoli la si deve omettere oppure inserire come -1000.000, così
come mostrato nell'esempio.

.topic 19105

-  Disegnare piani quotati, partendo da file di coordinate cartesiane, materializzando i punti con dei point di AutoCAD
-  Come aggiungere nuovi singoli punti ad un piano quotato esistente
-  Come aggiungere i testi di quota e nome a dei punti presenti del disegno
-  Disegnare piani quotati sotto forma di blocchi con attributo da file di coordinate cartesiane
-  Cambiare l'altezza, la posizione o la rotazione dei testi in un piano quotato già disegnato
-  Cambiare altezza, stile, larghezza, layer e rotazione dei testi in un piano quotato copiando il formato da altri testi presenti nel disegno
-  Cambiare le quote dei punti aggiornando anche i testi delle quote già presenti a video
-  Aggiungere punti ad un piano quotato nel disegno interpolando la quota fra altri punti
-  Ottenere un piano quotato partendo da polilinee "in quota"
-  Ricavare un piano quotato da una carta tecnica in formato Raster
-  Estrazione di coordinate dal disegno in un file di testo

.topic 19106

Disegnare piani quotati, partendo da file di coordinate cartesiane, materializzando i punti con dei point di AutoCAD

-	Prima di tutto si deve avere un file ASCII di partenza con le coordinate cartesiane dei punti, contenente tante righe quanti sono i punti da rappresentare.
Tali righe possono essere suddivise in tre, quattro o cinque parti (campi) secondo uno dei seguenti formati:

Significato delle lettere N, X, Y, Z, Layer:

Il carattere separatore fra i campi di ciascuna riga può essere lo spazio (uno o più spazi) oppure il carattere virgola.
Nel campo "Layer" si può introdurre una stringa che deve sottostare alle regole per la nomenclatura dei layer di AutoCAD (caratteri vietati: * ? . ; :).
Per ottenere tale file testo è possibile percorrere una delle seguenti strade:
      1)	Digitare manualmente le coordinate con un editor qualsiasi.
      2)	Esportando in un file ASCII le coordinate cartesiane da un altro programma, in questo caso si dovrebbe chiedere all'azienda produttrice del programma eventuali delucidazioni, 	magari inviando copia della presente pagina.
      3)	Elaborando i dati di campagna con TOPak Comando: NewPolig, si ottiene il file testo già pronto.
Nella directory C:\CADPAK\UTIPAK esiste un file di esempio di nome RILIEVO.XYZ.
NB:	Se il primo carattere di una riga del file è un punto e virgola ";", essa viene ignorata ai fini del disegno. Così facendo si possono inserire dei commenti.
Digitare IMPOSTA sulla riga di comando oppure cliccare sul bottone mostrato nella figura
Impostare le unità di misura a metri e la scala opportuna per il rilievo (scala delle lunghezze).

-	Lanciare CADPak e digitare C2D
In questo modo apparirà a video un box di dialogo tramite il quale si ha la facoltà di impostare una serie di parametri del disegno, come ad esempio la scala, l'altezza dei testi in millimetri stampati, il tipo di file dati da cui si attinge e così via.
Dopo aver effettuato le scelte opportune nel box, cliccare sul bottone OK ed a video comparirà il disegno del piano quotato (eventualmente utilizzare lo Zoom estensione).
Importante! Se il piano quotato serve per generare le curve di livello è necessario attivare l'opzione Punti 3D nel riquadro di dialogo di quest'ultimo comando.
NB: Nel file testo TOPAK1.VAR contenuto nella directory di CADPak, vi sono le variabili globali che regolano sia i valori di default per la finestra di dialogo del comando C2D, che ulteriori parametri per il disegno. Le variabili globali interessate sono quelle comprese fra TP1000 e TP1083.

.topic 19107

Come aggiungere nuovi punti ad un piano quotato esistente

Il comando che assolve a questo scopo è CP_PUNTO.

Questo comando presenta il seguente messaggio sul prompt dei comandi con il quale chiede di specificare la posizione del punto:

Coordinate-posizione punto o [Box/Selezione punti]:

scegliendo l'opzione B visualizza una finestra di dialogo in cui si possono determinare i parametri per l'inserimento di nuovi punti.

Le scelte effettuate in questa finestra di dialogo sono adatte al caso in cui si intendono aggiungere nuovi punti definendo la posizione XY con il mouse e la quota la si vuole digitare con la tastiera.

.topic 19108

Come aggiungere i testi di quota e nome a dei punti presenti del disegno

Il comando che assolve a questo scopo è CP_PUNTO come nel caso precedente ma con delle modalità leggermente diverse.

L'utilizzo del comando passa attraverso le seguenti fasi
1) Lanciare il comando e fare le stesse scelte fatte nella figura e premere OK
2) Alla domanda che segue
Coordinate-posizione punto o [Box/Selezione punti]:
scegliere l'opzione Selezione Punti attivabile con la lettera chiave S
3) Selezionare i punti presenti nel disegno

.topic 19109
Disegnare piani quotati sotto forma di blocchi con attributo da file di coordinate cartesiane

Il meccanismo è simile al caso appena visto, con la variante che l'utente dovrebbe definirsi il blocco personalizzato (vedasi il blocco di esempio PUNTI.DWG nella cartella di CADPak) con relativi attributi.
Si utilizza poi il comando C2D nel seguente modo:

E' possibile controllare la visibilità dei vari attributi con il comando CHGATTVIS che si trova nella toolbar Attributi.

.topic 19110

Cambiare l'altezza, la posizione o la rotazione dei testi in un piano quotato già disegnato

Se si vogliono effettuare delle modifiche "a monte", cioè prima di disegnare il piano quotato, e fare in modo che queste diventino permanenti (cioè il nuovo default) è necessario modificare le variabili globali da TP1051 a TP1083 nel file TOPAK1.VAR che si trova nella cartella di installazione di CADPak.
Se invece si vogliono modificare i testi dopo averli già inseriti ed "accomodati" nel disegno si può utilizzare il comando CHGTXT che consente di ruotare, spostare, cambiare l'altezza in millimetri in funzione della scala impostata dal comando "Imposta" ed inoltre di sommare un certo numero a dei testi numerici.

.topic 19112

Cambiare altezza, stile, larghezza, layer e rotazione dei testi in un piano quotato copiando il formato da altri testi presenti nel disegno

Si immagini di avere un gruppo di testi A che hanno delle caratteristiche corrette ed avere un secondo gruppo di testi B con caratteristiche indesiderate; il comando TXTLTXT (vedi figura) consente di copiare il formato di un testo su un gruppo di altri testi, diversificando per altezza, stile, layer etc.

.topic 19113

Cambiare le quote dei punti aggiornando anche i testi delle quote già presenti a video

Questa operazione implica due azione:

1) Spostare fisicamente gli oggetti lungo l'asse Z -->Utilizzare il comando Z-MOVE
2) Aggiornare i testi con le quote dei punti --> Utilizzare il comando CHGTXT

Per cambiare l'elevazione degli oggetti Punto che materializzano i punti del piano quotato, si utilizza il comando Z-MOVE (vedi figura) oppure il comando Sposta di AutoCAD standard, utilizzando come punto di partenza quello di coordinate 0,0,0 e quello di arrivo 0,0,Dz con Dz = valore dello spostamento.
Per aggiornare anche i valori dei testi che rappresentano le quote occorre utilizzare il comando CHGTXT (vedi figura).

offs nUm.co/Offs x,y/Pre-postfisso/……./Alt./Stile/aNgolo/Incl./Giustif./<scala alt.>: U
Offs nUm.co = offset numerico

.topic 19114

Aggiungere punti ad un piano quotato nel disegno interpolando la quota fra altri punti

Per inserire dei nuovi punti in un piano quotato interpolando la quota fra altri punti già presenti si può utilizzare il comando PXY che esegue materialmente l'operazione ed eventualmente il comando PxyDat permette di impostare il funzionamento del comando PXY.

.topic 19115

Ottenere un piano quotato partendo da polilinee "in quota"

Tipicamente, si ha questa necessità quando sono state digitalizzate le curve di livello da un raster, e da queste si vuole ottenere un piano quotato al fine di rifare il modello a falde triangolari e quindi la rappresentazione a griglia tridimensionale.

Si veda anche il comando EPM compreso nella toolbar delle curve di livello, che permette l'assegnazione della quota nel caso di polilinee digitalizzate con elevazione zero e che devono diventare curve di livello in 3D.

.topic 19116
Ricavare un piano quotato da una carta tecnica in formato Raster

In alcune situazioni si ha a disposizione un'immagine raster del territorio da cui si intende ricavare un modello a triangoli o a maglia quadrata, per farne un'analisi altimetrica o cliviometrica, oppure ottenere in AutoCAD delle curve di livello più fitte delle originali.
Di seguito, è indicata la strada più breve per fare in modo che da un'immagine Raster a curve di livello, si riesca a ricostruire il piano quotato sotto forma di punti e quote, per eseguire poi le operazioni appena menzionate.
-	Dal menu INSERISCI di AutoCAD scegliere IMMAGINE RASTER. Cliccare sul bottone ATTACCA e selezionare l'immagine per inserire la carta tecnica.
-	Dopo averla inserita è necessario che essa venga ingrandita o rimpiccolita, in modo tale che una unità di lunghezza in AutoCAD corrisponda ad un metro sul terreno.
-	Digitalizzare le linee di livello della zona di interesse con delle polilinee 2D.
-	Staccare il raster: dal menu INSERISCI di AutoCAD scegliere GESTIONE IMMAGINI e dopo aver selezionato il raster premere STACCA
-	Elevare le curve di livello digitalizzate, con il comando EPM
-	          Il comando DDMK_INVP, posiziona dei punti in corrispondenza dei vertici delle polilinee

Premere OK e selezionare le polilinee d'interesse.
In questo modo si ottengono dei punti in 3D sui quali si può sviluppare il modello a falde triangolari, la maglia quadrata, le curve di livello, le sezioni etc.
I punti così ottenuti possono essere esportati utilizzando il comando EXPDAT come indicato di seguito.

.topic 19117
Estrazione di coordinate dal disegno in un file di testo.

E' possibile estrarre le coordinate della posizione di punti, linee, polilinee, blocchi, testi, in un file ASCII. Questa possibilità è utile quando da un disegno s'intendono ricavare le coordinate dei punti per operazioni di tracciamento con una stazione totale. E' possibile inoltre convertire questi file di estrazione, nel formato proprio degli strumenti topografici (es. Wild, Topcon, Geotronics, ecc.).
Il comando da utilizzare è EXPDAT, che si può utilizzare anche per estrarre i dati delle sezioni sui punti battuti.

.topic 19118

La modellazione è un processo che genera il modello del terreno, attraverso un'opportuna unione dei punti, formando dei triangoli.
Per definizione, il modello è un oggetto che rappresenta il terreno, su cui, teoricamente, dovrebbe aderire perfettamente.
In realtà si tratta sempre di un'approssimazione, tanto più precisa, quanto più i punti sono rappresentativi e numerosi. Pertanto, la restituzione deve essere effettuata con la massima accuratezza.
Sul modello, se questo è sufficientemente rappresentativo, si possono fare operazioni di analisi altimetrica, cliviometriva e di calcolo dei volumi, con risultati veramente apprezzabili ed aderenti alla realtà.

.topic 19119

Definizione delle linee di vincolo

Le linee di vincolo possono essere:
Contorni esterni: definiti con il comando 3DPOLI  (3DPOLI  passanti per i punti) oppure con il comando PLINEA (Polilinee 2D non passanti per i punti) che delimitano esternamente il
modello

Contorni interni: definiti con il comando 3DPOLI  (3DPOLI  passanti per i punti) che delimitano zone interne al modello ove non si desidera venga sviluppato il modello
Discontinuità: definite con il comando 3DPOLI  (3DPOLI  passanti per i punti) che descrivono delle direttrici che non devono essere intersecate dai lati dei triangoli (es. ciglio di una rampa).

Nota importante:   Se, per varie esigenze, le linee di vincolo sono costruite a pezzi, possono essere unite a formare un unico elemento con il comando POLY_JOIN.

.topic 19120

Unire contorni e linee di vincolo quando sono frammentati

Non sempre si riesce a chiudere un contorno che delimita un'area dove si vuole elaborare il modello a falde triangolari, con una singola polilinea 3D chiusa.
La situazione più comune è che il contorno sia costituito da due o più polilinee 3D con un vertice in comune. Con il comando POLY_JOIN è possibile unirle ottenendo un'unica polilinea.

.topic 19122

Come disegnare il modello a falde triangolari partendo da un piano quotato a punti

Si presuppone che esistano i punti in AutoCAD sotto forma di Punti 3D. La procedura per generare il modello si compone dei seguenti comandi:
- Comando 3DPOLI per disegnare le linee di vincolo, contorni esterni, interni e discontinuità.
- Comando TRIGON per definire le modalità della restituzione e generare il modello a falde triangolari.

.topic 19123

Come disegnare il modello a falde triangolari partendo da un piano quotato a blocchi

E' possibile materializzare i punti in AutoCAD utilizzando dei blocchi con attributo, dove gli attributi possono rappresentare i valori definiti dalle variabili definite di seguito (TOPak1.var):
(TP0050 "QUOTA") ;nome dell'attributo quota
(TP0051 "NOME")  ;nome dell'attributo nome
(TP0052 "X")     ;nome dell'attributo X
(TP0053 "Y")     ;nome dell'attributo Y
(TP0054 "COD")   ;nome dell'attributo codice
(TP0055 "DESC")  ;nome dell'attributo descrizione

E' possibile

Nella cartella di CADPak vi è un blocco d'esempio PUNTI.DWG che può essere utilizzato nel comando C2D, come mostrato già in precedenza:

Il comando TRIGON utilizza le quote definite negli attributi, se queste non ci sono, utilizza come quota la posizione Z del blocco.

.topic 19124

Aggiunta di singoli triangoli al modello

Il comando TRIGONTRADD permette di aggiungere singoli triangoli nel disegno assecondando le impostazioni fatte con il comando TRIGON

.topic 19125

Modifica dei triangoli del modello

Nel caso in cui, nonostante fossero state inserite sufficienti linee di vincolo, qualche falda triangolare fosse errata è possibile correggere coppie di triangoli con il comando TRIGONTRINV.

.topic 19126

Eliminare triangoli dal modello

Per eliminare triangoli, é possibile utilizzare il comando CANCELLA di AutoCAD; tuttavia il comando TRIGONTRDEL permette di cancellare i triangoli cliccando nel loro interno anziché selezionando il bordo che potrebbe essere in comune con un altro triangolo e impedire la cancellazione di altri triangoli.

.topic 19127

Trasformare falde triangolari da 3DFACCIA a 3DPOLI e viceversa

Con TOPak i triangoli possono essere rappresentati sia con 3DFACCE che con 3DPOLI.
Con il comando D3F2PLV si possono trasformare le une nelle altre.
Se si vogliono fare le sezioni, basandosi sulle falde triangolari, occorre che queste siano delle 3DPOLI. Avendo triangoli già disegnati come 3DFACCE, con questo comando è possibile immediatamente in polilinee 3D. Le sezioni saranno trattate più avanti, in questo manuale.

.topic 19128

Aggiungere dei punti contenuti in un piano definito da tre punti

Si immagini di dover aggiungere dei punti complanari ad un triangolo, interni o esterni ad esso.
Il comando PTPLAN richiede di indicare i tre vertici del triangolo (utilizzare modo di Osnap opportuno) e di indicare con il mouse i punti da inserire. Il punto verrà disegnato utilizzando le coordinate XY indicate a video, mentre la coordinata Z sarà calcolata in funzione dei tre punti dati.
Nel caso in cui il punto indicato non sia posto all'interno del triangolo, la sua quota sarà calcolata ugualmente in modo che esso sia complanare al triangolo.

Vedere anche il comando CPPTONDTM spiegato al punto seguente.

.topic 19129

Aggiungere dei punti complanari ad un triangolo

Dovendo aggiungere dei punti che debbano giacere sul piano/piani di uno/più triangolo, si può utilizzare il comando CPPTONDTM che chiede di selezionare un modello e di indicare dei punti (X,Y) con il mouse da aggiungere; la coordinata Z di ciascun punto aggiunto verrà calcolata in modo che sia complanare con il triangolo in cui giace.
Se il punto indicato non ricade all'interno di un triangolo, la sua quota sarà zero.

Vedere anche il comando PTPLAN spiegato al punto precedente.

.topic 19130

Spostare dei punti o dei blocchi in modo che diventino complanari a dei triangoli

Si immagini di avere un modello a falde triangolari e di voler fare in modo che una serie di punti e/o blocchi vengano spostati in quota in modo che diventino complanari con i triangoli come mostrato nella figura.

Il dialogo del comando è il seguente:
Comando:
Selezionare i triangoli...
Selezionare oggetti: <selezionare i triangoli>
Selezionare oggetti: <invio per terminare la selezione dei triangoli>
Numero di triangoli...:   80
N. Triangoli: 80

Punto [Selezionare oggetti]: S
Selezionare testi/punti/blocchi
Selezionare oggetti: <selezionare i blocchi o gli oggetti che si vogliono spostare>

Vedere anche il comando PTPLAN spiegato al punto precedente.

.topic 19132

-  Disegno di una rappresentazione 3D a maglia quadrata partendo dal modello a falde triangolari
-  Disegno di una rappresentazione 3D a maglia quadrata partendo da un supporto cartaceo a curve di livello

.topic 19133

Disegno di una rappresentazione 3D a maglia quadrata partendo dal modello a falde triangolari

Spesso è richiesta una rappresentazione tridimensionale di un terreno rilevato, oppure una situazione di progetto per fare rappresentazioni tipo render.

Per ottenere questo risultato occorre partire dal modello a falde triangolari (vedere il comando TRIGON già esaminato nelle pagine precedenti).
Dopo aver ottenuto i triangoli in AutoCAD si puo elaborare il DTM a maglia quadrata con il comando CPGRID.

Per informazioni dettagliate sul funzionamento del comando CPGRID si rimanda al manuale di riferimento ai comandi.

.topic 19134

Disegno di una rappresentazione 3D a maglia quadrata partendo da un supporto cartaceo a curve di livello

Procedura:
-	Acquisizione della carta con uno scanner;
-	Digitalizzazione, in AutoCAD oppure con un vettorializzatore automatico, delle curve di livello, in modo che esse diventino delle polilinee; (vedere il comando MKP che si usa nel caso in cui siano linee invece di polilinee).
-	In questo modo si ottengono delle polilinee che non sono ancora curve di livello perché non hanno la quota, ma possono diventare tali attraverso il comando EPM di CADPak, come mostrato nella figura seguente.

-	Ora è necessario ottenere dei punti (entità punto) che permettano in seguito di sviluppare il modello a falde triangolari. Per raggiungere questo scopo si può utilizzare il comando DDMK_INVP.

-	Con il comando TRIGON (vedi toolbar Triangoli) si ottiene il disegno del modello a falde triangolari.

-	Con il comando CPGRID si ottiene il disegno del modello a maglia quadrata.

.topic 19135

-  Carta altimetrica
-  Carta clivometrica
-  Carta degli orientamenti
-  Carta dell'esposizione

.topic 19136

Carta altimetrica

Data la rappresentazione di un terreno attraverso un modello a falde triangolari, o attraverso una maglia quadrata, è possibile fare l'analisi numerica delle facce che discretizzano il terreno in funzione delle quote.
Nella procedura che segue si presuppone di avere già in AutoCAD il modello.

Cliccando su TRIGONCOLOR appare la seguente finestra:

Quando si preme il bottone OK avrà inizio la colorazione del modello e la richiesta del punto di inserimento della legenda.

.topic 19137
Carta clivometrica

In modo analogo alla carta altimetrica è possibile sviluppare la carta clivometrica; i comandi da utilizzare sono gli stessi con la differenza che nel box si dovrà scegliere Pendenza massima.

.topic 19138
Carta degli orientamenti

Vedere la procedura adottata per la carta altimetrica

.topic 19139
Carta dell'esposizione

Vedere la procedura adottata per la carta altimetrica

.topic 19140

I comandi per il disegno delle curve di livello sono raggruppati nella seguente toolbar.

.topic 19142

Dallo strumento alle curve di livello in sintesi

Segue una breve dei passi necessari per arrivare al disegno delle  curve di livello partendo dal libretto di campagna.

Passo 1. Dati in formato Strumento (Trimble, Leica, Nikon ecc)	--->    UNIDRV 	--->	Libretto di campagna in formato CADPak (<file>.myt)
Passo 2. Libretto di campagna in formato CADPak (<file>.myt)	--->    NEWPOLIG    	--->	Libretti vari + disegno in AutoCAD (Punti 3D)
Passo 3. Punti 3D in AutoCAD	--->    TRIGON         	--->	Modello a falde triangolari
Passo 4. Modello a falde triangolari	--->    TRIGONCL     	--->	Curve di livello

.topic 19143

Linee di livello, significato di Layered e 3D

Solitamente i programmi di topografia generano dei disegni in cui le curve di livello hanno un'elevazione (Z di AutoCAD) pari alla quota che devono rappresentare.
La rappresentazione a curve tridimensionali può causare delle difficoltà nella gestione e nell'editazione del disegno, come ad esempio nell'individuazione di intersezioni con gli snap ad oggetto o nella misura delle distanze e delle aree: inconvenienti ben conosciuti da chi lavora nel settore topografico con AutoCAD.
TOPak permette di aggirare l'ostacolo introducendo un nuovo concetto: le curve possono essere contenute nel piano cartesiano xy (ad elevazione zero) senza perdere l'informazione sulla quota. Questo è possibile facendo in modo che ciascuna curva sia posta su un layer particolare, il cui nome ne rappresenti la quota, seguendo una codifica ben definita.
Esempio:
     P0010_50 è il nome del layer che contiene la curva di livello +10.50.
M0025_75 è il nome del layer che contiene la curva di livello -25.75.

Questa codifica, causa ovviamente la generazione di molti layers, che tuttavia possono essere gestiti in serie tramite le funzioni di CADUtility per la gestione dei layers oppure con i comandi di TOPak in CLONOFF per attivare e disattivare e CLDELLYD per cancellare selettivamente soltanto le linee di livello di questo tipo.
Qualora l'utente abbia la necessità di avere le curve in 3D, TOPak permette di trasformare le curve di livello da layered a 3D e viceversa.
Come trasformare delle linee o polilinee in curve di livello con quota
Ci si trova in questa situazione quando le curve di livello sono soltanto linee o polilinee, ma non hanno alcuna informazione relativa alla quota; esse rappresentano le curve di livello soltanto graficamente.
Per assegnare la quota alle linee che ne sono prive si utilizza il comando EPM.

.topic 19144

Cambiare il colore e il tipo di linea delle curve di livello

Per cambiare il colore o il tipo di linea delle curve di livello che corrispondono alla codifica Layered oppure 3D, si può utilizzare il comando CLDATCOL.

.topic 19145

Smussare le curve di livello sotto forma di polilinee a spigoli

E' possibile smussare le curve di livello, e più in generale le polilinee, con il comando SMOOTHMPL. Questo comando asseconda le impostazioni fatte con il comando CURLIV_DAT.

.topic 19146

Disegnare le curve di livello per tre punti (caso di punti 2D + testo quota)

In questo caso si devono avere a video i punti anche con elevazione nulla e i testi delle quote di ciascun punto.
- Cliccare su CURLIV_DAT e nel riquadro Selezione punti scegliere - 2D + Testo

- Cliccare su CURLIV_T e specificare tre volte la sequenza:
Primo punto: 	selezionare punto a video
Selezionare il testo: 	selezionare il testo della quota
Secondo punto: 	selezionare punto a video
Selezionare il testo: 	selezionare il testo della quota
Terzo punto: 	selezionare punto a video
Selezionare il testo: 	selezionare il testo della quota
Ovviamente i tre punti devono individuare un triangolo!
A conclusione di questa sequenza si ottiene il disegno di linee di livello sulla falda individuata dai tre punti secondo le impostazioni di equidistanza e di colore effettuate con il comando CURLIV_DAT.

.topic 19147

Disegnare le curve di livello per tre punti (caso di punti 3D)

- Cliccare su R07,08C01 - CURLIV_DAT e nel riquadro Selezione punti scegliere 3D

- Cliccare su R07C03 - CURLIV_T e specificare tre  volte la sequenza:
Primo punto: 	selezionare punto a video
Secondo punto: 	selezionare punto a video
Terzo punto: 	selezionare punto a video
Ovviamente i tre punti devono individuare un triangolo e non essere allineati!
A conclusione di questa sequenza, come avviene nel caso precedente, si ottiene il disegno di linee di livello sulla falda individuata dai tre punti secondo le impostazioni di equidistanza e di colore effettuate con il comando R07,08C01 - CURLIV_DAT.

.topic 19148

Trasformare le curve di livello sotto forma di "Linea" in "Polilinea"

TOPak disegna le curve di livello in polilinee, tuttavia ci si può trovare nella situazione di avere dei rilievi costruiti con altri software che invece disegnano soltanto spezzate di livello con delle linee. TOPak è in grado di unire queste linee a formare delle polilinee con il comando MKP. Si sconsiglia di non selezionare insiemi troppo grandi di linee, per evitare durate eccessive del processo.

.topic 19149
Trasformare le curve di livello da Layered a 3D e viceversa

Il comando per eseguire questa trasformazione è LAY23DLAY.

.topic 19150

Disegnare le curve di livello partendo da un modello a falde triangolari

La procedura per ottenere il modello è già stata spiegata nelle pagine prededenti; in questo caso si presuppone di avere già il modello a falde triangolari in AutoCAD, dove le falde sono rappresentate con 3DFACCE oppure con 3DPOLI.
-	Cliccare su CURLIV_DAT per impostare la modalità di disegno delle linee di livello.
-	Cliccare su TRIGONCL Questo comando chiederà di selezionare i triangoli su cui tracciare le curve di livello.

.topic 19152

Come inserire le quote delle curve di livello

Per inserire le quote nelle cirve di livello si utilizza il comando CLOPER che si trova nella toolbar delle sezioni; il conando Cloper permette sia di ricavare i dati per generare le sezioni che per quotare le curve di livello.

.topic 19153

.topic 19154

Ricavare una sezione da una carta tecnica in formato raster

- Dalla barra degli strumenti Gestione Immagini Raster nel menu I&S CAD ->CADUtility ->Gestione Immagini,

utilizzare il comando IMAGEATTACH per inserire il raster nel disegno.
- Digitalizzare le linee di livello della zona/fascia di interesse con delle linee/polilinee 2D
- Assegnare la quota alle curve di livello digitalizzate con il comando EPM
- Tracciare la linea/polilinea di sezione in modo che intersechi le linee di livello digitalizzate
- Cliccare il bottone CLOPER

Copiare le impostazioni dalla figura
- Cliccare su OK, oppure lanciare il comando S2D per ottenere il disegno della sezione, premere sul bottone parametri per verificare la scala di rappresentazione prima di premere 	OK.

.topic 19155
Significato di Raster e Vettoriale

AutoCAD memorizza i suoi disegni scrivendo file contenenti le coordinate cartesiane delle varie entità, punti, linee, archi, cerchi con l'aggiunta delle caratteristiche quali il colore, il tipo di linea e altre informazioni numeriche e non; i disegni memorizzati in questo modo si dicono vettoriali.
Per fare un esempio una linea in AutoCAD è individuata attraverso le coordinate dei suoi vertici, con il suo colore ed il suo tipo di linea.
I disegni in formato Raster invece possono essere assimilati a dei mosaici formati da tessere colorate rettangolari o quadrate, più o meno grandi. Per ogni tessera sono memorizzate le informazioni relative alla posizione nel contesto del mosaico e del colore. Una linea in un file Raster è un insieme di tessere (pixel) più o meno allineate.
AutoCAD è un programma che tipicamente tratta disegni in formato vettoriale, ma, dalla versione 14, riesce anche ad importare nel disegno delle immagini Raster e fare degli interventi limitati su di esse. Notevole è la possibilità di stampare anche un'immagine mista raster/vettoriale; stampa ibrida. Questo è il caso ad esempio di una carta tecnica acquisita con lo scanner ed importata, dopo di che, su di essa, vengano inseriti dei retini in formato vettoriale; vedi carte geologiche, idrogeologiche e tematiche in generale.

.topic 19156
Sezioni del terreno sulle curve di livello layered, 2D ed anche 3D

Premessa.
Il comando S2D legge i numeri generatori da un file di testo e produce il disegno della sezione in AutoCAD.
La parte del file testo contenente i dati della sezione può essere in due diversi formati:

    (1° formato)
        N          DP          Q
        1	0.00	25.326
        2	25.326	28.326
        3	12.326	30.326
        4	10.547	29.326

    (2° formato)
        N              X                      Y                     Y
        1	-45.236		15.326		15.32
        2	-58.145		8.326		18.326
        3	-62.326		12.326		19.641
        4	-63.321		10.547		18.987

Dove:

    N	Nome del picchetto.
    DP	Distanza fra due picchetti consecutivi.
    Q	Quota del picchetto di destra.
    X	Coordinata X.
    Y	Coordinata Y.
    Z	Coordinata Z.

Esempio di file testo (CADPak usa l'estesione *.sez per questi file) con i dati nel primo formato n, dp, quota:
1000
Q = ,0.0, m s.l.m.,70,2,ISO,35,4,2
40,10,0,20,12100,20
Scala lunghezze 1:,200," ",100,20,ISO,35,5,0
Scala altezze 1:,100," ",100,30,ISO,35,5,0
1	0.00	25.326
2	25.326	28.326
3	12.326	30.326
4	10.547	29.326

Esempio di file testo (CADPak usa l'estesione *.sez per questi file) con i dati nel secondo formato n, x, y, z:

1000
Q = ,0.0, m s.l.m.,70,2,ISO,35,4,2
40,10,0,20,12
100,20
Scala lunghezze 1:,200," ",100,20,ISO,35,5,0
Scala altezze 1:,100," ",100,30,ISO,35,5,0
1	-45.236		15.326		15.32
2	-58.145		8.326		18.326
3	-62.326		12.326		19.641
4	-63.321		10.547		18.987

Per ottenere il disegno della sezione è necessario partire da un file dati in uno dei due formati possibili.
Trattandosi di un file ASCII, può essere prodotto con qualsiasi editor, oppure derivato da Excel.
Procedura.
-	Si parte dal presupposto che esistano a video le curve di livello in modalità layered e cioè che le curve di livello siano 2D oppure anche 3D ma soprattutto che rispondano alla codifica layered.
-	Se non fosse così (3D oppure 2D e layered), si può utilizzare il comando EPM per assegnare la quota.
-	Tracciare la linea (o una polilinea) di sezione in modo che essa intersechi le curve.
-	Lanciare il comando CLOPER che visualizzerà una finestra di dialogo nella quale si effettueranno le scelte mostrate nella figura seguente:

Dopo aver premuto OK, TOPak chiederà di selezionare la linea di sezione ed inizierà la ricerca di tutte le intersezioni fra questa e le linee di livello (soltanto quelle layered !!), elaborando automaticamente le eventuali interpolazioni necessarie sui vertici delle linee di sezione spezzate. Il risultato finale è la creazione di un file testo in cui le prime sei righe sono parametri (intestazione) e le rimanenti sono dati relativi alla sezione.
Nota: Le caselle Distanza ricerca e Suddivisioni sono dei parametri necessari per il calcolo delle interpolazioni, e per il loro significato si rimanda alla descrizione del comando CLOPER nella parte del manuale di TOPak in cui vengono descritti i comandi nel dettaglio.
-	Lanciare il comando S2D che disegna la sezione partendo dal file prodotto dal comando CLOPER. Verrà visualizzata una finestra di dialogo in cui si potrà scegliere il nome del file dati, il nome di un eventuale file testo con i dati di una sezione di progetto (vedi oltre) ed un file testo denominato File tabella che determina la fincatura. I bottoni Modifica... consentono di editare i files corrispondenti.

-	Cliccare OK e indicare con il mouse a TOPak dove si desidera la sezione nel disegno.

.topic 19157
Sezioni su curve di livello 3D e non layered

La sezione in questo caso va fatta selezionando gli oggetti 3D che intersecano la linea di sezione.

.topic 19158
Sezioni su curve di livello che tengano conto anche delle linee di vincolo (discontinuità e contorni)

Questo caso si presenta quando si devono sezionare, oltre le curve di livello, anche le linee di discontinuità che sono state utilizzate per sviluppare il modello a falde triangolari.

-	Quando le condizioni di base, cioè che gli oggetti da sezionare siano 3D, sono soddisfatte, si dovrà tracciare la linea di sezione avendo cura che essa non intersechi oggetti che non dovranno essere sezionati (linee di indicazione, simbolismi grafici, ecc.).
-	Lanciare il comando CLOPER

Il comando Cloper permette di ricavare in un file ASCII i dati della sezione semplicemente selezionando la linea di sezione.

-	Lanciare il comando S2D per ottenere il disegno della sezione in AutoCAD.

Nota importante:
Nella figura seguente le linee di livello sono di tipo layered e bidimensionali. In questa situazione non si possono ottenere sezioni con le quote dei cigli della strada (cioè le discontinuità) e con le quote del contorno esterno; pertanto si possono ottenere soltanto sezioni dove i picchetti rappresentano l'intersezione tra la linea di sezione e le curve di livello.

Per fare una sezione che intersechi sia le curve di livello che le linee di discontinuità ed i contorni occorre che anche le curve siano 3D; per trasformare le curve da layered+2D a layered+3D si può utilizzare il comando LAY23DLAY.

.topic 19159

Sezioni su modello a falde triangolari

Per ottenere la sezione sulle falde triangolari lanciare il comando CLOPER effettuare le impostazioni mostrate nella figura.

Lanciare poi il comando S2D per ottenere il disegno della sezione.

.topic 19160

Sezione su curve di livello prive di quota; non layered e non 3D.

In questo caso non sarebbe possibile ricavare le sezioni, non avendo l'informazione relativa a ciascuna curva di livello. Tuttavia è possibile con un comando assegnare la quota alle curve di livello: è sufficiente che esse siano delle linee/polilinee in AutoCAD.
Il comando è EPM e richiede la quota delle prima curva e l'equidistanza.

Si possono ottenere delle curve di tipo layered con le quali poi si possono ottenere le sezioni come descritto nelle pagine precedenti.

.topic 19162

Profilo o sezione lungo una polilinea 3D passante per i punti battuti

- Disegnare una Polilinea 3D passante per i punti battuti.
- Lanciare il comando CLOPER e copiare le impostazioni della figura seguente:

- Lanciare il comando S2D per ottenere il disegno della sezione.

Con quest'ultima operazione apparirà una finestra (come sopra) in cui impostare le opzioni come mostrato nella figura. Il file di intestazione può essere modificato dall'utente: per queste spiegazioni si rimanda la manuale di riferimento ai comandi.

.topic 19163

Profilo o sezione passante per i punti battuti (punti 2D con testo quota)

Ci si trova a seguire questa procedura quando i punti del piano quotato non sono tridimensionali, di conseguenza sorge il problema di ricavare la quota.
Se la quota dei punti è scritta sotto forma di testi accanto ai punti è possibile recuperarla al fine di produrre il profilo. L'obiettivo principale è produrre un file ASCII contenente le coordinate dei punti, in modo che poi questo sia trasformato nel disegno di un profilo con il comando S2D.

Per ricavare il file ASCII con le coordinate dei punti, si deve utilizzare il comando EXPDAT che visualizza la finestra di dialogo mostrata nella figura seguente.

.topic 19164

Sezioni passanti per i punti battuti, metodo di numerazione dei picchetti

La numerazione dei picchetti può avvenire:
- Automaticamente da un numero di partenza a scelta "m" con incremento "n"
- Manualmente, selezionando con il mouse i testi dei nomi nel disegno

.topic 19165
Sezione di progetto

Premessa.
Affinché il comando S2D riesca a disegnare il profilo di progetto assieme al profilo del terreno naturale si devono verificare le seguenti condizioni:
1.	Deve esistere un file testo con i dati del terreno naturale con relativa intestazione.
2.	Deve esistere un file testo con i dati della sezione di progetto (anche senza intestazione).
3.	La lunghezza (proiezione sull'asse delle distanze) delle due sezioni deve essere uguale.

Procedura.
Il punto di partenza è il disegno di una sezione del terreno naturale in AutoCAD; su questo disegno si traccia una polilinea che rappresenta la linea di progetto; eventualmente utilizzando il comando di PLINEA di AutoCAD oppure con il comando LINESLOPE di CADPak.
La lunghezza della proiezione orizzontale della sezione di progetto deve essere uguale a quella del terreno naturale (in caso contrario il programma dà un messaggio d'errore).

- Il punto 1. della premessa appena fatta dovrebbe essere già soddisfatto, infatti la sezione del terreno naturale è già stata prodotta e per produrla si è dovuto partire da un file di testo (ASCII) con Intestazione e dati come il seguente:

1000,3
"Q = ",0.0,"m.s.l.m.",70,2,ISO,35,4,2
40,10,0,20,12
100,20
"Scala lunghezze 1:",100," ",100,20,ISO,35,5,0
"Scala altezze 1:",100," ",100,30,ISO,35,5,0
1	0.0000	3.5000
2	1.4443	3.0000
3	1.6630	3.5000
4	1.5706	2.0000
5	1.5706	1.5000
6	0.9459	1.0000
7	2.7184	0.5000
8	4.0555	0.0000
9	4.5715	-0.5000
10	3.1383	-1.0000
11	20.1641	-1.5000

- Il punto 2. consiste nel generare il file con i dati della sezione di progetto partendo dalla "polilinea progettata" dall'utente; per raggiungere questo obiettivo si deve utilizzare il comando OUT_DAT.

Questo file è scritto nella forma: Num. Picchetto – Dist.Parziale – Quota.
Esempio:

1 	0.0000 	2.3741
2 	8.8154 	1.5236
3	 7.4334 	0.5598
4 	9.6465	-0.7442
5 	11.689 	-1.1411
6 	4.2576	-1.5000

- Per quanto riguarda la condizione di cui al punto 3. è controllata automaticamente dal programma.
La sezione basata su questi due file di esempio è:

.topic 19166

Modificare i parametri di disegno della sezione; Scala, Quota base etc.

Per modificare i parametri della sezione occorre intervenire sui dati che l'hanno generata; la sezione non viene aggiornata nel disegno ma deve essere inserita ex-novo nel disegno.
Per modificare i parametri si può utilizzare il comando MODDT oppure nella finestra di dialogo visualizzata dal comando S2D si può premere il bottone Modifica come mostrato nella figura.

.topic 19167

Importare una tabella di coordinate nel disegno

Il comando TEXTIMP, permette di inserire un file ASCII qualsiasi nel disegno; chiede di selezionare il nome di un file e poi, dopo il settaggio di alcuni parametri inserisce i testi nel disegno.

.topic 19168
Trasformare una polilinea in un disegno di una sezione

Si parte da una polilinea disegnata in AutoCAD e che rappresenta una linea di sezione

- Si disegna la polilinea che deve essere trasformata in una sezione
- Si disegna l'origine come mostrato nella figura
- Si lancia il comando OUT_DAT e si fanno le impostazioni come nella figura

Quando si preme OK, CADPak chiede di indicare il punto di inizio, cioè l'origine indicata nella figura e poi di selezionare la polilinea che rappresenta la sezione
- Si lancia il comando S2D e dopo aver modificato eventualmente i valori di scala o altro si preme OK